IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 1 reply
  • Latest Post - ‏2012-10-15T20:17:33Z by JAntley
Dr_Nino
Dr_Nino
1 Post

Pinned topic PLS extension for SPSS 20.0 for Mac

‏2012-10-14T14:02:03Z |
Dear all,

I tried to use PLS extension for SPSS 20.0 for Mac (OS X 10.5.8). It is really strange, how difficult it is to use the PLS extension. However, as required, I performed, as followed:
1. Download "Python 2.7"
2. Download "SPSSStatisticsEssentialsForPython_20.0.0.1_Mac"
3. Download the PLS extension
4. Added "PLS.py" and "plscommand.xml" to the folder "extensions"
5. Download SciPy and Numpy (for Nump I couldn't find a MAc version, so I had to download a win version)

When I choose PLS in the SPSS 20.0 software it is only mentioned that I should download the extension file and this is, what I get, when I start "IDLE":

  1. history
  2. 07-apr-2010 workaround pivot table bug when single column
  3. 02-mar-2011 try even harder to find the scipy cg function
  4. 04-mar-2011 Expose warning messages from UNIANOVA block

  1. copyright(c) SPSS Inc, 2007

import spss, re
from random import uniform

try:
import spssaux, spssdata, extension
except:
print """This module requires the spssaux, spssdata, namedtuple and extension modules from
SPSS Developer Central, www.spss.com/devcentral. One or more was not found.
Please download these and try again"""
raise ImportError
if int(spssaux.__version__[0]) < 2 or int(spssdata.__version__[0]) < 2:
print """This module requires at least version 2.0.0 of spssaux and spssdata. Please download a newer version from SPSS Developer Central"""
raise ImportError
#if int(extension.__version__[0]) < 1 or (int(extension.__version__[0]) == 1 and int(extension.__version__[2]) < 1):
  1. print """This module requires at least version 1.1.0 of spssaux and spssdata. Please download a newer version from SPSS Developer Central"""
  2. raise ImportError
if < 1,1,0:
print """This module requires at least version 1.1.0 of extension.py. Please download a newer version from SPSS Developer Central"""
raise ImportError
from extension import Syntax, Template

if spssaux.GetSPSSMajorVersion() < 16:
raise ImportError, "This module requires at least SPSS 16"

Any advice? What be very much appreciated, many thanks!
Updated on 2012-10-15T20:17:33Z at 2012-10-15T20:17:33Z by JAntley
  • JAntley
    JAntley
    125 Posts

    Re: PLS extension for SPSS 20.0 for Mac

    ‏2012-10-15T20:17:33Z  
    Hello Dr Nino,

    The forum where you have posted your questions is primarily for those who have questions about using the developerWorks site itself. There are several active forums for IBM SPSS on developerWorks (http://www.ibm.com/developerworks/forums/category.jspa?categoryID=302); you would have a better chance of getting the answers you want if you were to post in one of them.

    Let us know if we can be of additional assistance.

    Regards,
    Jeff Antley
    developerWorks Feedback Team