Topic
  • 4 replies
  • Latest Post - ‏2012-10-30T14:20:29Z by dlaboss
SystemAdmin
SystemAdmin
1245 Posts

Pinned topic Xterm error: Starting PE

‏2012-10-13T09:29:34Z |
Hey,

when I try to start a SPL as a Distributed Program my PEs are Partially unhealthy.

With: streamtool viewlog --which console --pe-id --print
I get this error: xterm Xt erro: Can't open display: frei68:1.0

my /etc/hosts:
127.0.0.1 localhost.localdomain localhost
134.106.56.68 frei68 frei68.offis.uni-oldenburg.de

In sshd_config I enabled X11Forwarding.

I tried some different parameters for streams::pe.display in Streams studio, like localhost:0.0, 0.0 ...

Do you know why it is working? What do I have to do? I think this is the reason why my PEs wont start at all. Standalone mode is working btw.
Thanks in advice!

Best Regards,
Mischa
  • Kevin_Foster
    Kevin_Foster
    98 Posts

    Re: Xterm error: Starting PE

    ‏2012-10-13T18:24:04Z  
    I don't know X11, but as a suggestion before someone else answers on that question....

    Maybe you could log into the frei68 machine and issue this command:

    streamtool lspes -i yourinstancename

    as that should give you all of the health information on all of your running PE's.

    -Kevin
  • SystemAdmin
    SystemAdmin
    1245 Posts

    Re: Xterm error: Starting PE

    ‏2012-10-13T20:20:24Z  
    I don't know X11, but as a suggestion before someone else answers on that question....

    Maybe you could log into the frei68 machine and issue this command:

    streamtool lspes -i yourinstancename

    as that should give you all of the health information on all of your running PE's.

    -Kevin
    Thanks, maybe it is helpful :)
    
    Id State      RC Healthy Host         PID JobId JobName                           Operators 0 Starting    - no      frei68         0     0 applicationTest::AliseProcessing  Input 1 Starting    - no      frei68         0     0 applicationTest::AliseProcessing  InputGPS 2 Starting    - no      frei68         0     0 applicationTest::AliseProcessing  TimeFunc 3 Starting    - no      frei68         0     0 applicationTest::AliseProcessing  WriteTcp 4 Starting    - no      frei68         0     0 applicationTest::AliseProcessing  WriteGPSTcp
    
  • SystemAdmin
    SystemAdmin
    1245 Posts

    Re: Xterm error: Starting PE

    ‏2012-10-26T13:07:32Z  
    I usually access the log files directly within the terminal. Look in
    
    /tmp/streams.<instanceID>/logs/ 
    
    for the service logs for the instance and in
    
    /tmp/streams.<instanceID>/jobs/ 
    
    for the PE logs for the submitted jobs.
  • dlaboss
    dlaboss
    46 Posts

    Re: Xterm error: Starting PE

    ‏2012-10-30T14:20:29Z  
    Caveat: I'm not an X11/ssh expert.

    Streams uses SSH for various Streams administrative operations (e.g., starting and stopping a Streams instance). However, Streams doesn't maintain any sort of open SSH session to Streams hosts and SSH doesn't come into play at all when submitting/launching Streams applications.

    Other than conveying the display value to use to the PEs (setting their DISPLAY ev), Streams is completely out of the loop with respect to the X11 connection. So you can also test your display value / setup with just X11. e.g., I'd expect the following to experience the same behavior:

    On the host where you're running Streams Studio...
    $ ssh frei68 # run the following cmd on frei68
    $ DISPLAY=frei68:1.0 xterm # expected to fail based on your earlier info

    What host are you running Streams Studio on and what's the DISPLAY ev value in the shell where you started Streams Studio?

    That DISPLAY value is generally the same value that you want to be given to the PEs to use, via the streams::pe.display submission parameter -- which defaults to using the submitter's DISPLAY value if the param isn't explicitly overridden.

    The hosts where the PEs are running need to be able to resolve whatever hostname is specified in that value. And the PE's hosts need to have permission to connect to the Xserver. See xhost / maybe try "xhost +" from the host where you're running Streams Studio.

    Hope this helps.
    Dale