Topic
4 replies Latest Post - ‏2012-11-05T21:55:16Z by RandyJ.Miller
RandyJ.Miller
RandyJ.Miller
12 Posts
ACCEPTED ANSWER

Pinned topic Restore database fails in Data Studio 3.1.1 - connectivity library error

‏2012-10-12T22:00:45Z |
I am trying to exceute a database restore built with Full Client Data Studio 3.1.1 on a Windows 2008 R2 SP1 server running LUW 9.7 and I am getting the following error:

RESTORE DATABASE xxxDEV FROM "E:\Backups\backup.1" TAKEN AT 20121011180131 WITHOUT PROMPTING

The connectivity libraries that are needed for local or remote non-JDBC operations were not found. To provide these libraries, you can install IBM Data Server Client or a local DB2 database server instance.

Can anyone tell me what this means and how to resolve the issue?

Data Studio 3.1.1 and DB2 LUW 9.7 are on the same server, so there is no remote connection. CYGWIN is installed on the server for Data Studio Web Console.

I certainly have a local DB2 database server, since Data Studio is connecting to it to lead me through the build instructions for the restore. I am able to see and connect to the databases with Data Studio, but it looks like the execution of the command can't figure out where it is.

I am verifying utility handling through Data Studio in order to migrate to LUW 10.1 where Contol Center is discontinued.

Thanks,
RJM
Updated on 2012-11-05T21:55:16Z at 2012-11-05T21:55:16Z by RandyJ.Miller
  • loicjulien
    loicjulien
    96 Posts
    ACCEPTED ANSWER

    Re: Restore database fails in Data Studio 3.1.1 - connectivity library error

    ‏2012-10-12T22:35:10Z  in response to RandyJ.Miller
    Hi Randy,

    Could it be that Data Studio is the 32 bits installation but the DB2 LUW 9.7 locally installed is the 64 bits installation?

    When executing locally (using DAS on windows), we do leverage some DDLs from the DB2 client that need to be compatible with the Data Studio client.

    The next version of Data Studio will support 64 bits.

    Let me know if this could explain the behavior you are experiencing.

    Thanks,
    ~Loic
    • RandyJ.Miller
      RandyJ.Miller
      12 Posts
      ACCEPTED ANSWER

      Re: Restore database fails in Data Studio 3.1.1 - connectivity library error

      ‏2012-10-12T23:03:24Z  in response to loicjulien
      It certainly is true that Data Sudio 3.1.1 is a 32-bit process and it is running on a 64-bit server, so if that would create an issue, that may be the explanation.

      But, color me stunned! LUW 10.1 requires a 64-bit Operating system, so I am disappointed that IBM would not have had a 64-bit version of Data Studio ready before completely discontinuing Control Center.

      Is there a release data for the 64-bit version of Data Studio?

      Thanks,
      RJM
      • loicjulien
        loicjulien
        96 Posts
        ACCEPTED ANSWER

        Re: Restore database fails in Data Studio 3.1.1 - connectivity library error

        ‏2012-10-12T23:54:10Z  in response to RandyJ.Miller
        Hi Randy,

        Thanks for your reply.

        I would just like to further clarify, for people reading this post, that some 32-bit Windows Workstations or Server platforms configurations are supported, as detailed here:
        http://pic.dhe.ibm.com/infocenter/db2luw/v10r1/index.jsp?topic=%2Fcom.ibm.db2.luw.qb.server.doc%2Fdoc%2Fr0025127.html

        My current experience on Windows 7 64-bit is that I am able to install the 32-bit package of LUW 10.1 without any issue. Unfortunately, I do not have Windows 2008 R2 to quickly validate the configuration.

        Would you mind please contacting me directly at "lj *at* us.ibm.com" so that I can connect you with the right people who may be able to provide you with more information.

        Thanks,
        ~Loic
        • RandyJ.Miller
          RandyJ.Miller
          12 Posts
          ACCEPTED ANSWER

          Re: Restore database fails in Data Studio 3.1.1 - connectivity library error

          ‏2012-11-05T21:55:16Z  in response to loicjulien
          There was an issue with 32-bit connectivity that was corrected in Fix Pack 4. I have applied Fix Pack 7 and Data Studio is now performing the RESTORE correctly.

          I still have a similar issue when running programs in Windows Compatibility mode (using compatibility with Windows Server 2003 where the programs function properly) which I have referred to the LUW developerWorks forum.

          RJM