Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
No replies
mhein
mhein
1 Post
ACCEPTED ANSWER

Pinned topic Personalization Components in Virtual Portal

‏2012-10-12T15:45:31Z |
Hi All,

I'm running Portal 8 (wp800_404_01) on Red Hat and am having a bit of an issue with my personalization components.

  • my portal is a virtual portal, call it 'CIM'
  • because we need to use personalization rules, the library containing the content is in the root portal, called 'CIM' as well
  • select rules are created and returning content
  • in the virtual portal we are using JSR286 Web Content Viewer portlet to display a personalization component
  • this portlet appears to only have access to a library in the VP, so i have added a new library 'CIM (VP)' to hold these components
  • components are personalization components, referencing the aformentioned rules

So I have a page on a virtual portal, showing a personalization component which references a select rule that returns content from a library in the root portal
The results:

The personalization component does display,and brings back the right content, but only Placeholder and Property tags seem to work in the element design. Element tags, which work if i do all of this in the root portal, do not work here.

I see that there is a fix in the list for Combined Cumulative Fix 02 (Specifically PM71374) that may address this. I have to wait a bit for my support team to apply the fix pack.

In the meantime, can anyone see a mistake I'm making? Have done a lot of searching around and can't find much information out there. Appreciate any help anyone can offer!
Thanks,

Mark