Topic
  • 5 replies
  • Latest Post - ‏2012-10-15T19:36:00Z by SystemAdmin
SystemAdmin
SystemAdmin
445 Posts

Pinned topic Cannot view a CMOD repository in Content Navigator

‏2012-10-11T17:52:51Z |
I have Content Navigator running on a 64 bit win 2008 server. On the same machine is CMOD. The Navigator admin section works, I can attach a repository to a desktop. I can log into the repository. I know CMOD is working becuase I'm able to load documents and see that the documents have been loaded.

When I open the desktop the repository icon on left nav. cannot be selected.

Besides the error below I notice no other errors in the log:

10/11/12 12:38:45:530 GMT-05:00 0000001c SystemOut O 10/11/12 12:38:45:530 GMT-05:00 00000047 SystemOut O CIWEB Debug: unknown @ unknown com.ibm.ecm.configuration.DatabaseConfiguration.getProperty() key = interfaceTextLocale.navigator.app_repository return empty result back. Make sure Grant SQL has been run if value is expected
  • KristinWallio
    KristinWallio
    42 Posts

    Re: Cannot view a CMOD repository in Content Navigator

    ‏2012-10-11T22:29:44Z  
    I'm not sure that I fully follow your scenario. The steps you list seem to indicate that from admin you have:
    1) Created a new CMOD repository and saved it without error
    2) Created a desktop, assigned the CMOD repository to it, and saved it without error.
    3) signed in to the new desktop and attempted to display the CMOD repository in the search view.
    Is this correct?

    The reason I'm clarifying is that the error you post seems to indicate that the administrative database was not updated using the steps under the topic "Running the script to configure your database for IBM Content Navigator".
    http://publib.boulder.ibm.com/infocenter/cmgmt/v8r4m0/index.jsp?topic=%2Fcom.ibm.installingeuc.doc%2Feucdb000.htm
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: Cannot view a CMOD repository in Content Navigator

    ‏2012-10-12T14:24:56Z  
    I'm not sure that I fully follow your scenario. The steps you list seem to indicate that from admin you have:
    1) Created a new CMOD repository and saved it without error
    2) Created a desktop, assigned the CMOD repository to it, and saved it without error.
    3) signed in to the new desktop and attempted to display the CMOD repository in the search view.
    Is this correct?

    The reason I'm clarifying is that the error you post seems to indicate that the administrative database was not updated using the steps under the topic "Running the script to configure your database for IBM Content Navigator".
    http://publib.boulder.ibm.com/infocenter/cmgmt/v8r4m0/index.jsp?topic=%2Fcom.ibm.installingeuc.doc%2Feucdb000.htm
    Yes to all three statements you listed. When I define a repository, a username password screen is presented. In this screen I enter the CMOD username and password without error.

    attached is a screen shot of the Admin view
  • KristinWallio
    KristinWallio
    42 Posts

    Re: Cannot view a CMOD repository in Content Navigator

    ‏2012-10-13T00:23:52Z  
    Yes to all three statements you listed. When I define a repository, a username password screen is presented. In this screen I enter the CMOD username and password without error.

    attached is a screen shot of the Admin view
    Is this an CMOD only configuration (no P8 Content Engine, no Content Manager repositories)? For clarity, would you be able to provide a screenshot of the page where you are attempting to get to a CMOD repository?
  • MikeAA
    MikeAA
    6 Posts

    Re: Cannot view a CMOD repository in Content Navigator

    ‏2012-10-15T16:23:45Z  
    When defining a desktop for CMOD - only the "Search" feature is available. When creating a new desktop the selected features are "Favorites", "Browse" and "Search" with "Favorites" selected as the default feature. The only feature supported on CMOD is "Search". Did you remove "Favorites" and "Browse" from the selected features and make "Search" the default ? See attachment with defaults.
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: Cannot view a CMOD repository in Content Navigator

    ‏2012-10-15T19:36:00Z  
    • MikeAA
    • ‏2012-10-15T16:23:45Z
    When defining a desktop for CMOD - only the "Search" feature is available. When creating a new desktop the selected features are "Favorites", "Browse" and "Search" with "Favorites" selected as the default feature. The only feature supported on CMOD is "Search". Did you remove "Favorites" and "Browse" from the selected features and make "Search" the default ? See attachment with defaults.
    Thanks. I can know search for applications and application groups. How would I get a list of documents? When I loaded the AFP file, I used ACIF. ACIF indexed based on TLE's. Can I search for a specific TLE and get a document back? FOr example I want to see a certain invoice with a specific account number?