Topic
  • 5 replies
  • Latest Post - ‏2012-10-10T20:45:52Z by Lee Wei
SystemAdmin
SystemAdmin
104 Posts

Pinned topic Excel Connector Returns Erroneous Data

‏2012-10-09T20:50:35Z |
It has been brought to my attention that a report I generate weekly
from the TEM Excel Connector contains a few lines of incorrect data.

The report simply returns the values of the "Microsoft SQL Server and
Client Tools Version Detection" analysis (Analysis #54) from the BES
Inventory and License site. I submit this report weekly to our SQL
DBAs.

When I run the report from the Excel connector for whatever reason I
get values for servers that do not have the specified SQL components
that are stated in the report. When I look at the analysis in the
console or view a report from WebReports I do not see this data.
Basically, I do not know where this data is coming from.

Is the data old data that needs to be cleaned out of the database?
Having this is putting in question the integrity of any report run via
the Excel connector.

Any ideas?
  • Lee Wei
    Lee Wei
    21 Posts

    Re: Excel Connector Returns Erroneous Data

    ‏2012-10-09T21:20:28Z  
    Hi Andrew,

    Sorry to hear of the problem.
    I tried to call you to help but could not get through to x28107.
    You can send me your contact info to leewei at us.ibm.com.

    In the meantime, there is a "Show Relevance Code" button in the Excel Connector menu.
    You can copy the statement and run it separately outside of the Excel Connector to double-check on the data being returned.
    The best place to test the Session Relevance statement is:
    http://web_reports_server:port/webreports?page=QNA

    Lee Wei
  • Lee Wei
    Lee Wei
    21 Posts

    Re: Excel Connector Returns Erroneous Data

    ‏2012-10-10T19:29:09Z  
    We determined that Web Reports is incorrectly reporting data when the endpoints are no longer relevant to an Analysis.
    This symptom is similar to bug# 41728 titled, "Analysis results appear for computers which are no longer reporting values when an analysis property column added to Explore Computers"

    Lee Wei
  • SystemAdmin
    SystemAdmin
    104 Posts

    Re: Excel Connector Returns Erroneous Data

    ‏2012-10-10T19:33:35Z  
    Thank you, is there an ETA on the bug already reported?
  • Lee Wei
    Lee Wei
    21 Posts

    Re: Excel Connector Returns Erroneous Data

    ‏2012-10-10T20:26:16Z  
    Thank you, is there an ETA on the bug already reported?
    I did not see an estimated fix date, but I have updated the report to include our information and requested an increase in priority.

    Lee Wei
  • Lee Wei
    Lee Wei
    21 Posts

    Re: Excel Connector Returns Erroneous Data

    ‏2012-10-10T20:45:52Z  
    • Lee Wei
    • ‏2012-10-10T20:26:16Z
    I did not see an estimated fix date, but I have updated the report to include our information and requested an increase in priority.

    Lee Wei
    For the record, this is also tracked as bug# 49883 "Web Reports still showing results for non-relevant properties" and it is scheduled to be fixed in the next major release of TEM, presumably "version 9.0" often referred to as "Gilman" and tentatively scheduled for 1H 2013.

    Lee Wei