Topic
  • 5 replies
  • Latest Post - ‏2013-01-24T08:04:23Z by SystemAdmin
boniprasad
boniprasad
2 Posts

Pinned topic Different PVID showing for same disk in vios comparing with one of the lpar

‏2012-10-09T16:58:57Z |
Hi
Here my problem is for the same disk the PVID is showing different,
In vios
lspv
hdisk0 00f624de7c594a49 None
hdisk1 00f624de3beebccc None
hdisk2 00f624dea8a6b18c rootvg active
hdisk3 00f624dea88c08d1 None
hdisk4 00f624dea88c3f87 None
hdisk5 00f624dea88ca448 None
hdisk6 00f624de2bbdbdcb None
hdisk7 00f624de2bbe2599 None
hdisk8 00f624de3f2384df None

on LPAR it is showing different
i am reading hdisk5
hdisk0 00f624de01685f31 rootvg active

what i have to do?
thank you
Updated on 2013-01-24T08:04:23Z at 2013-01-24T08:04:23Z by SystemAdmin
  • aix91246
    aix91246
    2 Posts

    Re: Different PVID showing for same disk in vios comparing with one of the lpar

    ‏2012-10-10T20:05:42Z  
    run cfgdev or cfgmgr in the vios.
  • SystemAdmin
    SystemAdmin
    1743 Posts

    Re: Different PVID showing for same disk in vios comparing with one of the lpar

    ‏2012-10-11T13:20:53Z  
    It depends on how your storage is configured on your VIOS. Most non-UDID disk storage multipathing software products use the PVID method instead of the UDID method. If this is the case then there will be a difference in the data format and placement associated with you LUNs. If I recall it's 0x200. All the major storage vendors support the UDID implementation. What type of storage is connected to your VIOS and what multipathing software are you using?
  • boniprasad
    boniprasad
    2 Posts

    Re: Different PVID showing for same disk in vios comparing with one of the lpar

    ‏2012-10-14T11:47:51Z  
    • aix91246
    • ‏2012-10-10T20:05:42Z
    run cfgdev or cfgmgr in the vios.
    If we run cfgdev or cfgmgr it will effect the existing configuration?
    and if the PVID is mismatching it will effect the Lpar?because now the LPAR is working fine.
    but in vios its showing different PVID and in that particular LPAR its showing different for the same disk.
    may b in future we will get any issue?once restarting the LPAR.
    plz let me know.
    Sorry if the questions are not sensible .i am new to this environment.

    thank you
  • teletype
    teletype
    3 Posts

    Re: Different PVID showing for same disk in vios comparing with one of the lpar

    ‏2012-10-31T13:05:22Z  
    To the best of my knowledge there is no problem. I don't know how you got the pvid's on your disk in the vio (may you build a volume group on them before). But if the vio is passing on a whole disk to a client it uses the the first few bytes (512?) for its administration. So I think you should see a different pvid in your lpar.
    At the moment I cannot look at a vio server. But I don't recollect seeing any pvid's there.

    Again to the best of my knowledge
  • SystemAdmin
    SystemAdmin
    1743 Posts

    Re: Different PVID showing for same disk in vios comparing with one of the lpar

    ‏2013-01-24T08:04:23Z  
    I have 2 VIO servers.
    And when I attach new disks I do:
    1. present disk to one vio
    2. run chdev -l hdiskX -a pv=yes
    3. present disk to second vio
    4. run chdev -l hdiskX -a pv=yes
    now you should have same pvid on both vio servers.
    5. now when you map the disk to the client, the pvid remains the same

    Make sure to run chdev before you map the disk to the client!