Topic
  • 2 replies
  • Latest Post - ‏2012-10-11T17:38:59Z by sathyaram_s
sathyaram_s
sathyaram_s
2 Posts

Pinned topic Repository admin user password change

‏2012-10-09T13:21:52Z |
OPM 5.1.1 on AIX monitoring 9.7 database

We had to change the repository admin user's( the db2 instance owner in this case) password.

I was unable to start opm, and found this page describing how to update the password.

http://publib.boulder.ibm.com/infocenter/perfmgmt/v5r1/topic/com.ibm.datatools.web.admin.access.doc/topics/def_admin_user.html
I get an error ..

/opt/IBM/OPM/bin/setupcredentials.sh -updateUser db2inst1 ibmdb2new
09-Oct-2012 14:12:52 zero.core.security.userservice.UserServiceCommand executeCommand
SEVERE: CWPZC2118I: The password of the user 'db2inst1' was not updated.

sslconfig file created: /opt/IBM/OPM/zero/dsweb/config/ssl.config
Generating 2,048 bit RSA key pair and self-signed certificate (SHA256WithRSA)
for: CN=IBM_dsserver, OU=IBM, O=IBM, L=IBM, ST=IBM, C=IBM
http://Storing /opt/IBM/OPM/zero/dsweb/config/key.jks
I then used updatemetadb.sh successfully.

OPMstart worked then and the monitoring data collection started.

But when using the browser console, I get an error message.

The message in the

2012-10-09 14:16:59,764 Thread-57 com.ibm.datatools.perf.repository.RsApiTracer - TIME : 2012-10-09T14:16:59.763+0100 IMPACT : Critical
ACTION : CONNECT OBJECT : DataBase OBJINFO : "FATAL :: com.ibm.datatools.perf.repository.api.config.impl.RSProfileService :: Exception thrown after RSProfileServiceOuter invocation of: public abstract com.ibm.datatools.perf.repository.api.profile.IManagedDatabase com.ibm.datatools.perf.repository.api.profile.IBasicProfileService.retrieveManagedDatabase(java.lang.String), with args: SAMPLE, thrown exception: CDPMA1109E A connection to the repository database failed.
ExplanationMessage = You cannot proceed without a connection to the repository database.
Details for SQLException: Credentials valid flag set to false so did not attempt to connect, SQLState=<null>, ErrorCode=<0>.
UserResponse = Review the trace files to find the cause of the problem. Check the repository console and log files and trace files for more information in case the problem is also at the repository server.
msgArguments=[], stack=[com.ibm.datatools.perf.repository.api.config.impl.SqlCommons.getConnectionFromService(SqlCommons.java:720), com.ibm.datatools.perf.repository.api.config.impl.SqlCommons.createNonexclusiveConnectionToPerfdb(SqlCommons.java:338), com.ibm.datatools.perf.repository.api.config.impl.RSCompatibilityChecker.assertPrivilegeAndCompatibility(RSCompatibi
How do I update the password ?

Thanks in advance for the guidance.
Sathyaram
Updated on 2012-10-11T17:38:59Z at 2012-10-11T17:38:59Z by sathyaram_s
  • UteBaumbach
    UteBaumbach
    55 Posts

    Re: Repository admin user password change

    ‏2012-10-10T18:56:50Z  
    Hi,
    after you have logged in to the Web UI use the 'Open' menu to select the 'Product Setup -> Configuration Repository' page. On that page enter the new password and test the connection. Then log out and log back in.
    Does it work then or do you still get the error message ?

    Regards
    Ute Baumbach
  • sathyaram_s
    sathyaram_s
    2 Posts

    Re: Repository admin user password change

    ‏2012-10-11T17:38:59Z  
    Hi,
    after you have logged in to the Web UI use the 'Open' menu to select the 'Product Setup -> Configuration Repository' page. On that page enter the new password and test the connection. Then log out and log back in.
    Does it work then or do you still get the error message ?

    Regards
    Ute Baumbach
    Hi Ute,
    That works.Thanks for your help.

    Sathyaram