Topic
  • 2 replies
  • Latest Post - ‏2012-10-09T08:49:42Z by SystemAdmin
SystemAdmin
SystemAdmin
603 Posts

Pinned topic can't run demo applications: error in opening zip file

‏2012-10-08T13:33:47Z |
Hello,
I've installed BigInsights Enterprise 1.4 as a single node installation on my machine (CentOS 6.3, 64 bit), but can't run demo applications.
I go to the "Applications" tab and click on "Word Count" application, then fill the form, but when i click on deploy, it says:

Unable to deploy the application.
REASON: java.util.zip.ZipException: error in opening zip file

and the same happens with all of the other applications.
In the log biginsightsconsole.log I see the exception stack:

java.util.zip.ZipException: error in opening zip file
at java.util.zip.ZipFile.open(Native Method)
at java.util.zip.ZipFile.<init>(ZipFile.java:150)
at java.util.zip.ZipFile.<init>(ZipFile.java:111)
at com.ibm.biginsights.web.applicationmanagement.beans.AppPalette.deployApplication(AppPalette.java:689)
at com.ibm.biginsights.web.applicationmanagement.action.ApplicationManagementAction.perform(ApplicationManagementAction.java:132)
at com.ibm.biginsights.webapp.actions.Action.doAction(Action.java:75)
at com.ibm.biginsights.webapp.ControllerServlet.helper(ControllerServlet.java:49)
at com.ibm.biginsights.webapp.ControllerServlet.doGet(ControllerServlet.java:78)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:707)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180)
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:126)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:68)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.eclipse.equinox.servletbridge.BridgeServlet.service(BridgeServlet.java:120)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.geronimo.tomcat.valve.DefaultSubjectValve.invoke(DefaultSubjectValve.java:56)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:563)
at org.apache.geronimo.tomcat.GeronimoStandardContext$SystemMethodValve.invoke(GeronimoStandardContext.java:406)
at org.apache.geronimo.tomcat.valve.GeronimoBeforeAfterValve.invoke(GeronimoBeforeAfterValve.java:47)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
at org.apache.geronimo.tomcat.valve.ThreadCleanerValve.invoke(ThreadCleanerValve.java:40)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
at java.lang.Thread.run(Thread.java:736)

How can I fix it?
Moreover, I can't figure out how to configure the execution of the Word Count application from Eclipse. I import the project from the web console, then publish the application using the workflow file found in the project, but when I run it the application gets killed since the output folder is not defined in JobConf, and in fact it didn't asked me about input and output paths.

Cheers,
Jacopo
Updated on 2012-10-09T08:49:42Z at 2012-10-09T08:49:42Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: can't run demo applications: error in opening zip file

    ‏2012-10-08T17:18:23Z  
    Hi Jacopo,

    First, please check the install log and and see if there were any errors reported during the installation of the product.

    If you find any error in the install.log, please paste here, and we can take a look.

    If no errors, still let us know and I can check what this error may mean.

    Please note that CentOS is not supported officially.

    http://pic.dhe.ibm.com/infocenter/bigins/v1r4/topic/com.ibm.swg.im.infosphere.biginsights.install.doc/doc/c0057608.html

    But at this point, I can't tell for sure if this issue due to CentOS or not.

    Thanks,

    Zach
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: can't run demo applications: error in opening zip file

    ‏2012-10-09T08:49:42Z  
    Hi Jacopo,

    First, please check the install log and and see if there were any errors reported during the installation of the product.

    If you find any error in the install.log, please paste here, and we can take a look.

    If no errors, still let us know and I can check what this error may mean.

    Please note that CentOS is not supported officially.

    http://pic.dhe.ibm.com/infocenter/bigins/v1r4/topic/com.ibm.swg.im.infosphere.biginsights.install.doc/doc/c0057608.html

    But at this point, I can't tell for sure if this issue due to CentOS or not.

    Thanks,

    Zach
    Today I tried again and it worked without problems. The installation log (attached) seems perfect.
    Thanks,
    Jacopo