Topic
14 replies Latest Post - ‏2013-02-08T13:44:54Z by SystemAdmin
RaviTamada
RaviTamada
29 Posts
ACCEPTED ANSWER

Pinned topic 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

‏2012-10-08T11:25:31Z |
Hi IBM Worklight Team,

I am trying to test the features of 'IBM Worklight V5.0 - Application Center'.
Based on the document 'wl_5_0_app_center.pdf' provided by Worklight, i have configured Application Center
in Tomcat7.0 with Derby as database & configured 'appcenteradmin/admin' as appcenter username & password.
Application Center is up & running and i have deployed one sample Android App and also deployed
'IBM App Center' client app to the app center. But i am not able to download this client application to andriod
device. Initially its asking for username & password. I have entred 'appcenteradmin/admin' as username & password. But still i am not able to download the app to Andriod device. What could be the problum?
Can you help me in resolving this issue?

Ravi Tamada
  • MichaelOrtman
    MichaelOrtman
    35 Posts
    ACCEPTED ANSWER

    Re: 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

    ‏2012-10-08T16:56:04Z  in response to RaviTamada
    Have you tried enabling unknown sources to install apps on android?

    From the following: http://droidlessons.com/how-to-install-non-market-third-party-apps-on-android/

    Step 1: Click the MENU button
    Step 2: Go to SETTINGS
    Step 3: Click on APPLICATIONS
    Step 4: Make sure that “UNKNOWN SOURCES” is checked
    Step 5: Read the warning message and acknowledge if you are OK to proceed with the changes

    Is the download starting or throwing an error?
    • RaviTamada
      RaviTamada
      29 Posts
      ACCEPTED ANSWER

      Re: 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

      ‏2012-10-09T11:58:24Z  in response to MichaelOrtman
      Hi IBM Worklight Support Team,

      Thanks for your reply. I tried this option also. But not working.
      App download page itself is not comming up in device.
      What are the other points that i need to check. Thanks.

      Ravi Tamada
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

    ‏2012-10-09T14:35:44Z  in response to RaviTamada
    Hello Ravi,

    If i understand correctly, you are trying to install the application center mobile client on an Android device.
    If this is correct, you can install the mobile client Over The Air when the the application center server is up by browsing the following address:

    http://hostname:portnumber/applicationcenter/installers.html

    This should drive you to a page that will ask you the credentials you set. After you log in, the page should show you a list of applications marked as installers and among them, the application center client installer.

    At this stage, taping the installer row in the page should start the application center client installation process on your device.

    If i did misunderstand your question, could you please precise the use case?

    Hope this helps

    Jean-Michel.
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

    ‏2012-10-09T14:57:20Z  in response to RaviTamada
    Well, in case this is unclear, i should have precised you need to browse the mentioned address from your device

    :)

    Hope this helps.

    Jean-Michel
    • RaviTamada
      RaviTamada
      29 Posts
      ACCEPTED ANSWER

      Re: 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

      ‏2012-10-09T18:03:23Z  in response to SystemAdmin
      Hi Jean-Michel(IBM Worklight Support Team),

      Thanks for your reply.

      From the device I tried accessing the client App by entering 'http://hostname:portnumber/applicationcenter/installers.html' URL.
      After Entering this URL in Device Browser, i am getting a dialog box to enter User Name & Password.
      I have entered 'appcenteradmin/admin' as credentials. Even after entring these correct credentials, i am not able to
      see the next page. But showing a blank page.
      If try to open the same URL in Windows browser & enter these credentials, then i am able to see the app page & allwing me to download the app. I dont know why i am not able to download the app from device.
      In this case what can i do? Thanks.
      Ravi Tamada
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

    ‏2012-10-10T07:24:18Z  in response to RaviTamada
    Hello Ravi,

    Thank you for the information.

    Can you precise the kind of device you are trying to install on?
    Is it an HTC or Samsung tablet or phone?
    Also, which version of Worklight did you install ?

    Thank you.

    Jean-Michel
    • RaviTamada
      RaviTamada
      29 Posts
      ACCEPTED ANSWER

      Re: 'IBM WL5.0-App Center' > issue with installing Client App to Andriod Device

      ‏2012-10-10T08:02:29Z  in response to SystemAdmin
      Hi Jean-Michel,

      I am trying to install the app on ' LG Optimus One , Android 2.3.3'.
      Worklight Version:
      1) We are using: Worklight 5.0 >>> 'IM_Rep_Worklight_Server_wee_5.0.0'
      2) More specific version >>> <offering id="com.ibm.imp.wee" version="5.0.0.20120608_0925">
      Regards,

      Ravi Tamada
      • SystemAdmin
        SystemAdmin
        2327 Posts
        ACCEPTED ANSWER

        Re: 'IBM WL5.0-App Center' &gt; issue with installing Client App to Andriod Device

        ‏2013-02-08T00:39:37Z  in response to RaviTamada
        Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

        See the Forum Migration announce post for more details. Thank you.

        Barbara Hampson, Manager, IBM Worklight
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: 'IBM WL5.0-App Center' &gt; issue with installing Client App to Andriod Device

    ‏2012-10-10T14:56:21Z  in response to RaviTamada
    Hello Ravi,

    Thank you for the details,

    We are trying to reproduce the issue.

    In the meantime, you should give a try to the latest 5.0.0.3 version that can be downloaded from your passport advantage account from http://www-947.ibm.com/support/entry/portal/downloads/software/other_software/ibm_mobile_foundation and let us know if the problem still occurs.

    Hope this helps

    Jean-Michel.
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: 'IBM WL5.0-App Center' &gt; issue with installing Client App to Andriod Device

    ‏2012-10-11T09:34:19Z  in response to RaviTamada
    Hi Ravi,

    We cannot reproduce your issue.
    It could be useful if you could send the Logcat result showing what happens when you access the installers URL.
    This Logcat result is directly accessible in the Logcat view that can be shown in your Eclipse.
    Also you need to set your phone device in USB debug mode (i think it is already set) and plug it to the debug machine to see the log results.

    Regards,
    Jean-Michel.
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: 'IBM WL5.0-App Center' &gt; issue with installing Client App to Andriod Device

    ‏2012-10-11T09:35:50Z  in response to RaviTamada
    Hi Ravi,

    We cannot reproduce your issue.
    It could be useful if you could send the Logcat result showing what happens when you access the installers URL.
    This Logcat result is directly accessible in the Logcat view that can be shown in your Eclipse.
    Also you need to set your phone device in USB debug mode (i think it is already set) and plug it to the debug machine to see the log results.

    Regards,
    Jean-Michel.
    • clivejefferies
      clivejefferies
      15 Posts
      ACCEPTED ANSWER

      Re: 'IBM WL5.0-App Center' &gt; issue with installing Client App to Andriod Device

      ‏2013-01-25T13:53:59Z  in response to SystemAdmin
      I have the same problem, I try to install, but the download never comes through - this is what I grabbed from Logcat:
      01-25 13:38:58.291: W/DownloadManager(17833): Aborting request for download 89: while

      trying to execute request: javax.net.ssl.SSLHandshakeException:

      java.security.cert.CertPathValidatorException: Trust anchor for certification path not

      found.
      Does anyone know a way round this.

      Thanks,

      Clive
      • clivejefferies
        clivejefferies
        15 Posts
        ACCEPTED ANSWER

        Re: 'IBM WL5.0-App Center' &gt; issue with installing Client App to Andriod Device

        ‏2013-01-28T13:07:58Z  in response to clivejefferies
        It looks like this could be an issue with Android: http://stackoverflow.com/questions/4115101/apache-httpclient-on-android-producing-certpathvalidatorexception-issuername
        • SystemAdmin
          SystemAdmin
          2327 Posts
          ACCEPTED ANSWER

          Re: 'IBM WL5.0-App Center' &gt; issue with installing Client App to Andriod Device

          ‏2013-02-08T13:44:54Z  in response to clivejefferies
          Hi,

          Do you use SSL so a URL like https://hostname:portnumber/applicationcenter/installers.html and not HTTP ?