Topic
2 replies Latest Post - ‏2012-10-05T14:56:29Z by jaalger
GKDV
GKDV
31 Posts
ACCEPTED ANSWER

Pinned topic Problem in creating android specific project

‏2012-10-05T14:08:34Z |
Hi,

there is a problem,

I have created a worklight project, successfully build it and deploy it.

Then create Worklight environment android for that project.

A new folder i created in my project explorer named as HelloWorklightHelloWorklightAndroid

Now due to some reasons i have to delete that android project.

now when i am again creating android environment for my project the android environment checkbox is disabled....

how can i again create that android environment or enable that checkbox again ???
Thaks
GKDV
  • IdanAdar
    IdanAdar
    741 Posts
    ACCEPTED ANSWER

    Re: Problem in creating android specific project

    ‏2012-10-05T14:46:37Z  in response to GKDV
    Sounds like you may have deleted the Android folder from the project, but kept the reference to the android environment in application-descriptor.xml

    Delete the android element from application-descriptor.xml and try again to add the environment.
    This should re-add the Android folder to your folder.

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
  • jaalger
    jaalger
    24 Posts
    ACCEPTED ANSWER

    Re: Problem in creating android specific project

    ‏2012-10-05T14:56:29Z  in response to GKDV
    GKDV,

    In order to recreate your android folder ("HelloWorklightHelloWorklightAndroid") all you want to do is right click on your android environment ("Project_name"->apps->"App_name"->android) and do a Run-As->Build Environment and Deploy. The reason your android environment check-box is disabled is because you already have the environment added to your project. The folder you have referenced to is not the environment, but it is the contents that is created after you complete a build for the specific android platform. If you delete the android environment found in "Project_name"->apps->"App_name"->android you will then see the check-box enabled once again since you have fully removed the environment.

    Regards,
    Joshua