Topic
2 replies Latest Post - ‏2012-10-17T08:30:31Z by GWReeves
GWReeves
GWReeves
69 Posts
ACCEPTED ANSWER

Pinned topic Process invoke of Mediation works via web interface but not via sca

‏2012-10-05T11:51:19Z |
Using WebSphere Process Server 6.2

I have a process module that is invoking a mediation.
I've generated both Web and SCA exports on the mediation.

If I use the web (i.e. web service, wsdl) interface in the process assembly it works fine.
If I regenerate the assemly to use the SCA interface I get a null pointer exception.

Both process and mediation are running on the same machine and on the same process server.

I've done this many times before without any issues.

Has anyone else experienced this and, more importantly, have a way to avoid it?

Thanks
Updated on 2012-10-17T08:30:31Z at 2012-10-17T08:30:31Z by GWReeves
  • mmalc
    mmalc
    216 Posts
    ACCEPTED ANSWER

    Re: Process invoke of Mediation works via web interface but not via sca

    ‏2012-10-07T09:38:10Z  in response to GWReeves
    If you have a SCA export in your mediation, I'd drag that again onto the process modules assembly diagram as a SCA import again and discard what you've done before. This should just work and I've never experienced problems like this. Probably the regeneration is causing the problem.
    • GWReeves
      GWReeves
      69 Posts
      ACCEPTED ANSWER

      Re: Process invoke of Mediation works via web interface but not via sca

      ‏2012-10-17T08:30:31Z  in response to mmalc
      I did as you suggested and the null pointer exception returned.
      Any other ideas? I've never seen this happen before and have no
      idea how to get around it.
      Thanks