Topic
  • 5 replies
  • Latest Post - ‏2012-10-05T13:23:46Z by ArupKar
babinag
babinag
91 Posts

Pinned topic Missing tabes and display artifacts after applying 9.1fp009

‏2012-10-02T07:39:24Z |
Hi.
I have faced with strange issues after applying fixpack009 to mdm9.1 with no previously installed fixpacks(means, ./migrateToInstalledFP.sh --fromversion=BASE)

1. After fixpack applied, 2 tables disappears

____________________________________________________________________________________________________ |Missing Tables                                                                                      | |====================================================================================================| |  TCTG_TSD_TEMPLATE_SEARCH_DATA                                                                     | |  TCTG_TSS_TEMPLATE_SEARCH_SORT                                                                     | |____________________________________________________________________________________________________|


Absence of this tables results in widget fail(with stacktrace info, check attachement) when catalog or hierarchy rich search "Search Options" frame of full richsearch screen renders.
This query fails:

2012-10-02 11:06:04,779 [jsp_10: classicornew.wpc] ERROR com.ibm.ccd.common.db.Query - CWPCM0040E:The query failed : [ Static Query [name: GEN_CTG_TSS_TEMPLATE_SEARCH_SORT_GETBYCMPCTGTPLUSR] [id: 150] SELECT * FROM tctg_tss_template_search_sort WHERE tss_company_id = 10001 AND tss_catalog_id = 17202 AND tss_template_id = 0 AND tss_user_id = 11202 ], Exception:ORA-00942:


2. Some widgets renders strangely - check attachement.
When i add occurences to plain "Spec/multioccAttribute", they renders with layout artifacts.

Does this issues will disappears after environment will be upgraded to mdm10.0 throught mdm9.1BASE->mdm9.1FP009->mdm10.0 ?
Updated on 2012-10-05T13:23:46Z at 2012-10-05T13:23:46Z by ArupKar
  • SystemAdmin
    SystemAdmin
    648 Posts

    Re: Missing tabes and display artifacts after applying 9.1fp009

    ‏2012-10-02T07:47:31Z  
    Hi,

    If you don't want to find out a cause of the issue with the migration just create the tables youself. The definitions of the tables and the indexes you can find in the directory $TOP/src/db/schema/gen
  • babinag
    babinag
    91 Posts

    Re: Missing tabes and display artifacts after applying 9.1fp009

    ‏2012-10-02T07:54:25Z  
    Hi,

    If you don't want to find out a cause of the issue with the migration just create the tables youself. The definitions of the tables and the indexes you can find in the directory $TOP/src/db/schema/gen
    Hi, Alexander.

    Yes, i can create that tables manually but i want to find a cause.
    Also, what about layout rendering artifacts of multioccurency attributes, did you ever faced with this issue?
  • SystemAdmin
    SystemAdmin
    648 Posts

    Re: Missing tabes and display artifacts after applying 9.1fp009

    ‏2012-10-02T08:05:23Z  
    • babinag
    • ‏2012-10-02T07:54:25Z
    Hi, Alexander.

    Yes, i can create that tables manually but i want to find a cause.
    Also, what about layout rendering artifacts of multioccurency attributes, did you ever faced with this issue?
    Hi,

    I faced with the rendering artifacts of linked multioccurency attributes in MDMCS v10.0. I opened a PMR and the issue will be fixed in next fixpack. I think you need to open PMR for MDM4PIM v9.1 also.
    At first you should know if the tables existed before you began the migration. Next you should study the migration script. I'm sure you will find there a lot of logical errors. Also check all migration logs for errors (it is good idea If you route the output of the migration script into a separate file)
  • babinag
    babinag
    91 Posts

    Re: Missing tabes and display artifacts after applying 9.1fp009

    ‏2012-10-02T10:45:28Z  
    Tables were recreated.
    First grep files in $TOP/src/db to find TCTG_TSS_TEMPLATE_SEARCH* containing files
    
    find $TOP/src/db/ -exec grep -H -n 
    'tctg_tss_template_search*' 
    {
    } \;
    
    .
    After inspecting some, tables created by executing sql file: $TOP/src/db/schema/dbscripts/oracle/create_new_tables_of_600.sql
  • ArupKar
    ArupKar
    16 Posts

    Re: Missing tabes and display artifacts after applying 9.1fp009

    ‏2012-10-05T13:23:46Z  
    • babinag
    • ‏2012-10-02T10:45:28Z
    Tables were recreated.
    First grep files in $TOP/src/db to find TCTG_TSS_TEMPLATE_SEARCH* containing files
    <pre class="jive-pre"> find $TOP/src/db/ -exec grep -H -n 'tctg_tss_template_search*' { } \; </pre> .
    After inspecting some, tables created by executing sql file: $TOP/src/db/schema/dbscripts/oracle/create_new_tables_of_600.sql
    Hi..Regarding the layout issue for the linked multi-occrrence attribs, there is already a APAR and is scheduled to be release with 9.1.0-FP010. Tentative release date I know is end of Oct 2012.