Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
2 replies Latest Post - ‏2012-10-02T15:18:19Z by SystemAdmin
SystemAdmin
SystemAdmin
300 Posts
ACCEPTED ANSWER

Pinned topic Error when configuring Application Center - user not in group 'admin'.

‏2012-09-27T16:42:28Z |
I have an IBM Worklight Enterprise server (5.0.0.3) installed and running in a Websphere Liberty Profile (wlp-8.5.0.0-20120428-1251) in a Ubuntu server (12.04.1 LTS) box. I have root privileges.

I am trying to configure and set up the Application Server as instructed in the Application Center User's Guide (p. 32) - http://public.dhe.ibm.com/ibmdl/export/pub/software/mobile-solutions/worklight/docs/wl_5_0_app_center.pdf

I stopped the worklightServer.

From /opt/IBM/Worklight/server/wlp/bin I run &> sudo ./server create appcenter

However, I get the following error: "This program can only be executed by users in group 'admin'."

My user is listed in the admin group for the Ubuntu box. Is there a config file I am missing to run this command in Liberty?

Thanks,
Ralph Pina
  • slowhand
    slowhand
    35 Posts
    ACCEPTED ANSWER

    Re: Error when configuring Application Center - user not in group 'admin'.

    ‏2012-09-27T20:20:09Z  in response to SystemAdmin
    > I am trying to configure and set up the Application Server as instructed in the Application Center User's Guide (p. 32)
    > - http://public.dhe.ibm.com/ibmdl/export/pub/software/mobile-solutions/worklight/docs/wl_5_0_app_center.pdf

    Note that the beginning of section 2.4 (p. 31) mentions that starting with 5.0.0.3, the easier alternative to the manual installation instructions is to rely on the IM based installer. It installs the Application Center in the server called worklightServer.

    > From /opt/IBM/Worklight/server/wlp/bin I run &> sudo ./server create appcenter
    > However, I get the following error: "This program can only be executed by users in group 'admin'."

    Said wlp/bin/server program is configured to be runnable from any user in group 'admin'.
    Most likely user 'root', which you want to run this program, is not in group 'admin'.

    I would try to run ./server create appcenter. The 'server' binary is a setgid binary so that any user in group 'admin' can run it without needing to use 'root' credentials.

    --slowhand
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: Error when configuring Application Center - user not in group 'admin'.

    ‏2012-10-02T15:18:19Z  in response to SystemAdmin
    Yeah... that was it. I guess I did not read it properly and was over complicating it. Thanks for pointing that out.