Topic
10 replies Latest Post - ‏2012-10-03T19:53:34Z by Srinivas Rao
Nissad
Nissad
10 Posts
ACCEPTED ANSWER

Pinned topic Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

‏2012-09-27T14:17:09Z |
Hi,
Recently we did upgrade/new install Optim8.1 sever AIX side.

We have a backup of old Optim 7.2.1:
rtsetenv
sbin/rtserver
sbin/rt4s
etc/pstserv.cfg
etc/pstlocal.cfg
etc/locale.conf

And replaced after the new install: and modified the scripts according to new 8.1
/optim/8.1/rt/rtsetenv
/optim/8.1/rt/sbin/rtserver
/optim/8.1/rt/sbin/rt4s
/optim/8.1/rt/etc/pstserv.cfg
/optim/8.1/rt/etc/pstlocal.cfg
/optim/8.1/rt/etc/locale.conf
When I try to start the Optim server -I am getting server not found.

$ rtserver start
ksh: rtserver: not found

Pls let me know if I am missing any configuration or do I need to follow any other steps?

Thanks,
Nissa
Updated on 2012-10-03T19:53:34Z at 2012-10-03T19:53:34Z by Srinivas Rao
  • Srinivas Rao
    Srinivas Rao
    61 Posts
    ACCEPTED ANSWER

    Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

    ‏2012-09-27T14:40:46Z  in response to Nissad
    Hi,

    By looking at your below details, I can see that path has been changed to /optim/8.1 after the upgrade.
    Can you please chekc the PSTHOME environment variable in /optim/8.1/rt/rtsetenv file and .profile or .bash_profile and
    correct the path if not already there.

    Once you update this,can you please relogin and open another session and try rtserver command.

    e.g which rtserver or rtserver start

    Let me know how it goes.
    Thanks,

    Srinivas
    • Nissad
      Nissad
      10 Posts
      ACCEPTED ANSWER

      Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

      ‏2012-09-27T15:20:01Z  in response to Srinivas Rao
      Hi Srinivas,

      I have verified the environment variable the path is fine.

      After the install- updated PSTHOME:
      PSTHOME=${PSTHOME:-/optim/8.1/rt}
      PSTINFO=${PSTINFO:-/optim/8.1/rt/tmp/rt4s}
      PSTDIRS=${PSTDIRS:-/optim_data/optimdirs}


      #!/bin/ksh

      . ./setenv.sh

      . /optim/8.1/rt/rtsetenv
      still getting the same error.

      Thanks,
      Nissa
      • Srinivas Rao
        Srinivas Rao
        61 Posts
        ACCEPTED ANSWER

        Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

        ‏2012-09-27T15:33:02Z  in response to Nissad
        I am sure you would have opened a new session and tried executing the rtserver command.

        Can you please share what was the previous 7.2 ( absolute path of PSTHOME ) and in 8.1.0 what is the absolute path.

        Still after you login to a new session again ,can you please execute the below command and sent me the output ?

        pwd
        which rtserver
        which pr0sign
        echo $PSTHOME
        echo $PSTUSER
        echo $PATH | grep -i "optim"

        Output of these would be helpful.
        Thanks
        • Nissad
          Nissad
          10 Posts
          ACCEPTED ANSWER

          Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

          ‏2012-09-27T16:01:31Z  in response to Srinivas Rao
          Hi Srinivas,

          My previous 7.2.1 PSTHOME:PSTHOME=${PSTHOME:-/optim/7.2.1/rt}

          executed all the commands mentioned by you.

          here are the results:
          $ pwd
          /home/optimdba

          $ which rtserver
          no rtserver in /usr/bin /etc /usr/sbin /usr/ucb /usr/bin/X11 /sbin /usr/java5/jr e/bin /usr/java5/bin

          /usr/local/bin /usr/local/bin /etc/adm /usr/lpp/OV/bin/OpC /usr/lpp/OV/bin/OpC/utils

          /var/opt/OV/bin/OpC/cmds /usr/local/bin /usr/DynamicLi nkManager/bin/ /opt/IBM/ITM/bin /var/ifor

          /usr/opt/ifor/ls/conf /opt/pb/bin /opt /quest/bin
          $ which pr0sign
          no pr0sign in /usr/bin /etc /usr/sbin /usr/ucb /usr/bin/X11 /sbin /usr/java5/jre/bin /usr/java5/bin /usr/local/bin

          /usr/local/bin /etc/adm /usr/lpp/OV/bin/OpC /usr/lpp/OV/bin/OpC/utils /var/opt/OV/bin/OpC/cmds /usr/local/bin

          /usr/DynamicLinkManager/bin/ /opt/IBM/ITM/bin /var/ifor /usr/opt/ifor/ls/conf /opt/pb/bin /opt/quest/bin
          $ echo $PSTHOME

          $ echo $PSTUSER

          $ echo $PATH | grep -i "optim"

          $ $
          • Nissad
            Nissad
            10 Posts
            ACCEPTED ANSWER

            Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

            ‏2012-09-28T18:18:00Z  in response to Nissad
            Hi Srinivas,

            Here are the results(I have modified:rtsetenv..profile,rt4s)
            $ pwd
            /home/optimdba

            $ which rtserver
            /optim/8.1/rt/sbin/rtserver

            $ which pr0sign
            /optim/8.1/rt/bin/pr0sign

            $ echo $PSTHOME
            /optim/8.1/rt

            $ echo $PSTUSER

            $ echo $PATH | grep -i "optim"
            /optim/8.1/rt/mw/bin:/optim/8.1/rt/mw/bin-rs6000_aix4:/optim/8.1/rt/mw/bin-aix4_optimized:/u01/app/oracle/product/10.2.0.4/client_1/bin:/usr/bin:/etc:/usr/sbin:/usr/ucb:/usr/bin/X11:/sbin:/usr/java5/jre/bin:/usr/java5/bin:/usr/local/bin:/usr/local/bin:/etc/adm:/usr/lpp/OV/bin/OpC:/usr/lpp/OV/bin/OpC/utils:/var/opt/OV/bin/OpC/cmds:/usr/local/bin:/usr/DynamicLinkManager/bin/:/opt/IBM/ITM/bin:/var/ifor:/usr/opt/ifor/ls/conf:/opt/pb/bin:/opt/quest/bin:/optim/8.1/rt/bin:/optim/8.1/rt/sbin:/usr/bin/X11:/cae64adm/sqllib/bin:/cae64adm/sqllib/adm:/cae64adm/sqllib/misc:/optim/8.1/rt/navroot/bin:/u01/app/oracle/product/10.2.0.4/client_1/bin:/usr/vacpp/bin
            $
            Thanks,
            Nissa
  • SueP
    SueP
    16 Posts
    ACCEPTED ANSWER

    Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

    ‏2012-09-27T14:43:26Z  in response to Nissad
    Hi Nissa,

    Is PSTHOME set? Once 8.1 was installed, did you overwrite the configuration files or did you manually update them? Are all your paths correct within them?

    Thanks,
    Sue
    • Nissad
      Nissad
      10 Posts
      ACCEPTED ANSWER

      Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

      ‏2012-09-27T14:55:44Z  in response to SueP
      After the install- updated PSTHOME:

      PSTHOME=${PSTHOME:-/optim/8.1/rt}
      PSTINFO=${PSTINFO:-/optim/8.1/rt/tmp/rt4s}
      PSTDIRS=${PSTDIRS:-/optim_data/optimdirs}


      #!/bin/ksh

      . ./setenv.sh
      . /optim/8.1/rt/rtsetenv
  • SystemAdmin
    SystemAdmin
    304 Posts
    ACCEPTED ANSWER

    Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

    ‏2012-09-28T19:02:06Z  in response to Nissad
    Hi Nissa,

    Interestingly enough you are pointing to the rtserver script in the proper directory. What happens if you path to the directory and run the
    script from there?

    Thanks,
    Kevin
  • Nissad
    Nissad
    10 Posts
    ACCEPTED ANSWER

    Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

    ‏2012-10-03T18:44:37Z  in response to Nissad
    Hi Kevin,

    Thank you for your response.
    Now I am able to start the server.
    rtserver start --is working

    Thanks,
    Nissa
    • Srinivas Rao
      Srinivas Rao
      61 Posts
      ACCEPTED ANSWER

      Re: Optim7.2.1 to 8.1 upgrade/new install server on AIX- rtserver not found

      ‏2012-10-03T19:53:34Z  in response to Nissad
      We are glad that it worked :)
      Thanks,
      Srinivas