Topic
2 replies Latest Post - ‏2012-10-15T10:01:42Z by fjb_saper
Church55
Church55
6 Posts
ACCEPTED ANSWER

Pinned topic slashes in flow name?

‏2012-09-25T21:25:05Z |
What am I doing wrong? It finds the flow name in the first command, but I cannot use the flow name in the second command...

C:\IBM\MQSI\8.0.0.0\bin>mqsireportflowstats MB8BROKER -e default -j -a
BIP8187I: Statistics Archive collection for flow Simple_Monitoring/Simple_Monitoring_MF in execution group default is...
BIP8071I: Successful command completion.

C:\IBM\MQSI\8.0.0.0\bin>mqsireportflowstats MB8BROKER -e default -f Simple_Monitoring/Simple_Monitoring_MF -a
BIP8045E: The message flow is not available.
The message flow could not be found; it may have been deleted by the Message Broker Toolkit or a CMP application.
Use the Message Broker Toolkit or a CMP application to see if the message flow exists.
Updated on 2012-10-15T10:01:42Z at 2012-10-15T10:01:42Z by fjb_saper
  • SystemAdmin
    SystemAdmin
    4179 Posts
    ACCEPTED ANSWER

    Re: slashes in flow name?

    ‏2012-10-15T04:55:19Z  in response to Church55
    I figured out that the slashes in the flow name has something to do with message flows being defined in an application as opposed to being defined as an independent resource. It might be something new in V8. Not sure.

    There seem to be some big differences in capability between these two ways of building flows. It seems like I can do stuff in one that I can't do in the other and vice versa.

    I can't deploy a flow that's part of application separate from that application. But deploying them together is what's putting the slash in the flow name. And I can't enable monitoring events if there's a slash in the flow name. But if I make the flow into an independent resource I lose other capabilities.
    • fjb_saper
      fjb_saper
      120 Posts
      ACCEPTED ANSWER

      Re: slashes in flow name?

      ‏2012-10-15T10:01:42Z  in response to SystemAdmin
      Have you tried escaping the / in the flow name when issuing the command?
      Have you tried encasing the flow name in quotes when issuing the command?