Topic
  • 6 replies
  • Latest Post - ‏2013-06-17T23:23:19Z by Nebrken
Bob Genis
Bob Genis
18 Posts

Pinned topic Debugger: Mouse hover does not evaluate variables (RDP 8.5.0)

‏2012-09-25T15:41:28Z |
I recently upgraded from 7.6 to 8.5 and have noticed that when debugging I can no longer hover over a variable and have the value display. I scanned though the Preferences and in

Run/Debug
Compiled Debug
Debug Editors

I have "Allow hover evaluation" and "Display types in hover" selected.

In the debug, I occasionally get a value displayed for some variables but nothing on others. On the ones that do display, the values aren't current (don't represent the actual value from "Monitor Expression").

I do not have "Always use Debugger Editor when debugging" and reuse the Text Editor. Do I have to use the Debugger Editor?

Is there something else I am missing to get this to work?

Any help is appreciated.
Updated on 2012-12-14T16:48:10Z at 2012-12-14T16:48:10Z by SystemAdmin
  • gkern
    gkern
    23 Posts

    Re: Debugger: Mouse hover does not evaluate variables (RDP 8.5.0)

    ‏2012-09-27T16:57:11Z  
    I found that I have to first right click, go to Switch View and then select Show *Listing. I also need to do this just to be able to double click to add a monitor.

    I'm also trying to figure out if there is a preference that will set this permanently. I first noticed this on my first version of R8. WDSC V7 never had this issue.
  • Bob Genis
    Bob Genis
    18 Posts

    Re: Debugger: Mouse hover does not evaluate variables (RDP 8.5.0)

    ‏2012-10-02T13:16:20Z  
    The *LISTING view works. I'd still prefer to have the functionality work on the *SOURCE view and RSE Editor window. But...such is life.
  • Bob Genis
    Bob Genis
    18 Posts

    Re: Debugger: Mouse hover does not evaluate variables (RDP 8.5.0)

    ‏2012-11-28T16:32:40Z  
    • Bob Genis
    • ‏2012-10-02T13:16:20Z
    The *LISTING view works. I'd still prefer to have the functionality work on the *SOURCE view and RSE Editor window. But...such is life.
    Just a follow-up: I recently installed the v8.5.1 Fix Pack and the problem seems to have been resolved. You can use the *SOURCE view and RSE editor while debugging and the Hover Over evaluation works. Hooray!
  • SystemAdmin
    SystemAdmin
    225 Posts

    Re: Debugger: Mouse hover does not evaluate variables (RDP 8.5.0)

    ‏2012-12-14T16:48:10Z  
    • Bob Genis
    • ‏2012-11-28T16:32:40Z
    Just a follow-up: I recently installed the v8.5.1 Fix Pack and the problem seems to have been resolved. You can use the *SOURCE view and RSE editor while debugging and the Hover Over evaluation works. Hooray!
    So that you don't think it was an accident that it is fixed... :-)

    The problem was introduced in RDp 8.5.0 and fixed in 8.5.1

    APAR SE53486
  • Walt1968
    Walt1968
    3 Posts

    Re: Debugger: Mouse hover does not evaluate variables (RDP 8.5.0)

    ‏2013-05-13T15:02:30Z  

    Would it be possible to make RDP work so that a monitor is added when a variable is double-clicked in *SOURCE view, and not just in *LISTING view?

  • Nebrken
    Nebrken
    1 Post

    Re: Debugger: Mouse hover does not evaluate variables (RDP 8.5.0)

    ‏2013-06-17T23:23:19Z  
    So that you don't think it was an accident that it is fixed... :-)

    The problem was introduced in RDp 8.5.0 and fixed in 8.5.1

    APAR SE53486

    We just installed RDP 8.5.1 and I am still having the problem.