Topic
2 replies Latest Post - ‏2012-09-17T15:13:53Z by rossdavibm
eric_scr
eric_scr
1 Post
ACCEPTED ANSWER

Pinned topic SCP 2.1 on Laptop W520 ?

‏2012-09-15T09:37:01Z |
Hi,

I would like to test SCP 2.1 (trial version) on my laptop W520 with 16Go RAM (Windows 7).
I know this is not a good configuration, but it's just for testing.
I could install the iso file without problem, but when I want to install a storage or compute node, I receive the message "The CPU has been disabled by the guest operating system. Power off or reset the virtual machine.".
I'm working on VmWare Workstation 8, and took care of checking the VT button on the processor properties.

I made a lot of tests, but always same thing.

Do you have some idea, advices to do ?

Thank you

Regards
Updated on 2012-09-17T15:13:53Z at 2012-09-17T15:13:53Z by rossdavibm
  • rossella
    rossella
    58 Posts
    ACCEPTED ANSWER

    Re: SCP 2.1 on Laptop W520 ?

    ‏2012-09-17T08:07:03Z  in response to eric_scr
    Hi!

    The iso installation already installs by default a compute node and two storage nodes. Could you check the installation was effectively completed correctly? If you open HSLT admin UI you should be able to see in the Cloud Infrastructure tab the compute node and the storage nodes.
    I'm asking you to check that because most likely you may have a problem with dual layer virtualization or with the CUPID flag.
  • rossdavibm
    rossdavibm
    25 Posts
    ACCEPTED ANSWER

    Re: SCP 2.1 on Laptop W520 ?

    ‏2012-09-17T15:13:53Z  in response to eric_scr
    Greetings.

    I know that all W520s I have seen are all fully capable of running this product virtually in VMware images. Confirm the BIOS settings to ensure that the virtualization support is enabled - it should be by default.

    The other thing you need to check - and this caused me grief until discovered - is in the VMX file for the VMs. VMware supports 'hot add' of CPUs. If this is enabled, it causes issues with the libvirtd process, used to run the kernel services and instances on the KVM compute node. Find the line in the VMX and modify it to read "vcpu.hotadd = FALSE" (default is true).

    Good luck - again, work from the premise that this does indeed work on your platform and that any issues are specific to something you are doing.