Topic
  • 2 replies
  • Latest Post - ‏2012-10-03T12:31:14Z by EHJH_Luis_Seisdedos
EHJH_Luis_Seisdedos
EHJH_Luis_Seisdedos
2 Posts

Pinned topic Unable to record response file for silent install, Win7 SP1, IBMIM 1.5.1

‏2012-09-13T16:55:54Z |
I am trying to run Installation Manager in record mode and it doesn't work. I am launching something as simple as this:

IBMIM.exe -record ResponseFile.xml -skipInstall C:\MonCRM\temp

Unfortunately the distribution I am running is in French, so when translating maybe I won't be showing exactly the same message that "canonical" English version would show... (see attached file to see original message in French). It is so bad that IBMIM does not show an error code in this case for rapid, simple and accurate debugging in this case! If I translate error message into English, it kind of gives the following:

Incorrect command line arguments.

Cause:

{IM installation folder}/IBMIM:
Problem in command line: -toolId ibmim -accessRights nonAdmin
-record ResponseFile.xml -skipInstall c:\MonCRM\temp
Command line argument "-record" is not recognized.

Use "help" command for information about available commands.

My environment is:

Windows 7 Enterprise Service Pack 1, 64 bits
Installation Manager 1.5.1, internal version is 1.5.1000.20111128_0824
I run cmd.exe as administrator, so I tried both having -accessRight either nonAdmin and then admin, it did not work in any case.

I have searched the Internet and it seems that no bug has been reported on this, so I must be doing something wrong. Can anyone tell me what it is?

Thanks a lot in advance.
Updated on 2012-10-03T12:31:14Z at 2012-10-03T12:31:14Z by EHJH_Luis_Seisdedos
  • SystemAdmin
    SystemAdmin
    14225 Posts

    Re: Unable to record response file for silent install, Win7 SP1, IBMIM 1.5.1

    ‏2012-09-13T19:49:03Z  
    Hi.
    In the image you attached, I see that the dash (-)is short for the params -toolId and -accessRights, but it is long in parameters -record and -skipInstall. Did you copy the command line from a text editor that could have replaced the short dash by a long one?
  • EHJH_Luis_Seisdedos
    EHJH_Luis_Seisdedos
    2 Posts

    Re: Unable to record response file for silent install, Win7 SP1, IBMIM 1.5.1

    ‏2012-10-03T12:31:14Z  
    Hi.
    In the image you attached, I see that the dash (-)is short for the params -toolId and -accessRights, but it is long in parameters -record and -skipInstall. Did you copy the command line from a text editor that could have replaced the short dash by a long one?
    Hi!

    Thanks a lot, what you pointed out appears to be the cause for my problem.

    At the same time I was trying to record the response file, I was documenting this task. Somehow I copied text from word processor to Windows command shell. But word processor had some time changed the short dash into a long one. Unfortunately, when copying that character back into the shell, it is shown equal or very similar, so on the shell you cannot see the difference. And fortunately, Installation Manager does show the difference.