Topic
  • 2 replies
  • Latest Post - ‏2013-03-23T02:50:46Z by spriet
sralman
sralman
1 Post

Pinned topic HelloWorld Tutorial - HTTP ( 404 ) Not Found address

‏2012-09-13T09:15:21Z |
Hi

Im new to WID and did the first tutorial HelloWorld Part 1 on WID 7.0.

First i did it myself but when it didnt work I imported the ready made project from IBM but got the same exception message when I ran the test:

CWSXM0202E: An unexpected exception occurred when processing mediation flow for component HelloWorldMediation in module HelloWorldMediation: CWSXM1025E: An unexpected exception occurred when the flow was called: CWSXM0111E: Service runtime exception calling an import from mediation component HelloWorldMediation in module HelloWorldMediation: CWSXM0205E: An unexpected business logic exception occurred.: CWSXM3300E: Fail primitive 'Fail1', component 'HelloWorldMediation', module 'HelloWorldMediation', interface '{http://HelloWorldMediation}ErrorHandling', operation 'callHello/ResponseFlow/ErrorHandling/in', raised a FailFlowException. The user-supplied error message is '2012-09-13 11:06, BEE0D1FE-0139-4000-E000-05D8C0A87182, Fail1, HelloWorldMediation, <failInfo xsi:type="Se:FailInfoType" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:Se="http://www.ibm.com/websphere/sibx/smo/v6.0.1"><failureString>javax.xml.ws.WebServiceException: java.net.ConnectException: HTTP ( 404 ) Not Found address : http://localhost:9080/HelloServiceWeb/sca/HelloService</failureString><origin>External Service</origin></failInfo>
, 7'
Refer to the server logs for more information.

When i put http://localhost:9080/HelloServiceWeb/sca/HelloService in my web browser i get this message:

Error 404: com.ibm.ws.webcontainer.servlet.exception.NoTargetForURIException: No target servlet configured for uri: /HelloServiceWeb/sca/HelloService
I got the tip to configure my web.xml file. The problem is that i dont know how to do this since im new to the whole thing.

Can anyone please help me with (1) WHAT can be done to fix this problem and (2) HOW you do it?

Cheers
Updated on 2013-03-23T02:50:46Z at 2013-03-23T02:50:46Z by spriet
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: HelloWorld Tutorial - HTTP ( 404 ) Not Found address

    ‏2012-09-13T13:01:19Z  
    The most likely cause for that sort of problem is that the URL is incorrect. Probably localhost:9080 is not right - is the server you are targeting local? Is the port number correct? You can use the admin console to see the ports that are in use under Servers->server1. If multiple servers/profiles are on the same machine the port might be 9081 or 9082, etc. You can change the URL in the WSDL file.
  • spriet
    spriet
    58 Posts

    Re: HelloWorld Tutorial - HTTP ( 404 ) Not Found address

    ‏2013-03-23T02:50:46Z  
    You should not make changes to the web.xml since it is generated. I am not sure where that tip came from.

    I suspect the port is the problem. As stated in the previous post you can check that in the admin console.

    Dave Spriet
    BPM Architect, BPM SWAT