Topic
No replies
mickyhussy
mickyhussy
1 Post
ACCEPTED ANSWER

Pinned topic files after a clean install

‏2012-09-11T08:54:40Z |
We have just installed CSM 1.6.0.1, and after an clean node install with RHEL4U3 on an x326 we are getting the following warning when we install our TopSpin IB drivers:

WARNING: /lib/modules/2.6.9-34.ELsmp/kernel/drivers/scsi/qla2xxx/qla6312.ko needs unknown symbol qla2x00_remove_one
WARNING: /lib/modules/2.6.9-34.ELsmp/kernel/drivers/scsi/qla2xxx/qla6312.ko needs unknown symbol qla2x00_probe_one
Watch The Expendables 2 Online
This was quite surprising, since this worked fine when we used CSM 1.5.1.3.

An ls of the qla dir shows the following:
ls -al /lib/modules/2.6.9-34.ELsmp/kernel/drivers/scsi/qla2xxx/
total 144
drwxr-xr-x 2 root root 4096 Dec 4 15:02 .
drwxr-xr-x 10 root root 4096 Dec 4 14:58 ..
-rwxr--r-- 1 root root 119664 Feb 24 2006 qla6312.ko

While the install done by 1.5.1.3 had 7 qla* files in that directory.
Watch The Dark Knight Rises Online
After looking in the file: /csminstall/csm/scripts/installprereboot/001CSM_cpDrivers._LinuxNodes, we found the following:

97 # remove the qla2* drivers from the installed system.
98 drivers=`/usr/bin/find /lib/modules/ -name qla2*.o ; /usr/bin/find /lib/modules/ -name qla2*.ko`
99 for driver in $drivers
100 do
101 cmd="/bin/rm $driver"
102 echo $cmd>>$LOG
103 eval "$cmd"
104 done

This is then again followed by the copying of new drivers to the machine. So my question is as follows: Why do you remove the qla2* modules, and do you have any idea why new modules are not copied in ?
Watch Ted Movie Online