Topic
  • 6 replies
  • Latest Post - ‏2012-09-12T07:46:26Z by Click_Apply
Click_Apply
Click_Apply
37 Posts

Pinned topic Cant access WEBGUI- How to Configure mgmt (eth4) with 3.6.1

‏2012-09-10T04:55:37Z |
Any help is appreciated.

I know these appliances need an upgrade of firmware.

We inherited a few Datapower 9002 (with 3.6.1 firmware)appliances. We were trying to get these working and we are having issues with the access to webgui.

CLI works fine - Can someone please share the 3.6.1 CLI command reference pdf.

The appliance is connected to router Cisco E900 (to one of the LAN ports)through a patch cable and am trying to access the webgui with a computer connected to the same router on a LAN port

commands used to configure the interface of datpower as instructed in the guide:
configure terminal
int mgt0
ip address 192.168.1.125/23
ip default-gateway 192.168.1.1
write mem

The web-mgmt admin state is enabled. It shows ip as 10.0.0.23(don't know why), enabled, 9090, idle 600 on command 'show'

The host-alias command is not working, I need a command reference for this firmware level.

In the DHCP client list(in the router) the appliance is not shown until 'dhcp' command is given,with aip granted by the router((something other than that configured one above such as 192.168.1.126) ping works fine on this ip.

I can't access the webgui by the interface configured ip above or the dhcp ip above.

If it is thought to be a certificate issue on DP side(I faced a similar issue once where 'no ssl' and then 'ssl' worked). In this scenario 'no ssl' command is not working or I am not giving the command syntax correctly to disable it.
Updated on 2012-09-12T07:46:26Z at 2012-09-12T07:46:26Z by Click_Apply
  • GKReddy
    GKReddy
    138 Posts

    Re: Cant access WEBGUI- How to Configure mgmt (eth4) with 3.6.1

    ‏2012-09-10T21:47:37Z  
    #configure terminal
    #web-mgmt
    #local-address xx.xxx.xxx.xx
    #exit
    #save-config overwrite
    #exit
    #exit

    Hope this helps.
    • GK
  • Click_Apply
    Click_Apply
    37 Posts

    Re: Cant access WEBGUI- How to Configure mgmt (eth4) with 3.6.1

    ‏2012-09-11T03:29:55Z  
    • GKReddy
    • ‏2012-09-10T21:47:37Z
    #configure terminal
    #web-mgmt
    #local-address xx.xxx.xxx.xx
    #exit
    #save-config overwrite
    #exit
    #exit

    Hope this helps.
    • GK
    Thank you I appreciate you help Mr. Reddy.

    xs40# configure terminal
    Global configuration mode
    xs40(config) int mgt0
    Interface configuration mode (mgt0 )
    xs40(config-ifeth4) ip address 10.10.13.35/24
    xs40(config-ifeth4) web-mgmt 10.10.13.35 9090
    xs40(config-ifeth4) exit
    xs40(config) ssh 10.10.13.35
    xs40(config) exit

    write mem after that resolved this.

    Now, We are faced with "able to login through CLI but Authentication failure in WEBGUI" problem. It is a certificate issue in the WEBGUI. We have to firmware upgrade these boxes. we created a backup admin account and are going to upgrade on one box to 3.7.3.7 to develop some procedure to replicate on other
  • HermannSW
    HermannSW
    6381 Posts

    Re: Cant access WEBGUI- How to Configure mgmt (eth4) with 3.6.1

    ‏2012-09-11T13:06:37Z  
    Thank you I appreciate you help Mr. Reddy.

    xs40# configure terminal
    Global configuration mode
    xs40(config) int mgt0
    Interface configuration mode (mgt0 )
    xs40(config-ifeth4) ip address 10.10.13.35/24
    xs40(config-ifeth4) web-mgmt 10.10.13.35 9090
    xs40(config-ifeth4) exit
    xs40(config) ssh 10.10.13.35
    xs40(config) exit

    write mem after that resolved this.

    Now, We are faced with "able to login through CLI but Authentication failure in WEBGUI" problem. It is a certificate issue in the WEBGUI. We have to firmware upgrade these boxes. we created a backup admin account and are going to upgrade on one box to 3.7.3.7 to develop some procedure to replicate on other
    I still have one 9002 box myself among my boxes.

    But be aware that 9002 boxes are end of service, and even 9003 boxes went end-of-service last December.
    The last firmware you can install on 9002 boxes is 3.7.3.x and that went end-of-service last December, too.

     
    Hermann<myXsltBlog/> <myXsltTweets/>
  • Click_Apply
    Click_Apply
    37 Posts

    Re: Cant access WEBGUI- How to Configure mgmt (eth4) with 3.6.1

    ‏2012-09-11T13:43:41Z  
    • HermannSW
    • ‏2012-09-11T13:06:37Z
    I still have one 9002 box myself among my boxes.

    But be aware that 9002 boxes are end of service, and even 9003 boxes went end-of-service last December.
    The last firmware you can install on 9002 boxes is 3.7.3.x and that went end-of-service last December, too.

     
    Hermann<myXsltBlog/> <myXsltTweets/>
    Hello Hermann, I really appreciate your quick answers on DW, I am a regular follower of your blog and learned a lot from you. Just today.. I started using your webdatapower in the link below, It is amazing.. expecting to save a lot of time with this.

    https://www.ibm.com/developerworks/forums/thread.jspa?threadID=367478

    These XS40 appliances are wiped clean and are planned to be used for some beginner's practicing purpose. We are gonna firmware upgrade them to 3.7.3.6

    I do have one query for you.. when I checked the device certificate in the browser it is valid till June 2013. but, still WEBGUI authentication fails.. Same login credentials work in CLI, Am I missing something..other than an upgrade
  • GKReddy
    GKReddy
    138 Posts

    Re: Cant access WEBGUI- How to Configure mgmt (eth4) with 3.6.1

    ‏2012-09-11T16:16:41Z  
    Hello Hermann, I really appreciate your quick answers on DW, I am a regular follower of your blog and learned a lot from you. Just today.. I started using your webdatapower in the link below, It is amazing.. expecting to save a lot of time with this.

    https://www.ibm.com/developerworks/forums/thread.jspa?threadID=367478

    These XS40 appliances are wiped clean and are planned to be used for some beginner's practicing purpose. We are gonna firmware upgrade them to 3.7.3.6

    I do have one query for you.. when I checked the device certificate in the browser it is valid till June 2013. but, still WEBGUI authentication fails.. Same login credentials work in CLI, Am I missing something..other than an upgrade
    Probably, that particular user have no access to the web-interface. I had this kind of issue at on of the clients I worked for, but it is the other way around. I had no access to CLI but was able to login to web-interface with the same credentials. Hope this gives you some clarity.
    • GK
  • Click_Apply
    Click_Apply
    37 Posts

    Re: Cant access WEBGUI- How to Configure mgmt (eth4) with 3.6.1

    ‏2012-09-12T07:46:26Z  
    • GKReddy
    • ‏2012-09-11T16:16:41Z
    Probably, that particular user have no access to the web-interface. I had this kind of issue at on of the clients I worked for, but it is the other way around. I had no access to CLI but was able to login to web-interface with the same credentials. Hope this gives you some clarity.
    • GK
    Mr. Reddy, Its the admin account I am using.. so no RBM restrictions as such.