Topic
2 replies Latest Post - ‏2012-10-02T23:40:14Z by R6BN_Robert_Wright
RGSMani
RGSMani
12 Posts
ACCEPTED ANSWER

Pinned topic Copying an Entity

‏2012-09-05T14:12:28Z |
We have upgraded to IDA 8.1. When I try to copy and paste an entity within the same model or across another model, the tool creates a reference copy of it. This does not allow to change the entity. The purpose of the copy is to create another entity with most of the attributes of this entity so that I don't have to recreate it from scratch, especially when the size of the entity is too big with lot of attributes. Trying to find out if there is a way to do this in IDA. I am guessing that it has to do with some settings. Any help would be appreciated.
Thanks
RGSMani
Updated on 2012-10-02T23:40:14Z at 2012-10-02T23:40:14Z by R6BN_Robert_Wright
  • reital
    reital
    58 Posts
    ACCEPTED ANSWER

    Re: Copying an Entity

    ‏2012-09-06T07:16:28Z  in response to RGSMani
    Hello RGSMani

    I guess you are doing the copy from diagram surface, diagram is only a visual representation for the model, so copy/paste from diagram surface will not create new entity . For the copy of reuse existing design purpose, could you try to do the copy/paste from the model in Data Design Project .

    Thanks .
    -Tao
  • R6BN_Robert_Wright
    R6BN_Robert_Wright
    13 Posts
    ACCEPTED ANSWER

    Re: Copying an Entity

    ‏2012-10-02T23:40:14Z  in response to RGSMani
    I've seen this message and it doesn't have any pattern. I copy/paste from the Explorer and 9 times out of 10 I get what I want. Periodically I get this message. If you hit escape then it seems to work as expected.