Topic
  • 3 replies
  • Latest Post - ‏2012-11-18T16:15:33Z by SystemAdmin
jyoti_TCS
jyoti_TCS
6 Posts

Pinned topic Issue faced in IBM BPM 7.5.1

‏2012-09-01T13:20:00Z |
I am converting XML to string in 7.5.0 and its working fine.

tw.local.Untitled1=tw.local.xmlFormName.toString(true);
giving output :
<?xml version="1.0" encoding="UTF-8"?><object type="F0001"></object>

however the same state in 7.5.1 gives me xml string with escape characters < > and "
like this :

<?xml version="1.0" encoding="UTF-8"?><object type="F0001"></object>

can anyone suggest what changes should i make to get the output as the 7.5.0 version?
Updated on 2012-11-18T16:15:33Z at 2012-11-18T16:15:33Z by SystemAdmin
  • jyoti_TCS
    jyoti_TCS
    6 Posts

    Re: Issue faced in IBM BPM 7.5.1

    ‏2012-09-06T06:47:19Z  
    editing the question : and replacing < with & lt ; (spaces given deliberately so that the prob is visible)

    I am converting XML to string in 7.5.0 and its working fine.

    tw.local.Untitled1=tw.local.xmlFormName.toString(true);
    giving output :
    <?xml version="1.0" encoding="UTF-8"?><object type="F0001"></object>

    however the same state in 7.5.1 gives me xml string with escape characters & lt ; & gt ; and & quot ;
    like this :

    & lt ;?xml version=& quot ;1.0& quot ; encoding=& quot ;UTF-8& quot ;?& gt ;& lt ;object type=& quot ;F0001& quot ;& gt ;& lt ;/object& gt ;

    can anyone suggest what changes should i make to get the output as the 7.5.0 version?
  • SystemAdmin
    SystemAdmin
    7615 Posts

    Re: Issue faced in IBM BPM 7.5.1

    ‏2012-09-06T15:09:19Z  
    • jyoti_TCS
    • ‏2012-09-06T06:47:19Z
    editing the question : and replacing < with & lt ; (spaces given deliberately so that the prob is visible)

    I am converting XML to string in 7.5.0 and its working fine.

    tw.local.Untitled1=tw.local.xmlFormName.toString(true);
    giving output :
    <?xml version="1.0" encoding="UTF-8"?><object type="F0001"></object>

    however the same state in 7.5.1 gives me xml string with escape characters & lt ; & gt ; and & quot ;
    like this :

    & lt ;?xml version=& quot ;1.0& quot ; encoding=& quot ;UTF-8& quot ;?& gt ;& lt ;object type=& quot ;F0001& quot ;& gt ;& lt ;/object& gt ;

    can anyone suggest what changes should i make to get the output as the 7.5.0 version?
    There is a setting in one the ##SomeName.xml files called something like "disable-output-escaping" Try playing with that. Note that if you flip it from false to true it may open you to Cross Site Scripting attacks. I think there is an iFix out there because this was over applied by a very zelous engineer.

    Andrew Paier | Director of Special Operations | BP3 Global, Inc. www.bp-3.com
  • SystemAdmin
    SystemAdmin
    7615 Posts

    Re: Issue faced in IBM BPM 7.5.1

    ‏2012-11-18T16:15:33Z  
    I faced this issue after updating the IBM BPM from 7.5.0 to 7.5.1. Can you help me how can i solve this issue to disable the XML escaping?