Topic
  • 13 replies
  • Latest Post - ‏2013-10-17T14:34:43Z by Marcu
SystemAdmin
SystemAdmin
301 Posts

Pinned topic RPC server is not listening

‏2012-08-29T09:29:17Z |
Have installed ibm optim and trying to configure it .
using DB2 as backend.

iam receving the following issue while configuring
"Unable to communicate with server IBMOPTIM
The RPC server is not listening "

Here is the attachment of error message iam receiving.
Updated on 2012-09-05T13:57:34Z at 2012-09-05T13:57:34Z by TulasiDas
  • TulasiDas
    TulasiDas
    70 Posts

    Re: RPC server is not listening

    ‏2012-08-29T09:37:34Z  
    Hi,

    To answer your questions, I would need below details:

    what Optim Release you are trying?
    On what platform Optim is server running?

    Also attach Optim trace files.

    Thanks,
    Tulasi
  • SystemAdmin
    SystemAdmin
    301 Posts

    Re: RPC server is not listening

    ‏2012-08-29T09:40:59Z  
    • TulasiDas
    • ‏2012-08-29T09:37:34Z
    Hi,

    To answer your questions, I would need below details:

    what Optim Release you are trying?
    On what platform Optim is server running?

    Also attach Optim trace files.

    Thanks,
    Tulasi
    optim 8.1 version installed in windows xp machine.

    dont know how to get trace files from windows.
    could you please help in getting that trace files.
  • TulasiDas
    TulasiDas
    70 Posts

    Re: RPC server is not listening

    ‏2012-08-29T09:54:57Z  
    optim 8.1 version installed in windows xp machine.

    dont know how to get trace files from windows.
    could you please help in getting that trace files.
    Please try following things and let me know:

    1) Make sure you are able to connect DB2 without Optim
    2) Try without Optim server (select LOCAL under Server name)

    Trace files goto Optim Tool>Options>Personal Options>General Tab and you can see "Temporary Work Directory"

    File names like PR0TOOL., PR0SVCE., PR0SVER.*
    Thanks,
    Tulasi
  • SystemAdmin
    SystemAdmin
    301 Posts

    Re: RPC server is not listening

    ‏2012-08-29T11:10:51Z  
    • TulasiDas
    • ‏2012-08-29T09:54:57Z
    Please try following things and let me know:

    1) Make sure you are able to connect DB2 without Optim
    2) Try without Optim server (select LOCAL under Server name)

    Trace files goto Optim Tool>Options>Personal Options>General Tab and you can see "Temporary Work Directory"

    File names like PR0TOOL., PR0SVCE., PR0SVER.*
    Thanks,
    Tulasi
    Here is the trace file you asked for in the attachment.

    DB2 is working fine without Optim.

    Please do the necessary help in resolving the error.
  • Ducatiman
    Ducatiman
    58 Posts

    Re: RPC server is not listening

    ‏2012-08-29T15:39:08Z  
    Here is the trace file you asked for in the attachment.

    DB2 is working fine without Optim.

    Please do the necessary help in resolving the error.
    Disable firewall
    open port 1024
    are you using TCPip as protocol?
  • TulasiDas
    TulasiDas
    70 Posts

    Re: RPC server is not listening

    ‏2012-08-30T01:37:50Z  
    • Ducatiman
    • ‏2012-08-29T15:39:08Z
    Disable firewall
    open port 1024
    are you using TCPip as protocol?
    I looked at the trace files, looks like there is some configuration problem either in the Optim server or client.

    1) Make sure you have correct IP and port number (EndPoint) at the client side
    2) Check whether Server is running or not
    3) For more details you can refer Optim Document under <Optim Installation folder>/rt/DOC

    If server is running you can find trace files such as PR0SVCE,* under Optim Temp folder.
  • SystemAdmin
    SystemAdmin
    301 Posts

    Re: RPC server is not listening

    ‏2012-09-04T14:07:36Z  
    • Ducatiman
    • ‏2012-08-29T15:39:08Z
    Disable firewall
    open port 1024
    are you using TCPip as protocol?
    Have updated the protocol and endpoint/port as mentioned but still we are getting RPC error .
    It is running fine when we select LOCAL server but not for the server details (NEWOPTIMDIR) we have created.
    screenshot is attached.
  • SystemAdmin
    SystemAdmin
    301 Posts

    Re: RPC server is not listening

    ‏2012-09-04T14:20:48Z  
    • TulasiDas
    • ‏2012-08-30T01:37:50Z
    I looked at the trace files, looks like there is some configuration problem either in the Optim server or client.

    1) Make sure you have correct IP and port number (EndPoint) at the client side
    2) Check whether Server is running or not
    3) For more details you can refer Optim Document under <Optim Installation folder>/rt/DOC

    If server is running you can find trace files such as PR0SVCE,* under Optim Temp folder.
    Thanks a lot for your responses.

    i) We are getting the "RPC not listening" error when we are trying to execute any activity through the Optim Directory (OPTIMDIR) we configured after installation even though its connected.

    ii)The trace files such as PR0SVCE.* which should get created under Optim Temp folder, are not getting created.

    We are also not sure, if this requires any other additional software to go with it.

    In the attachment we have provided the screenshots of errors as well as some settings we did.
  • TulasiDas
    TulasiDas
    70 Posts

    Re: RPC server is not listening

    ‏2012-09-04T22:17:43Z  
    Thanks a lot for your responses.

    i) We are getting the "RPC not listening" error when we are trying to execute any activity through the Optim Directory (OPTIMDIR) we configured after installation even though its connected.

    ii)The trace files such as PR0SVCE.* which should get created under Optim Temp folder, are not getting created.

    We are also not sure, if this requires any other additional software to go with it.

    In the attachment we have provided the screenshots of errors as well as some settings we did.
    Hi,

    I looked at all your screen shots. All these are related client setting but I don't see one related to server settings.

    If server is enabled, you will see Optim icon in the control panel. Double click, configure with all relevant details and then start the server. Looks like it is either not configured properly or server not started.

    Perhaps, you can refer Optim document <OPTIM Instllation folder>/rt/doc/config.pdf
    Chapter Name: Configure the Optim Server

    Thanks,
    Tulasi
  • SystemAdmin
    SystemAdmin
    301 Posts

    Re: RPC server is not listening

    ‏2012-09-05T08:52:09Z  
    • TulasiDas
    • ‏2012-09-04T22:17:43Z
    Hi,

    I looked at all your screen shots. All these are related client setting but I don't see one related to server settings.

    If server is enabled, you will see Optim icon in the control panel. Double click, configure with all relevant details and then start the server. Looks like it is either not configured properly or server not started.

    Perhaps, you can refer Optim document <OPTIM Instllation folder>/rt/doc/config.pdf
    Chapter Name: Configure the Optim Server

    Thanks,
    Tulasi
    Thanks for your help.

    We could find the Optim icon in 32bit Control Panel window and we configured it. We started the service in the services. After configuration, though we are not getting the "RPC not listening" error , but we are getting error as "Directory not found".

    Please find the attached screenshot for the same and also settings screenshots.
  • TulasiDas
    TulasiDas
    70 Posts

    Re: RPC server is not listening

    ‏2012-09-05T12:10:58Z  
    Thanks for your help.

    We could find the Optim icon in 32bit Control Panel window and we configured it. We started the service in the services. After configuration, though we are not getting the "RPC not listening" error , but we are getting error as "Directory not found".

    Please find the attached screenshot for the same and also settings screenshots.
    For the directory you have to do following steps:

    1) Optim Server Settings>Connection Tab>Click "Merge Current User" (you can found at Bottom Left)
    Restart server and try to connect from client
    2) If that doesn't work, then on the same Connection tab, client "Configuration" then from Tasks, Access Existing Optim Directory then follow the steps

    This should solve your problem.
  • SystemAdmin
    SystemAdmin
    301 Posts

    Re: RPC server is not listening

    ‏2012-09-05T13:16:26Z  
    • TulasiDas
    • ‏2012-09-05T12:10:58Z
    For the directory you have to do following steps:

    1) Optim Server Settings>Connection Tab>Click "Merge Current User" (you can found at Bottom Left)
    Restart server and try to connect from client
    2) If that doesn't work, then on the same Connection tab, client "Configuration" then from Tasks, Access Existing Optim Directory then follow the steps

    This should solve your problem.
    Thanks a lot for your immediate reponses. We were able to run it successfully with your help.

    We will revert back to you if we get any issue further.

    Thanks :)
  • TulasiDas
    TulasiDas
    70 Posts

    Re: RPC server is not listening

    ‏2012-09-05T13:57:34Z  
    Thanks a lot for your immediate reponses. We were able to run it successfully with your help.

    We will revert back to you if we get any issue further.

    Thanks :)
    Thanks for the Update.