Topic
  • 7 replies
  • Latest Post - ‏2012-08-28T13:41:24Z by Sunit
SystemAdmin
SystemAdmin
3908 Posts

Pinned topic Help regarding mpmstats

‏2012-08-27T13:11:05Z |
Hi,

I have installed IHS 7.0 in linux and also I have enabled the mpmstats in the httpd.conf.
Now it is showing in the error.log :

mpmstats:reached null (0/0)

Please let me know what is it means.

Regards,
JagadesH L.
Updated on 2012-08-28T13:41:24Z at 2012-08-28T13:41:24Z by Sunit
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Help regarding mpmstats

    ‏2012-08-27T14:34:16Z  
    > 4P33_JagadesH_Lakshmanan wrote:
    > Hi,
    >
    > I have installed IHS 7.0 in linux and also I have enabled the mpmstats in the httpd.conf.
    > Now it is showing in the error.log :
    >
    > mpmstats:reached null (0/0)
    >
    > Please let me know what is it means.
    >
    > Regards,
    > JagadesH L.

    Just once? At startup or shutdown? All the time?
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Help regarding mpmstats

    ‏2012-08-27T18:24:53Z  
    > 4P33_JagadesH_Lakshmanan wrote:
    > Hi,
    >
    > I have installed IHS 7.0 in linux and also I have enabled the mpmstats in the httpd.conf.
    > Now it is showing in the error.log :
    >
    > mpmstats:reached null (0/0)
    >
    > Please let me know what is it means.
    >
    > Regards,
    > JagadesH L.

    Just once? At startup or shutdown? All the time?
    It appears all the time.
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Help regarding mpmstats

    ‏2012-08-27T19:40:17Z  
    It appears all the time.
    Very odd, what's your full IHS version and OS version? Are you sure you didn't use a downloaded mod_mpmstats.so and used the one bundled with the product?
  • Sunit
    Sunit
    199 Posts

    Re: Help regarding mpmstats

    ‏2012-08-27T20:40:52Z  
    It appears all the time.
    What is ReportInterval set to?

    Here is more info on mod_mpmstats
    http://publib.boulder.ibm.com/httpserv/ihsdiag/2.0/mod_mpmstats.html#ReportInterval

    • Sunit
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Help regarding mpmstats

    ‏2012-08-28T06:17:10Z  
    Very odd, what's your full IHS version and OS version? Are you sure you didn't use a downloaded mod_mpmstats.so and used the one bundled with the product?
    This is my specification:

    OS: Red Hat Linux 2.6.32-131.0.15.el6.x86_64
    App Server: IBM WebSphere Application Server: Version - 7.0.0.17 (x64)
    Web Server: IBM_HTTP_Server/7.0.0.17

    I have used which comes with the product.
  • SystemAdmin
    SystemAdmin
    3908 Posts

    Re: Help regarding mpmstats

    ‏2012-08-28T06:18:06Z  
    • Sunit
    • ‏2012-08-27T20:40:52Z
    What is ReportInterval set to?

    Here is more info on mod_mpmstats
    http://publib.boulder.ibm.com/httpserv/ihsdiag/2.0/mod_mpmstats.html#ReportInterval

    • Sunit
    I have given 600 for the ReportInterval.

    Regards,
    JagadesH L.
  • Sunit
    Sunit
    199 Posts

    Re: Help regarding mpmstats

    ‏2012-08-28T13:41:24Z  
    I have given 600 for the ReportInterval.

    Regards,
    JagadesH L.
    So mpmstats should write a message every 10 minutes.

    Do you have any load whatsoever on the web server? Or none of the threads are being used?

    • Sunit