Topic
  • 14 replies
  • Latest Post - ‏2012-09-06T08:39:39Z by SystemAdmin
SystemAdmin
SystemAdmin
403 Posts

Pinned topic Web Services Explorer wont save

‏2012-08-24T13:30:56Z |
Hey,

I've been trying to record some requests for AppScan to scan my web service. To do this, I am using the web services explorer. All of this seems to work fine, but then when I go to close the Generic Services Client, the save as box appears as normal, but doesn't actually save the .zip file.

Help!

Thanks :)
Updated on 2012-09-06T08:39:39Z at 2012-09-06T08:39:39Z by SystemAdmin
  • warrenm1
    warrenm1
    224 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-27T14:58:10Z  
    Hi,

    This is a known issue if you have both a previous version of the web services component and the new version installed. Please uninstall all versions you currently have in add/remove programs and install only the most and this should remdy the issue for you.

    Regards,
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-28T09:01:53Z  
    • warrenm1
    • ‏2012-08-27T14:58:10Z
    Hi,

    This is a known issue if you have both a previous version of the web services component and the new version installed. Please uninstall all versions you currently have in add/remove programs and install only the most and this should remdy the issue for you.

    Regards,
    Hey,

    I've tried uninstalling all versions of the web services explorer (there was only one) and then reinstalling and that didn't fix the problem. Any other ideas?

    Thanks.
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-28T09:15:20Z  
    • warrenm1
    • ‏2012-08-27T14:58:10Z
    Hi,

    This is a known issue if you have both a previous version of the web services component and the new version installed. Please uninstall all versions you currently have in add/remove programs and install only the most and this should remdy the issue for you.

    Regards,
    I've also tried it on a couple of other computers (that definitely won't have had it installed before) and have the same problem there. Its version 8.6.0.0.
  • bbrazeau
    bbrazeau
    148 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-28T12:49:09Z  
    I've also tried it on a couple of other computers (that definitely won't have had it installed before) and have the same problem there. Its version 8.6.0.0.
    Hi,

    Are you running AppScan Standard or AppScan Enterprise? Also, what operating system are you using and have you installed/run the GSC tool as an administrator?

    -B
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-28T14:14:26Z  
    • bbrazeau
    • ‏2012-08-28T12:49:09Z
    Hi,

    Are you running AppScan Standard or AppScan Enterprise? Also, what operating system are you using and have you installed/run the GSC tool as an administrator?

    -B
    I am running AppScan enterprise on a company server, but have installed the GSC tool on my local machine running Windows 7. Yes I have installed and run the tool as an administrator.
  • bbrazeau
    bbrazeau
    148 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-28T16:52:26Z  
    I am running AppScan enterprise on a company server, but have installed the GSC tool on my local machine running Windows 7. Yes I have installed and run the tool as an administrator.
    Hi,

    I also have the GSC tool running locally on a Windows 7 machine and the dialog to save the zip file appears successfully. Are you running the GSCLauncher.exe executable to bring up the GSC tool or running GSC.exe ?

    -B
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-29T08:18:44Z  
    • bbrazeau
    • ‏2012-08-28T16:52:26Z
    Hi,

    I also have the GSC tool running locally on a Windows 7 machine and the dialog to save the zip file appears successfully. Are you running the GSCLauncher.exe executable to bring up the GSC tool or running GSC.exe ?

    -B
    The dialog appears but when I actually tell it to save it doesn't do anything (I have checked that there isn't a hidden file or anything). I run the GSCLauncher.exe executable.
  • bbrazeau
    bbrazeau
    148 Posts

    Re: Web Services Explorer wont save

    ‏2012-08-29T13:58:02Z  
    The dialog appears but when I actually tell it to save it doesn't do anything (I have checked that there isn't a hidden file or anything). I run the GSCLauncher.exe executable.
    The only other thing I can think of is that there is a problem with permissions when trying to save the file on the system. I would get in touch with the support team to see if they can help you out with this. You can open up a ticket with them by calling 1-800-IBM-SERV or by visiting http://www.ibm.com/support/servicerequest/ .

    -B
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-09-05T08:33:18Z  
    I managed to get the file to save by downloading an older version (8.1) of the GSC, but if I only include endpoints in the client then the saved file is empty.

    My web service does not have a WSDL, I simply want to record a set of requests and have AppScan execute these (with headers and authentication) on a regular basis to check that there are no security issues with them. Is this possible using only endpoints, or am I doing it wrong?

    Thanks
  • bbrazeau
    bbrazeau
    148 Posts

    Re: Web Services Explorer wont save

    ‏2012-09-05T14:02:47Z  
    I managed to get the file to save by downloading an older version (8.1) of the GSC, but if I only include endpoints in the client then the saved file is empty.

    My web service does not have a WSDL, I simply want to record a set of requests and have AppScan execute these (with headers and authentication) on a regular basis to check that there are no security issues with them. Is this possible using only endpoints, or am I doing it wrong?

    Thanks
    So when you save the WebServicesImportPackage.zip file, it does not contain the urls.txt or workspace.encoded file?

    Both files should be in the .zip file, regardless if any data was entered into the GSC tool.

    -B
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-09-05T15:17:00Z  
    • bbrazeau
    • ‏2012-09-05T14:02:47Z
    So when you save the WebServicesImportPackage.zip file, it does not contain the urls.txt or workspace.encoded file?

    Both files should be in the .zip file, regardless if any data was entered into the GSC tool.

    -B
    No they are in the file, but when I upload it to AppScan and run the scan I get an error message saying 'CRWAE1750E  No Web Services URLs specified in the job options'.
  • bbrazeau
    bbrazeau
    148 Posts

    Re: Web Services Explorer wont save

    ‏2012-09-05T16:49:20Z  
    No they are in the file, but when I upload it to AppScan and run the scan I get an error message saying 'CRWAE1750E  No Web Services URLs specified in the job options'.
    If you open urls.txt file, is your WSDL url listed? If not, are you entering a full http url link when selecting 'add endpoint request'?

    -B
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-09-06T08:32:30Z  
    • bbrazeau
    • ‏2012-09-05T16:49:20Z
    If you open urls.txt file, is your WSDL url listed? If not, are you entering a full http url link when selecting 'add endpoint request'?

    -B
    Yes it has all the endpoints that I provided in the urls file. My web service doesn't actually have a wsdl so all I can provide is endpoint requests.
  • SystemAdmin
    SystemAdmin
    403 Posts

    Re: Web Services Explorer wont save

    ‏2012-09-06T08:39:39Z  
    • bbrazeau
    • ‏2012-09-05T16:49:20Z
    If you open urls.txt file, is your WSDL url listed? If not, are you entering a full http url link when selecting 'add endpoint request'?

    -B
    They are also listed in AppScan when I upload the file, in the "Web Service URL" list.