• 3 replies
  • Latest Post - ‏2012-08-10T22:53:25Z by EricJackson
2 Posts

Pinned topic Need help with JPA 2.0 in WAS 7.0

‏2012-08-09T19:06:14Z |
I have WAS installed (test server running under RAD I installed the feature pack for OSGi and JPA 2.0. It shows up in my install manager history and it shows up as being installed for the profile that I am using.
C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\profiles\WTE_APPSRV71\bin>versionInfo.bat
WVER0010I: Copyright (c) IBM Corporation 2002, 2005, 2008; All rights reserved.
WVER0012I: VersionInfo reporter version, dated 6/15/11

IBM WebSphere Application Server Product Installation Status Report

Report at date and time August 9, 2012 1:59:41 PM CDT


Product Directory C:\Program Files (x86)\IBM\SDP\runtimes\base_v7
Version Directory C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\properties\version
DTD Directory C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\properties\version\dtd
Log Directory C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\logs
Backup Directory C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\properties\version\nif\backup
TMP Directory C:\Users\g63vk0\AppData\Local\Temp

Product List

ARIESJPA installed
BASE installed

Installed Product

Name Feature Pack for OSGi Applications and Java Persistence API 2.0
Build Level cf071218.02
Build Date 5/1/12
Architecture Intel (32 bit)

Installed Product

Name IBM WebSphere Application Server
Build Level cf231218.02
Build Date 4/30/12
Architecture Intel (32 bit)

End Installation Status Report

However, when I run the jpa version checker, it still shows openjpa 1.2.3 as being active. Am I missing some step here? I am at a loss as to how to proceed. Any help would be appreciated.

C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\profiles\WTE_APPSRV71\bin>wsjpaversion.bat
version id: WSJPA-1.2.1-SNAPSHOT-r1118:2454
revision: 1118:2454

version id: openjpa-1.2.3-SNAPSHOT-r422266:1295280
Apache svn revision: 422266:1295280 Windows 7
os.version: 6.1 build 7601 Service Pack 1
os.arch: x86

java.version: 1.6.0
java.vendor: IBM Corporation

C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\dev\JavaEE\j2ee.jar
C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\plugins\
C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\plugins\

user.dir: C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\profiles\WTE_APPSRV71\bin
Updated on 2012-08-10T22:53:25Z at 2012-08-10T22:53:25Z by EricJackson
  • leealber
    5 Posts

    Re: Need help with JPA 2.0 in WAS 7.0

    Have you augmented the profile? Otherwise, the profile is still using the V7 JPA provider.

    See for more details.

    Albert Lee
  • leealber
    5 Posts

    Re: Need help with JPA 2.0 in WAS 7.0

    Try this link instead:
  • EricJackson
    2 Posts

    Re: Need help with JPA 2.0 in WAS 7.0

    • leealber
    • ‏2012-08-09T20:31:19Z
    Try this link instead:
    Well I tried! I was unable to determine which version of the deployment manager I had, since it was created for me.

    manageprofiles.bat -listAugments kept giving me an error. There must have been something messed up with the profile. I ultimately just tried to delete the profile and create a new one and that failed too, leaving me in a state where the only thing I could effectively do was just blow everything (as in uninstall WAS and RAD) and start over.

    On the next install, I held off creating a profile until after I had updated both RAD and WAS and applied the fix pack. Then I let the tool create a profile for me and it correctly reports that it is using jpa 2.

    C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\profiles\WTE_APPSRV7_FEP1\bin>wsjpaversion.bat
    version id: WSJPA-2.0.1-SNAPSHOT-r1118:2323
    WebSphere JPA svn revision: 1118:2323

    OpenJPA 2.0.2-SNAPSHOT
    version id: openjpa-2.0.2-SNAPSHOT-r422266:1295351
    Apache svn revision: 422266:1295351

    When I run the manageprofiles.bat tool on the profile, it now seems to run (whereas before it would not).

    C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\profiles\WTE_APPSRV7_FEP1\bin>manageprofiles.bat -listAugments -profileName WTE_APPSRV7_FEP1
    Registered Augment Templates
    C:\Program Files (x86)\IBM\SDP\runtimes\base_v7\profileTemplates\JPA\default.jpafep
    I am thinking that maybe for the next developer, I'll just create a new profile and not bother with trying to augment existing profiles.

    Thanks for the assistance.

    • Eric