Topic
  • 6 replies
  • Latest Post - ‏2012-08-22T13:52:39Z by cmack
cmack
cmack
14 Posts

Pinned topic -d flag for GPFS command mmdefquotaon seems to be broken or man page wrong

‏2012-08-09T15:44:28Z |
Please note the man pages for mmdefquotaon; where it states:

-d
Specifies that existing users, groups of users, or filesets with no established quota limits will have default quota values assigned when the mmdefedquota command is issued.
If this option is not chosen, existing quota entries remain in effect and are not governed by the default quota rules.
root@rc-gridscaler-1 nfsexport# mmfsadm dump version|grep branch
Build branch "3.4.0.11 ".

root@rc-gridscaler-1 nfsexport# mmdefquotaon -u -d gs1
root@rc-gridscaler-1 nfsexport# mmdefedquota -u gs1

  • Edit quota limits for USR DEFAULT entry
NOTE: block limits will be rounded up to the next multiple of the block size.
block units may be: K, M, G, or T.
gs1: blocks in use: 0K, limits (soft = 4294967296K, hard = 4294967296K)
inodes in use: 0, limits (soft = 0, hard = 0)

root@rc-gridscaler-1 nfsexport# mmlsfs gs1 -Q
flag value description

------------------------
-Q user;group;fileset Quotas enforced
user;group;fileset Default quotas enabled
New user "jlmcginn" has a 4TB default quota, but existing user "fding" and numerous others does not, that's not right:

root@rc-gridscaler-1 nfsexport# mmrepquota gs1
Block Limits | File Limits
Name type KB quota limit in_doubt grace | files quota limit in_doubt grace

fding USR 10904636 0 0 0 none | 146 0 0 0 none
root USR 1670024 0 0 0 none | 3685 0 0 0 none
jlmcginn USR 8 4294967296 4294967296 0 none | 1 0 0 0 none

Please tell me either; what I am doing wrong, if this is a doc-bug, or a software bug...running mmcheckquota doesn't help either...
Updated on 2012-08-22T13:52:39Z at 2012-08-22T13:52:39Z by cmack
  • truongv
    truongv
    98 Posts

    Re: -d flag for GPFS command mmdefquotaon seems to be broken or man page wrong

    ‏2012-08-09T19:57:50Z  
    I could not recreate what you saw. It behaves correctly for me.
    
    -d Specifies that existing users, groups of users, or filesets with no established quota limits will have 
    
    default quota values assigned when the mmdefedquota command is issued. If 
    
    this option is not chosen, existing quota entries remain in effect and are not governed by the 
    
    default quota rules.
    

    It says that existing users with no established quota limits...please check on that.
  • cmack
    cmack
    14 Posts

    Re: -d flag for GPFS command mmdefquotaon seems to be broken or man page wrong

    ‏2012-08-10T13:14:30Z  
    • truongv
    • ‏2012-08-09T19:57:50Z
    I could not recreate what you saw. It behaves correctly for me.
    <pre class="jive-pre"> -d Specifies that existing users, groups of users, or filesets with no established quota limits will have default quota values assigned when the mmdefedquota command is issued. If this option is not chosen, existing quota entries remain in effect and are not governed by the default quota rules. </pre>
    It says that existing users with no established quota limits...please check on that.
    I believe the information above already shows that; plus, this is the very first and only quota...the default quota:
    See user "fding" has no quota as he wrote data to the filesystem prior to the default quota being created. User "jlmcginn" wrote to teh filesystem after the default quota was put in place. He has a quota.
    But just for grins; let's see:
    root@rc-gridscaler-1 nfsexport# mmlsquota
    Block Limits | File Limits
    Filesystem type KB quota limit in_doubt grace | files quota limit in_doubt grace Remarks
    gs1 USR no limits
    root@rc-gridscaler-1 nfsexport# mmlsquota -d -u gs1
    Default Block Limits(KB) | Default File Limits
    Filesystem type quota limit | quota limit Remarks
    gs1 USR 4294967296 4294967296 | 0 0
    So, bug?

    root@rc-gridscaler-1 nfsexport# mmfsadm dump version|grep branch
    Build branch "3.4.0.11 ".
  • cmack
    cmack
    14 Posts

    Re: -d flag for GPFS command mmdefquotaon seems to be broken or man page wrong

    ‏2012-08-10T14:36:00Z  
    • cmack
    • ‏2012-08-10T13:14:30Z
    I believe the information above already shows that; plus, this is the very first and only quota...the default quota:
    See user "fding" has no quota as he wrote data to the filesystem prior to the default quota being created. User "jlmcginn" wrote to teh filesystem after the default quota was put in place. He has a quota.
    But just for grins; let's see:
    root@rc-gridscaler-1 nfsexport# mmlsquota
    Block Limits | File Limits
    Filesystem type KB quota limit in_doubt grace | files quota limit in_doubt grace Remarks
    gs1 USR no limits
    root@rc-gridscaler-1 nfsexport# mmlsquota -d -u gs1
    Default Block Limits(KB) | Default File Limits
    Filesystem type quota limit | quota limit Remarks
    gs1 USR 4294967296 4294967296 | 0 0
    So, bug?

    root@rc-gridscaler-1 nfsexport# mmfsadm dump version|grep branch
    Build branch "3.4.0.11 ".
    Also, english is hard and all...but the man page first sentence to the second seem to negate one another a bit:

    Specifies that existing users, groups of users, or filesets with no established quota limits will have default quota values assigned when the mmdefedquota command is issued.

    Seems to indicate that folks without a quota will have the default quota enforced upon them.

    If this option is not chosen, existing quota entries remain in effect and are not governed by the default quota rules.

    Seems to indicate that by choosing this option the default quota will overwrite existing quotas enforcing the default upon them. I always hate negative definitions / descriptions of usage...positive ones are much easier and more clear to understand.
    So doc bug too?
  • cmack
    cmack
    14 Posts

    Re: -d flag for GPFS command mmdefquotaon seems to be broken or man page wrong

    ‏2012-08-17T18:01:37Z  
    • cmack
    • ‏2012-08-10T14:36:00Z
    Also, english is hard and all...but the man page first sentence to the second seem to negate one another a bit:

    Specifies that existing users, groups of users, or filesets with no established quota limits will have default quota values assigned when the mmdefedquota command is issued.

    Seems to indicate that folks without a quota will have the default quota enforced upon them.

    If this option is not chosen, existing quota entries remain in effect and are not governed by the default quota rules.

    Seems to indicate that by choosing this option the default quota will overwrite existing quotas enforcing the default upon them. I always hate negative definitions / descriptions of usage...positive ones are much easier and more clear to understand.
    So doc bug too?
    bump;

    1. mmrepquota gs1|grep 4294967296 |wc -l
    87

    1. mmrepquota gs1|grep -z 4294967296 |wc -l
    531
  • SystemAdmin
    SystemAdmin
    2092 Posts

    Re: -d flag for GPFS command mmdefquotaon seems to be broken or man page wrong

    ‏2012-08-20T14:14:39Z  
    Please provide the output of mmrepquota with -u -v flag for the above mentioned ids.
  • cmack
    cmack
    14 Posts

    Re: -d flag for GPFS command mmdefquotaon seems to be broken or man page wrong

    ‏2012-08-22T13:52:39Z  
    Please provide the output of mmrepquota with -u -v flag for the above mentioned ids.
    I figure it out. Restarting the system or turning off the default quota and back on fixed the bug... no other changes made...