Topic
  • 4 replies
  • Latest Post - ‏2012-08-13T08:14:23Z by SystemAdmin
SystemAdmin
SystemAdmin
648 Posts

Pinned topic Error Importing catalog content from version 5.3 into PIM collaboration

‏2012-08-08T06:56:28Z |
Hi,

I am moving a company from version 5.3 to version 10 of PIM. So far we had no troubles importing the model and data into the new version.
But when trying to import an item that had date attributes it seems that version 10 uses different date then earlier versions (I tried from version 9 to 10 also).
This is the Error I get and I hope there is someone who can help me with this:

Error building entries while processing catalog at line number [1] for token [/primspec/datefield|Thu Jul 24 17:34:47 CEST 2008] with error Exception:CWPEL0083E:Type Conversion Error: the value is Thu Jul 24 17:34:47 CEST 2008 the node is primspec/datefield and node's type is DATE and locale is en_US
CWPEL0083E:Type Conversion Error: the value is Thu Jul 24 17:34:47 CEST 2008 the node is primspec/datefield and node's type is DATE and locale is en_US
Updated on 2012-08-13T08:14:23Z at 2012-08-13T08:14:23Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    648 Posts

    Re: Error Importing catalog content from version 5.3 into PIM collaboration

    ‏2012-08-08T07:42:08Z  
    Hi,

    Be best way, I think, is to open a PMR
  • SystemAdmin
    SystemAdmin
    648 Posts

    Re: Error Importing catalog content from version 5.3 into PIM collaboration

    ‏2012-08-08T12:25:22Z  
    Hi

    I saw I had this problem before, moving from version 9 to 10.
    You then told me to try to change the timezone.

    This time I did change it to CEST, like it is in the file, my systems timezone was pdt.
    Still no luck.

    So i tried something else. I created a new item on the version 10 system and exported that catalog.
    I still get the same error, so might be indeed that a PMR will be needed. I will contact some IBM people i guess. Or if anyone else has a nice solution, I am open for everything since this is holding us back badly.
  • KaranBal
    KaranBal
    108 Posts

    Re: Error Importing catalog content from version 5.3 into PIM collaboration

    ‏2012-08-12T22:20:15Z  
    Hi

    I saw I had this problem before, moving from version 9 to 10.
    You then told me to try to change the timezone.

    This time I did change it to CEST, like it is in the file, my systems timezone was pdt.
    Still no luck.

    So i tried something else. I created a new item on the version 10 system and exported that catalog.
    I still get the same error, so might be indeed that a PMR will be needed. I will contact some IBM people i guess. Or if anyone else has a nice solution, I am open for everything since this is holding us back badly.
    v-10 does not handle dates any differently from v-5.3. There are some database schema changes but they are all enhancements and they shouldn't break anything in your environment. I would suggest converting the source date format to GMT format and trying again. If that doesn't work, then please open a PMR.
  • SystemAdmin
    SystemAdmin
    648 Posts

    Re: Error Importing catalog content from version 5.3 into PIM collaboration

    ‏2012-08-13T08:14:23Z  
    Hi,

    Thank you for your response.
    It is not really solved since I am still getting the same error on my Local Vm installation, but on the server of the client the import works fine.
    Seems to be a problem of my own installation. I still do not know how to fix it, but for now i can continue and will have to reinstall my local VM or change some settings in it.