Topic
  • 3 replies
  • Latest Post - ‏2012-08-24T21:56:24Z by flurry
flurry
flurry
2 Posts

Pinned topic Errors running builder 'Android Package Builder' ... sun/security/x509/X500

‏2012-08-02T22:33:48Z |
I am trying to develop an Android application. I am following the dW article http://www.ibm.com/developerworks/mobile/library/mo-aim1206-working-with-worklight-1/index.html?cmp=dw&cpb=dwmob&ct=dwnew&cr=dwnen&ccy=zz&csr=062212. I am running on Windows 7. I am using Worklight 5.0.1 in Eclipse Indigo release 2 (EE IDE). I downloaded the Sun JDK 6.0 update 33 (32 bit) and pointed my project at that. When I attempt to run the Android application (fig.16 of the article), I get a build error "Errors running builder 'Android Package Builder' on project 'Todo ProjectTodoAndroid'.
sun/security/x509/X500Name".

I've done some searching and it appears to have something to do with signing of jars, or the keytool or something. See http://osdir.com/ml/Android-Developers/2011-02/msg04421.html; or see https://www.ibm.com/developerworks/mydeveloperworks/blogs/94e7fded-7162-445e-8ceb-97a2140866a9/entry/developing_hybrid_applications_for_android_try_mobile_web_tools_in_rad_8_0_3_ifix1?lang=en.

I cannot figure out what to do to make things work. Help.
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: Errors running builder 'Android Package Builder' ... sun/security/x509/X500

    ‏2012-08-02T22:52:14Z  
    This looks like the error you get when you don't use the Oracle JRE to run eclipse. The IBM JRE won't work because the Android Development Tools plug-in uses some internal Sun classes.

    If you have more than one JRE installed on your system, you may need to use the -vm option in eclipse.ini to tell it to use the right one.

    You can check which JRE you are pointed to by going to Windows->Preferences->Java->Installed JREs. By default the only one you get is the one used to launch eclipse. (Adding the Oracle JRE here won't help, it has to be the JRE that eclipse itself is using)
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: Errors running builder 'Android Package Builder' ... sun/security/x509/X500

    ‏2012-08-03T05:17:06Z  
    Edit eclipse.ini above the varargs
    -vm C:\Java\JDK\1.5\bin\javaw.exe
    Save and run Eclipse.

    src: http://stackoverflow.com/a/6881907/186909
  • flurry
    flurry
    2 Posts

    Re: Errors running builder 'Android Package Builder' ... sun/security/x509/X500

    ‏2012-08-24T21:56:24Z  
    The answers provided enough information to fix the problem, even if they did not exactly describe the right details.