Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
4 replies Latest Post - ‏2012-10-02T04:44:03Z by IDMGuy
abouchard
abouchard
11 Posts
ACCEPTED ANSWER

Pinned topic TIM Adapter Development Tool won't run

‏2012-08-02T16:55:52Z |
All,

I just downloaded and install ADT 5.1.2.3. The install went fine, no errors or warning.

The problem I am having is that when I double click the shortcut or the exe file, it won't run. And I don't have any errors in the log. Do you have any hints where I could look to find a solution?

Here is the environment I am working with :

Windows Server 2003 R2
TIM 5.1
TDI 7.0

Thanks
Updated on 2012-10-02T04:44:03Z at 2012-10-02T04:44:03Z by IDMGuy
  • abouchard
    abouchard
    11 Posts
    ACCEPTED ANSWER

    Re: TIM Adapter Development Tool won't run

    ‏2012-08-02T19:30:53Z  in response to abouchard
    To help, I just found a log and here is the error :

    eclipse.buildId=unknown
    java.version=1.6.0_21
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
    Command-line arguments: -os win32 -ws win32 -arch x86

    !ENTRY org.eclipse.osgi 4 0 2012-08-02 06:57:35.858
    !MESSAGE Application error
    !STACK 1
    java.lang.NoClassDefFoundError: com/ibm/di/config/interfaces/ConnectorConfig

    It must be related to the JVM used or the classpath. I just don't know where to look to change it.
    • SystemAdmin
      SystemAdmin
      9855 Posts
      ACCEPTED ANSWER

      Re: TIM Adapter Development Tool won't run

      ‏2012-09-25T08:50:51Z  in response to abouchard
      Hello,
      I guess this tool is not meant for being supported by 64 bit OS.
      I have exactly teh same problem.

      java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:197)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
      at org.eclipse.swt.internal.C.<clinit>(C.java:21)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:138)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:686)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:161)
      at com.ibm.itim.tools.adt.Application.start(Application.java:16)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1383)

      Did you get a chance to solve this?
      Best regards:
      Manila
      • SystemAdmin
        SystemAdmin
        9855 Posts
        ACCEPTED ANSWER

        Re: TIM Adapter Development Tool won't run

        ‏2012-09-25T09:08:23Z  in response to SystemAdmin
        Hello,
        I guess , I should share my solution. And if you did solve it, then you must have solved, by copying or installing a JVM of 32 bit and then set it in the path and voila!! it runs !!!
        Bon courage!!
        Manila
        • IDMGuy
          IDMGuy
          7 Posts
          ACCEPTED ANSWER

          Re: TIM Adapter Development Tool won't run

          ‏2012-10-02T04:44:03Z  in response to SystemAdmin
          Solution to your problem is to install 32 bit JDK on the machine. Then create a batch file and set path env variable to JDK bin folder, then have the command to start the ADT. Your batch file should look like this

          
          @ECHO OFF   REM - Drive on which ADT is installed [
          
          for me it was D: drive]   D:   REM - Change directory to ADT executable   cd D:\IBM\ITIM Adapter Development Tool   REM - SET JDK 32-bit PATH variable   set PATH=%PATH%;C:\Program Files (x86)\Java\jdk1.6.0_07\bin   REM - Issue the below command to start ADT   %windir%\system32\cmd.exe /c start /b ITIMAdapterDevelopmentTool.exe
          


          Remove the REM lines if the batch doesn't execute. I hope this helps.