Topic
2 replies Latest Post - ‏2012-09-10T23:26:43Z by Ron_Smith
Ron_Smith
Ron_Smith
6 Posts
ACCEPTED ANSWER

Pinned topic MQ explorer 7.1 and CICS explorer - Joe Winchester

‏2012-07-31T21:25:47Z |
I was following the instructions given by Joe Winchester for MQ explorer 7.1 to CICS explorer 1.1.1.1

I am on step 3 - add Java tooling into CICS explorer
when I try to install the java development tools I get the following errors

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse Java Development Tools 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F (org.eclipse.jdt.feature.group 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F)
Software currently installed: IBM CICS Explorer 1.1.1.1_201205240100 (com.ibm.cics.explorer.product 1.1.1.1_201205240100)
Only one of the following can be installed at once:
Help System Webapp 3.5.4.r36_20120404 (org.eclipse.help.webapp 3.5.4.r36_20120404)
Help System Webapp 3.5.2.r36_r20100816 (org.eclipse.help.webapp 3.5.2.r36_r20100816)
Help System Webapp 3.5.3.r36_20101130 (org.eclipse.help.webapp 3.5.3.r36_20101130)
Help System Webapp 3.5.0.v20100507 (org.eclipse.help.webapp 3.5.0.v20100507)
Cannot satisfy dependency:
From: Eclipse Platform for Explorer 3.6.2.201205240100 (com.ibm.cics.eclipse.platform.feature.feature.group 3.6.2.201205240100)
To: org.eclipse.help.webapp http://3.5.4.r36_20120404
Cannot satisfy dependency:
From: IBM CICS Explorer 1.1.1.1_201205240100 (com.ibm.cics.explorer.product 1.1.1.1_201205240100)
To: com.ibm.cics.eclipse.platform.feature.feature.group http://3.6.2.201205240100
Cannot satisfy dependency:
From: Eclipse Help System 1.2.1.r362_v20101111-7e7jEVFDr6xg-LSlC_z0w1D (org.eclipse.help.feature.group 1.2.1.r362_v20101111-7e7jEVFDr6xg-LSlC_z0w1D)
To: org.eclipse.help.webapp http://3.5.3.r36_20101130
Cannot satisfy dependency:
From: Eclipse Java Development Tools 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F (org.eclipse.jdt.feature.group 3.6.2.r362_v20101117-0800-7z8XFW6FLFlmjJcvz03jyeFBLS_F)
To: org.eclipse.platform.feature.group 3.6.2
Cannot satisfy dependency:
From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)
To: org.eclipse.help.feature.group http://1.2.1.r362_v20101111-7e7jEVFDr6xg-LSlC_z0w1D
Updated on 2012-09-10T23:26:43Z at 2012-09-10T23:26:43Z by Ron_Smith
  • JoeWinchester
    JoeWinchester
    32 Posts
    ACCEPTED ANSWER

    Re: MQ explorer 7.1 and CICS explorer - Joe Winchester

    ‏2012-09-04T15:52:17Z  in response to Ron_Smith
    Hi Ron,

    This issue was introduced in CICS Explorer 1.1.1.1 where we had to upgrade the help plugin org.eclipse.help.webapp to 3.5.4. The Eclipse Java tooling has a hard dependency on 3.5.3, and because the CICS Explorer has a later version this is stopping the install from proceeding.

    The only way I can suggest to resolve this, is to aggregate the combination of the three things - Eclipse components, CICS Explorer, MQ Explorer - differently. The approach you were using before (which did work until the CICS Explorer 1.1.1.1 release) was to start with CICS Explorer - add in some Eclipse components (the Java and debug tooling) and then add in the MQ Explorer. If however you start with Eclipse - then add in the CICS Explorer - then MQ Explorer, this should work.

    Step 1- get Eclipse 3.6.2. This is a good URL to get a build from - http://archive.eclipse.org/eclipse/downloads/drops/R-3.6.2-201102101200/
    Step 2- get CICS Explorer SDK. This is the set of plugins that are the CICS Explorer minus the Eclipse ones. You can then install this into the Eclipse you got in step 1 by downloading it as a .zip file and install from it as an archive update site, or else pointing your Eclipse at http://public.dhe.ibm.com/software/htp/cics/updates/explorer/1.1/1.1.1/ (which is our update site) and installing from there. This means you now have Eclipse + CICS Explorer
    When you launch this it will open with the Eclipse splash screen - rather than the CICS Explorer. If you want to make it open with the CICS Explorer splash screen you can edit the eclipse.ini file and put the line "-product com.ibm.cics.explorer.product" which should now launch Eclipse as though it was the CICS Explorer
    Step 3- Install the MQ Explorer from the MQExplorerSDK.zip.

    Let me know if this works or not - if it doesn't I'll write a blog entry and post a link to it with screen shots and a bit more detail on where things can go wrong, etc...

    Apologies for not seeing your post sooner - thanks for letting us know that the integration was broken. Going forward, in an ideal scenario, how would you like to see integration between CICS and MQ Explorer working. Improving integration is something we're keen to address, so any feedback would be great, and also once you have CICS and MQ Explorer together, what are the operational scenarios where the two side by side would help. Do you want to go from a CICS Region straight to the list of queues - from trigger queues to CICS tasks - etc...

    Best regards and many thanks,

    Joe
  • Ron_Smith
    Ron_Smith
    6 Posts
    ACCEPTED ANSWER

    Re: MQ explorer 7.1 and CICS explorer - Joe Winchester

    ‏2012-09-10T23:26:43Z  in response to Ron_Smith
    Thanks Joe.
    I will give that a try and let you know.
    I have a different PC now so it will be like a fresh install.
    One would wish it could be a touch easier.
    We would like to go into the MQ queues that CICS is using to keep it all in one spot.