Topic
  • 10 replies
  • Latest Post - ‏2013-10-18T07:01:27Z by BhupathiReddy
MoatazElSayed
MoatazElSayed
14 Posts

Pinned topic DB2Connector and OracleConnector are not working

‏2012-07-29T12:09:52Z |
Hi All,

While using Information Analyzer and trying to add a DB2 data source. I faced an issue with using DB2Connector or OracleConnector. However I can use ODBC connector properly.

Has anyone face the same issue before?

Regards,
Moataz ElSayed
Updated on 2012-08-17T20:06:56Z at 2012-08-17T20:06:56Z by MoatazElSayed
  • RobertDickson
    RobertDickson
    74 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-07-29T21:49:47Z  
    Hi Moataz,

    Kind of hard to say with out details (version, platform, specific issue encountered...).

    Taking a shot in the dark, try http://www-01.ibm.com/support/docview.wss?uid=swg1JR37598

    Good luck!
    Robert
  • MoatazElSayed
    MoatazElSayed
    14 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-07-31T14:03:51Z  
    Hi Robert,

    Thanks for reminding me to add some details about the environment used:

    OS: Red Hat Enterprise Linux Server release 5.5 (Tikanga)
    IA version: 8.7
    Error Message: Unable to connect successfully using the selected connector. Check to ensure the selected connector is installed on the engine tier or select a different connector to establish the connection.

    I got the error once I choose DB2Connector or OracleConnector.

    So did any one face this error before?

    Regards,
    Moataz ElSayed
  • RobertDickson
    RobertDickson
    74 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-07-31T14:22:17Z  
    Hi Robert,

    Thanks for reminding me to add some details about the environment used:

    OS: Red Hat Enterprise Linux Server release 5.5 (Tikanga)
    IA version: 8.7
    Error Message: Unable to connect successfully using the selected connector. Check to ensure the selected connector is installed on the engine tier or select a different connector to establish the connection.

    I got the error once I choose DB2Connector or OracleConnector.

    So did any one face this error before?

    Regards,
    Moataz ElSayed
    Hi Moataz,

    Yes, that does help a bit :) I have see this before.

    Have you tried recycling the NodeAgents on your server?

    Regards,
    Robert
  • RobertDickson
    RobertDickson
    74 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-07-31T14:25:08Z  
    Hi Moataz,

    Yes, that does help a bit :) I have see this before.

    Have you tried recycling the NodeAgents on your server?

    Regards,
    Robert
    Hi Moataz,

    I almost forgot - have you installed the latest Information Analyzer RollUp patch from Fix Central?


    Regards,
    Robert
  • MoatazElSayed
    MoatazElSayed
    14 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-08-05T02:03:04Z  
    Hi Moataz,

    I almost forgot - have you installed the latest Information Analyzer RollUp patch from Fix Central?


    Regards,
    Robert
    Hi Robert,

    Do you mean by recycling the NodeAgents to stop/start the NodeAgents services or something else?

    Also I will try to update IS, the current version I use is: 8.7.0.302 and the latest is 8.7.0.328? Although the readme file attached with update package doesn't mention any issue fix related to OracleConnector or DB2Connector.
    Thanks,
    Moataz
  • MoatazElSayed
    MoatazElSayed
    14 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-08-05T13:47:56Z  
    Hi All,

    Should I install Oracle Connector and DB2Connector, each in a separate installation? or they are in Information Server as one bundle installation ?

    Thanks,
    Moataz
  • RobertDickson
    RobertDickson
    74 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-08-05T20:21:30Z  
    Hi Robert,

    Do you mean by recycling the NodeAgents to stop/start the NodeAgents services or something else?

    Also I will try to update IS, the current version I use is: 8.7.0.302 and the latest is 8.7.0.328? Although the readme file attached with update package doesn't mention any issue fix related to OracleConnector or DB2Connector.
    Thanks,
    Moataz
    Hi Moataz,

    Yes, I mean the NodeAgents.sh -restart

    Regarding versions: Being up-to-date is usually a good thing :) Also, 8.7 Fix Pack 1 was recently released. The fix list is at http://www-01.ibm.com/support/docview.wss?uid=swg21585489

    Regards,
    Robert
  • RobertDickson
    RobertDickson
    74 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-08-05T20:23:07Z  
    Hi All,

    Should I install Oracle Connector and DB2Connector, each in a separate installation? or they are in Information Server as one bundle installation ?

    Thanks,
    Moataz
    Hi Moataz,

    They are core components (used across many modules in Information Server), and do not need to be installed separately.

    Regards,
    Robert
  • MoatazElSayed
    MoatazElSayed
    14 Posts

    Re: DB2Connector and OracleConnector are not working

    ‏2012-08-17T20:06:56Z  
    Hi guys,

    This issue solved, It was a matter of configuring Oracle Home to be compatible with OS bit type. Once I installed Oracle Client 64 and set the value of ORACLE_HOME.

    Regards,
    Moataz
  • BhupathiReddy
    BhupathiReddy
    1 Post

    Re: DB2Connector and OracleConnector are not working

    ‏2013-10-18T07:01:27Z  
    Hi Robert,

    Thanks for reminding me to add some details about the environment used:

    OS: Red Hat Enterprise Linux Server release 5.5 (Tikanga)
    IA version: 8.7
    Error Message: Unable to connect successfully using the selected connector. Check to ensure the selected connector is installed on the engine tier or select a different connector to establish the connection.

    I got the error once I choose DB2Connector or OracleConnector.

    So did any one face this error before?

    Regards,
    Moataz ElSayed

    Hello Moataz ElSayed,

      We are experiencing this issue from yesterday.  Did you resolved the issue.

      The DSN is available in .odbc.ini file I am not sure why i am geting this.

    If you know the resolution could you please let me know ASAP.

     

    Thanks

    Bhupathi