Topic
3 replies Latest Post - ‏2012-10-08T13:48:28Z by Mark_Winton
SystemAdmin
SystemAdmin
30899 Posts
ACCEPTED ANSWER

Pinned topic Portal v8 theming - enable drag-and-drop

‏2012-07-27T08:06:37Z |
Hi all,

I'm new to Portal v8 theming, therefor I started changing the default80 theme accordingly to the wiki documentation.
Currently I'm struggling to enable drag-and-drop when I'm in edit-mode.
When I compare my generated html source code with the html source code generated by the default portal 8 theme. I can see that the dndSourceDefinitions are not defined.

Can someone point me into the right direction the change the dndSourceDefinitions?

Many thanks,

Br.

Wim
Updated on 2012-10-08T13:48:28Z at 2012-10-08T13:48:28Z by Mark_Winton
  • YRJQ_Joost_Ridderbos
    1 Post
    ACCEPTED ANSWER

    Re: Portal v8 theming - enable drag-and-drop

    ‏2012-09-26T08:55:57Z  in response to SystemAdmin
    Hi Wim,

    I was wondering if you have found the solution for drag and drop in the Portal v8 Theme. I am having the same issues.
    I hope you can help me out.

    Kind Regards,
    Joost
  • SystemAdmin
    SystemAdmin
    30899 Posts
    ACCEPTED ANSWER

    Re: Portal v8 theming - enable drag-and-drop

    ‏2012-10-06T18:02:59Z  in response to SystemAdmin
    Hi Wim,
    Export your theme xml and verify if these parameters are included in the xml.

    <parameter name="com.ibm.portal.theme.dnd.sources" type="string" update="set"><![CDATAibmDndColumn:com.ibm.pb.dnd.layout.LayoutColumnSource:vertical,ibmDndRow:com.ibm.pb.dnd.layout.LayoutRowSource:horizontal]></parameter>
    <parameter name="com.ibm.portal.themetype" type="string" update="set"><![CDATAssa]></parameter>
    Thanks
    Surender
    • Mark_Winton
      Mark_Winton
      110 Posts
      ACCEPTED ANSWER

      Re: Portal v8 theming - enable drag-and-drop

      ‏2012-10-08T13:48:28Z  in response to SystemAdmin
      I believe what SurenderReddy's on about is the issue mentioned at http://www-01.ibm.com/support/docview.wss?uid=swg21607292.

      It should also possible to fix the issue using the steps at http://infolib.lotus.com/resources/portal/8.0.0/doc/en_us/PT800ACD002/dev/themeopt_cust_copy_statictheme.html - this worked on our environment.