Topic
3 replies Latest Post - ‏2012-07-18T21:15:21Z by curtisr7
V.S.Sravan
V.S.Sravan
2 Posts
ACCEPTED ANSWER

Pinned topic WAS 7.0.0.13 + JPA 2.0.X

‏2012-07-18T10:12:27Z |
Hi,

We have WAS 7.0.0.13 installed on Linux server. If we run wsjpaversion command on profile it is using JPA 1.2.1 but we need it to be updated to 2.0.X:

WSJPA 1.2.1-SNAPSHOT
version id: WSJPA-1.2.1-SNAPSHOT-r1118:1872
revision: 1118:1872

OpenJPA 1.2.3-SNAPSHOT
version id: openjpa-1.2.3-SNAPSHOT-r422266:965640
Apache svn revision: 422266:965640

os.name: Linux
os.version: 2.6.18-238.9.1.el5
os.arch: amd64

java.version: 1.6.0
java.vendor: IBM Corporation

java.class.path:
/data/ibm/WebSphere/AppServer/dev/JavaEE/j2ee.jar
/data/ibm/WebSphere/AppServer/plugins/com.ibm.ws.jpa.jar
/data/ibm/WebSphere/AppServer/plugins/com.ibm.ws.prereq.commons-collections.jar

Can you please suggest me how to proceed further.
Updated on 2012-07-18T21:15:21Z at 2012-07-18T21:15:21Z by curtisr7
  • curtisr7
    curtisr7
    2 Posts
    ACCEPTED ANSWER

    Re: WAS 7.0.0.13 + JPA 2.0.X

    ‏2012-07-18T14:23:29Z  in response to V.S.Sravan
    You need to install the JPA 2.0 Feature Pack to get JPA 2 functionality on a WAS V7.

    I also recommend moving to a newer fix pack if at all possible, 7.0.0.13 is nearly two years old.

    Thanks,
    Rick
    • V.S.Sravan
      V.S.Sravan
      2 Posts
      ACCEPTED ANSWER

      Re: WAS 7.0.0.13 + JPA 2.0.X

      ‏2012-07-18T14:42:45Z  in response to curtisr7
      Hi Rick,

      Thanksk for the response. I was going through IBM info center and found the following link.

      http://www-01.ibm.com/support/docview.wss?uid=swg24032494

      Link tell us that we need fix pack 9 to be installed for installing JPA 2.0 Feature pack.

      Can you suggest.

      Thanks,
      Sravan.
      • curtisr7
        curtisr7
        2 Posts
        ACCEPTED ANSWER

        Re: WAS 7.0.0.13 + JPA 2.0.X

        ‏2012-07-18T21:15:21Z  in response to V.S.Sravan
        I believe you might need to use Installation Manager to install newer versions of the Feature Pack. I'll check with some colleagues tomorrow and follow up with you.

        http://www-01.ibm.com/support/docview.wss?uid=swg24023498

        Thanks,
        Rick