Topic
14 replies Latest Post - ‏2012-08-02T14:41:04Z by SystemAdmin
SystemAdmin
SystemAdmin
300 Posts
ACCEPTED ANSWER

Pinned topic [Solved] Developer edition install broken on Indigo?

‏2012-07-16T01:36:59Z |
I've recently had to rebuild my eclipse configuration. I'm using eclipse-jee-indigo-SR2-macosx-cocoa-x86_64 as the base eclipse install. This is the same eclipse that I have successfully used previously to do a Marketplace install of Worklight Developer Edition.

However, whenever I try to add Worklight to Eclipse Indigo now it seems to corrupt the eclipse install. The problem seems to be around the Rich Page Editor, and as far as I can make out, eclipse is pulling in some Juno classes when it satisfies the prerequisites for the Developer Edition install. Symptoms are: lots of error when I open an HTML with the rich page editor, and problems installing ADT after installing Worklight.

If I start with Juno, everything seems to just work.

Is anyone else seeing a (new) problem installing Developer Edition from the Marketplace in Indigo?

What is the status of Developer Edition on Juno? I saw in another thread that it is not yet supported, but right now it is the only thing I can get to work.
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: Developer edition install broken on Indigo?

    ‏2012-07-17T14:09:46Z  in response to SystemAdmin
    Hi,

    I'm attempting to reproduce now.

    Thanks,
    Nell
    • SystemAdmin
      SystemAdmin
      300 Posts
      ACCEPTED ANSWER

      Re: Developer edition install broken on Indigo?

      ‏2012-07-17T15:36:23Z  in response to SystemAdmin
      We have reproduced the issue and a defect will be opened internally to track it -- we'll let you know when we have more info on what the issue is/how it can be resolved.
      • SystemAdmin
        SystemAdmin
        300 Posts
        ACCEPTED ANSWER

        Re: Developer edition install broken on Indigo?

        ‏2012-07-17T15:52:41Z  in response to SystemAdmin
        It might be related to this issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=379473 which is getting reported by folks who are installing the WebSphere Development tools (which share features with Worklight Developer Edition)
        • SystemAdmin
          SystemAdmin
          300 Posts
          ACCEPTED ANSWER

          Re: Developer edition install broken on Indigo?

          ‏2012-07-17T16:07:53Z  in response to SystemAdmin
          Thanks, I'll add that info to the defect.
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: Developer edition install broken on Indigo?

    ‏2012-07-18T22:37:26Z  in response to SystemAdmin
    I was able to install successfully by downloading worklight_studio_wee_5.0.0.2.zip from FixCentral and using Help -> Install New Software... in a clean install of Eclipse Indigo.

    So either something was fixed in 5.0.0.2, or the problem is specific to the Marketplace install.
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: Developer edition install broken on Indigo?

    ‏2012-07-18T23:37:45Z  in response to SystemAdmin
    We're still investigating, but we have determined the issue is specific to the marketplace install. It is also specific to MacOS. Until this is resolved, you can work around this by using an alternative install method. You can go to:

    http://www.ibm.com/developerworks/mobile/worklight

    and click on "Download and Install". You will need to register/complete a short profile, and then you will see a page with two tabs. The first tab "Install" uses a marketplace-based install, but the second tab has "Alternative Install Option". You should be able to use either the P2 update site or the zip to install.

    Thanks,
    Nell
    • SystemAdmin
      SystemAdmin
      300 Posts
      ACCEPTED ANSWER

      Re: Developer edition install broken on Indigo?

      ‏2012-07-19T03:17:22Z  in response to SystemAdmin
      >> It is also specific to MacOS.

      Not true... I'm running on WinXP and the same problems exist. I will try the alternative install and see if it cleans this up.
      • SystemAdmin
        SystemAdmin
        300 Posts
        ACCEPTED ANSWER

        Re: Developer edition install broken on Indigo?

        ‏2012-07-19T03:55:12Z  in response to SystemAdmin
        It appears that the problem can be fixed on WinXP by following the advice of downloading the Studio plugin and doing the alternate install.
      • SystemAdmin
        SystemAdmin
        300 Posts
        ACCEPTED ANSWER

        Re: Developer edition install broken on Indigo?

        ‏2012-07-19T12:35:27Z  in response to SystemAdmin
        Thank you for reporting -- we have not seen it on the Windows 7 systems we tested, but we did not test XP specifically.
    • SystemAdmin
      SystemAdmin
      300 Posts
      ACCEPTED ANSWER

      Re: Developer edition install broken on Indigo?

      ‏2012-07-19T03:24:22Z  in response to SystemAdmin
      I seem to have spoken too soon. The install I did today using a fresh copy of eclipse indigo and the downloaded repository from FixCentral (5.0.0.2) worked for a while, and then started throwing exceptions. (can't locate the class org.mortbay.Jetty, and then the rich page editor started throwing an exception that it couldn't connect to localhost:0)

      The symptoms are a bit different, but it is still broken, and the problems still seem to be around the rich page editor. The funny thing is it was working for a while, and I can't think of anything I did between working and broken that would have altered the configuration.
      I see the same problem with the marketplace install on Windows 7 that I see with the marketplace install on MacOS. Could this be a 64 bit issue? All the systems I have tried have been 64 bit.

      On Windows this hasn't been an issue for me because I primarily use an IM based install which hasn't been giving me any problems.
      • SystemAdmin
        SystemAdmin
        300 Posts
        ACCEPTED ANSWER

        Re: Developer edition install broken on Indigo?

        ‏2012-07-19T17:00:18Z  in response to SystemAdmin
        Can you check your list of available update sites and see if http://marketplace.eclipse.org/repo/ is one of the available software sites (in preferences > Install/Update > Available Software Sites)?
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: Developer edition install broken on Indigo?

    ‏2012-07-24T18:50:24Z  in response to SystemAdmin
    I was able to successfully install with a clean install of Eclipse and the non-Marketplace version of Workplace.
    • SystemAdmin
      SystemAdmin
      300 Posts
      ACCEPTED ANSWER

      Re: Developer edition install broken on Indigo?

      ‏2012-08-02T14:38:41Z  in response to SystemAdmin
      I've been on vacation ... Since returning the install issues seem to have gone away. I have been able to to install from the marketplace with no issues. Looking at the bug I referenced earlier (https://bugs.eclipse.org/bugs/show_bug.cgi?id=379473), it looks like there was a problem where adding features from the marketplace would incorrectly update some Indigo classes to Juno leaving you in a mess. This has been fixed on the eclipse side. (https://bugs.eclipse.org/bugs/show_bug.cgi?id=385334)

      In any case, as far as I can tell, this is resolved.
      • SystemAdmin
        SystemAdmin
        300 Posts
        ACCEPTED ANSWER

        Re: Developer edition install broken on Indigo?

        ‏2012-08-02T14:41:04Z  in response to SystemAdmin
        That's correct -- the issue has been resolved on the marketplace side. Thanks, Nell