Topic
5 replies Latest Post - ‏2013-06-24T10:13:22Z by jafaeldon
SystemAdmin
SystemAdmin
7754 Posts
ACCEPTED ANSWER

Pinned topic Error during install Datastage 8.5 on Opensuse

‏2012-07-12T09:25:22Z |
Hi Dear all

some problems are blocking me to install DS on Opensuse

i am using Opensuse 12.1

and have IBM InfoSphere server

duing i was installing the server ,first i got this error "malloc: top chunk is corrupt" after i ran ./setup

then i did this "export MALLOC_CHECK_=4"

then i can perform ./setup

next i was informed to choice a link

http://linux-mvuo:8081/ISInstall
https://linux-mvuo:8444/ISInstall

i choiced http://linux-mvuo:8081/ISInstall ( i also tried https://linux-mvuo:8444/ISInstall )

i was directed web installation page

then got this error

Could not create the view: An unexpected exception was thrown.
java.lang.NullPointerException
at com.ibm.is.install.ui.rap.WizardFlowManager.init(WizardFlowManager.java:59)
at com.ibm.is.install.ui.rap.WizardFlowManager.<init>(WizardFlowManager.java:27)
at com.ibm.is.install.ui.rap.WizardFlowManager.getInstance(WizardFlowManager.java:34)
at com.ibm.is.install.atlasinstaller.ui.controller.WizardController.moveCurrent(WizardController.java:279)
at com.ibm.is.install.atlasinstaller.ui.View.createPartControl(View.java:93)
at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:371)
at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:230)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:594)
at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:312)
at org.eclipse.ui.internal.ViewPane.setVisible(ViewPane.java:545)
at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:185)
at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:265)
at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:64)
at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:478)
at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1268)
at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1221)
at org.eclipse.ui.internal.PartStack.showPart(PartStack.java:1620)
at org.eclipse.ui.internal.PartStack.createControl(PartStack.java:659)
at org.eclipse.ui.internal.PartStack.createControl(PartStack.java:585)
at org.eclipse.ui.internal.PartSashContainer.createControl(PartSashContainer.java:569)
at org.eclipse.ui.internal.PerspectiveHelper.activate(PerspectiveHelper.java:269)
at org.eclipse.ui.internal.Perspective.onActivate(Perspective.java:930)
at org.eclipse.ui.internal.WorkbenchPage.onActivate(WorkbenchPage.java:2494)
at org.eclipse.ui.internal.WorkbenchWindow$22.run(WorkbenchWindow.java:2933)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:66)
at org.eclipse.ui.internal.WorkbenchWindow.setActivePage(WorkbenchWindow.java:2914)
at org.eclipse.ui.internal.WorkbenchWindow.busyOpenPage(WorkbenchWindow.java:720)
at org.eclipse.ui.internal.Workbench$18.runWithException(Workbench.java:1065)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:32)
at org.eclipse.rwt.internal.lifecycle.UICallBackManager.addSync(UICallBackManager.java:119)
at org.eclipse.swt.widgets.Display$2.run(Display.java:649)
at org.eclipse.rwt.internal.lifecycle.UICallBackServiceHandler.runNonUIThreadWithFakeContext(UICallBackServiceHandler.java:455)
at org.eclipse.rwt.lifecycle.UICallBack.runNonUIThreadWithFakeContext(UICallBack.java:44)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:647)
at org.eclipse.ui.internal.StartupThreading.runWithWorkbenchExceptions(StartupThreading.java:55)
at org.eclipse.ui.internal.Workbench.busyOpenWorkbenchWindow(Workbench.java:1061)
at org.eclipse.ui.internal.Workbench.doOpenFirstTimeWindow(Workbench.java:1888)
at org.eclipse.ui.internal.Workbench.openFirstTimeWindow(Workbench.java:1824)
at org.eclipse.ui.internal.WorkbenchConfigurer.openFirstTimeWindow(WorkbenchConfigurer.java:188)
at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:790)
at org.eclipse.ui.internal.Workbench$25.runWithException(Workbench.java:1430)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:32)
at org.eclipse.rwt.internal.lifecycle.UICallBackManager.addSync(UICallBackManager.java:119)
at org.eclipse.swt.widgets.Display$2.run(Display.java:649)
at org.eclipse.rwt.internal.lifecycle.UICallBackServiceHandler.runNonUIThreadWithFakeContext(UICallBackServiceHandler.java:455)
at org.eclipse.rwt.lifecycle.UICallBack.runNonUIThreadWithFakeContext(UICallBack.java:44)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:647)
at org.eclipse.ui.internal.StartupThreading.runWithoutExceptions(StartupThreading.java:110)
at org.eclipse.ui.internal.Workbench.init(Workbench.java:1425)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2404)
at org.eclipse.ui.internal.Workbench.access$5(Workbench.java:2295)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:514)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:497)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:157)
at com.ibm.is.install.atlasinstaller.ui.Application.createUI(Application.java:266)
at org.eclipse.rwt.internal.lifecycle.EntryPointManager.createUI(EntryPointManager.java:92)
at org.eclipse.rwt.internal.lifecycle.RWTLifeCycle.createUI(RWTLifeCycle.java:228)
at org.eclipse.rwt.internal.lifecycle.RWTLifeCycle$UIThreadController.run(RWTLifeCycle.java:116)
at java.lang.Thread.run(Thread.java:810)
Pls kindly have a look and advise, Thank you
Updated on 2013-01-13T17:12:47Z at 2013-01-13T17:12:47Z by SystemAdmin
  • RobertDickson
    RobertDickson
    33 Posts
    ACCEPTED ANSWER

    Re: Error during install Datastage 8.5 on Opensuse

    ‏2012-07-12T09:56:17Z  in response to SystemAdmin
    Hi,

    According to http://www-01.ibm.com/software/data/infosphere/info-server/overview/requirements.html, OpenSUSE is not supported. Can you please retry on a supported os?

    Regards,
    Robert
    • SystemAdmin
      SystemAdmin
      7754 Posts
      ACCEPTED ANSWER

      Re: Error during install Datastage 8.5 on Opensuse

      ‏2012-07-13T09:58:19Z  in response to RobertDickson
      Hi Robert

      Thanks a lot for your quick response

      Yes i tried red had enterprise 6

      but still blocked by below poblem,

      INFO: Installation program will be running in this session, please do not close installation window until installation program completes.
      ENOENT: file or path Segmentation fault (core dumped)
      before i got this error i disabled selinux

      by vi /etc/selinux/config

      change SELINUX=enforcing to SELINUX=disabled
      • RobertDickson
        RobertDickson
        33 Posts
        ACCEPTED ANSWER

        Re: Error during install Datastage 8.5 on Opensuse

        ‏2012-07-13T12:29:21Z  in response to SystemAdmin
        Hi,

        Try downloading the IBM Support Assistant Lite (ISALite) for Information Server at http://www-01.ibm.com/support/docview.wss?uid=swg24022700. After you install, one option will be a prerequisites checker. It is possible you are missing a required component.


        Regards,
        Robert
      • SystemAdmin
        SystemAdmin
        7754 Posts
        ACCEPTED ANSWER

        Re: Error during install Datastage 8.5 on Opensuse

        ‏2013-01-13T17:12:47Z  in response to SystemAdmin
        hi,rwang:
        I also have this problem. when i install datastage 8.5 in redhat 6.2 , I got these messages:

        root@vmrhel is-suite# ./setup
        INFO: Installation program will be running in this session, please do not close installation window until installation program completes.
        ENOENT: file or path Segmentation fault (core dumped)
        root@vmrhel is-suite#

        Do you have solved it ?
        How did you solve it ?
        • jafaeldon
          jafaeldon
          1 Post
          ACCEPTED ANSWER

          Re: Error during install Datastage 8.5 on Opensuse

          ‏2013-06-24T10:13:22Z  in response to SystemAdmin

          I'm getting the same error. Were you able to resolve this issue?