Topic
  • 2 replies
  • Latest Post - ‏2013-01-17T16:40:46Z by SystemAdmin
Y800_H_P
Y800_H_P
5 Posts

Pinned topic websphere 7 JSF 1.2 issues with AjaxFacesContextFactory no actions work

‏2012-07-09T17:52:53Z |
Hello,
I have upgraded all the libraries and migrated everything to JSF 1.2, Webmodule 2.5 on Websphere 7.0 Now I face an issue where no action goes to the action classes. After a lot of pain, I realized that if I comment the render-kit-factory, the JSF takes an action and starts complaining about wrong methods etc. Again this works in Websphere 6.1. I don't get any errors. I verified the class loading policy to make sure that I had correct classes loaded in correct order.

Even if I added simple hello world kind of page, it will not take any action.

1) Upgraded JWL libraries like jsf-ibm.jar.
2) Upgraded the JSF to use 1.2 libraries.

What am I doing wrong?
<factory>
<faces-context-factory>
com.ibm.faces.context.AjaxFacesContextFactory</faces-context-factory>
<render-kit-factory>
com.ibm.faces.renderkit.AjaxRenderKitFactory
</render-kit-factory>
</factory>
Updated on 2013-01-17T16:40:46Z at 2013-01-17T16:40:46Z by SystemAdmin
  • Ravi_Hariharan
    Ravi_Hariharan
    8 Posts

    Re: websphere 7 JSF 1.2 issues with AjaxFacesContextFactory no actions work

    ‏2012-07-13T16:56:21Z  
    Try and ask IBM for the current base version of JWL and test.

    we had problem with a JWL comonent and they provide the new base version and it worked.
  • SystemAdmin
    SystemAdmin
    6420 Posts

    Re: websphere 7 JSF 1.2 issues with AjaxFacesContextFactory no actions work

    ‏2013-01-17T16:40:46Z  
    Try and ask IBM for the current base version of JWL and test.

    we had problem with a JWL comonent and they provide the new base version and it worked.
    Ravi, Do you know the new base version you used which worked on WAS7, and perhaps where you got this, and perhaps the version if WAS7 you were running on (ie: WAS 7.0.0.19)?
    Thanks, Stephen.