• 1 reply
  • Latest Post - ‏2012-07-09T20:55:36Z by SystemAdmin
5837 Posts

Pinned topic Updating locally installed V10.1 Info Center fails on Linux Ubuntu 12.04

‏2012-07-08T12:03:33Z |

I had successfully installed V10.1 Info Center on my Ubuntu 12.04 just after GA (doce_install).
I have just tried to update it because updates came on the 11th of June.
I followed the procedure :
- Stop the info center : sudo /etc/init.d/db2icdv101 stop
- Start it in standalone mode : sudo /opt/ibm/db2ic/V10.1/doc/bin/help_start
- The browser window opened, I chose the features to be updated (namely the en and fr features), and started the upgrade.
- Since the download was very slow, I checked on the next morning, and found everything installed, except a little round arrow was still turning on the left of the last feature...
- Got a message that clicking on Finish would start the initialization of the Information center. Clicked on finish... Nothing significant happened.
- Stop the information center : sudo /opt/ibm/db2ic/V10.1/doc/bin/help_stop
- Attempted to start the information center in shared mode... Failed.

The relevant part of doc/eclipse/workspace/.metadata/.log is attached.

A package similar to the initial doc would be far more convenient, rather than this slow and unreliable update process...

How can I repair my installation in order to be able to start and use my local IC at the latest documentation level ?

Thanks for your help!
Yves-Antoine Emmanuelli
Updated on 2012-07-09T20:55:36Z at 2012-07-09T20:55:36Z by SystemAdmin
  • SystemAdmin
    5837 Posts

    Re: Updating locally installed V10.1 Info Center fails on Linux Ubuntu 12.04


    I uninstalled/reinstalled the Information Center with doce_deinstall/doce_install (btw, why are these commands "deprecated" ? They are the only ones working properly...), and tried socalled automatic update. It failed (log attached).

    The main message is :
    java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini)

    Yves-Antoine Emmanuelli