Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
9 replies Latest Post - ‏2012-07-30T18:40:12Z by warpman666
warpman666
warpman666
9 Posts
ACCEPTED ANSWER

Pinned topic cvc-complex-type.2.4.a: Invalid content was found starting with element...

‏2012-07-05T01:33:15Z |
Hi people,

We have been searching for an answer to this, but without success. We are in the midst of porting some J2EE solutions we have developed running WAS6.1, enterprise edition, to WASCE3.0. We have been using Eclipse with the WASCE WTP Server Adapter. Our problem is that for even the simplest, vanilla EJB project, the openejb-jar.xml won't validate, giving us the following error :

Referenced file contains errors (jar:file:/D:/Apps/eclipse-jee-indigo-SR2-win32-x86_64/eclipse/dropins/wascewep/eclipse/plugins/org.apache.geronimo.st.schemas_3.0.0.jar!/v30/openejb-jar-2.2.xsd).

Has anyone overcome this issue? Any pointers will be appreciated, thanks!
Updated on 2012-07-30T18:40:12Z at 2012-07-30T18:40:12Z by warpman666
  • Shawn_Jiang
    Shawn_Jiang
    154 Posts
    ACCEPTED ANSWER

    Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

    ‏2012-07-09T05:08:49Z  in response to warpman666
    I can tell your OS is win 64bit and you are using Eclipse indigo sr2. Could you provide more info about this ?

    1, WAS CE version.
    2, WAS CE Eclipse plugin version.
    • warpman666
      warpman666
      9 Posts
      ACCEPTED ANSWER

      Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

      ‏2012-07-16T13:07:40Z  in response to Shawn_Jiang
      Hi Shawn, thanks for your reply.

      We are using WasCE, version 3.0.0.1, and the WASCE v3.0 Server Adapter Assembly Eclipse Plugin, version is 3.0.0-20120618-130145.

      Please let me know if you have any ideas!

      Regards,

      • bb
      • Shawn_Jiang
        Shawn_Jiang
        154 Posts
        ACCEPTED ANSWER

        Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

        ‏2012-07-20T08:11:38Z  in response to warpman666
        it seems I can't reply this thread due to the unknow server issue. try this simple message.
      • Shawn_Jiang
        Shawn_Jiang
        154 Posts
        ACCEPTED ANSWER

        Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

        ‏2012-07-20T08:15:42Z  in response to warpman666
        Please make sure you are using server 3002 because your plugin is for CE3002.
        • warpman666
          warpman666
          9 Posts
          ACCEPTED ANSWER

          Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

          ‏2012-07-20T13:20:59Z  in response to Shawn_Jiang
          Shawn,

          We are currently trying with the 3.0.0.2 CE version, along with the above mentioned plugin version.

          Our problem is really only when creating a plain EJB project. The open-ejb.jar file gives validation errors in Eclipe, and at deploy time in CE.
          • Shawn_Jiang
            Shawn_Jiang
            154 Posts
            ACCEPTED ANSWER

            Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

            ‏2012-07-20T15:10:40Z  in response to warpman666
            we've realized this and are working on a fix. Will provide the fix via the update site once we complete it. It would be in next week. Keep tuned.
            • warpman666
              warpman666
              9 Posts
              ACCEPTED ANSWER

              Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

              ‏2012-07-20T15:46:07Z  in response to Shawn_Jiang
              This is great news, thanks Shawn. Will follow up next week!
              • Shawn_Jiang
                Shawn_Jiang
                154 Posts
                ACCEPTED ANSWER

                Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

                ‏2012-07-25T01:42:21Z  in response to warpman666
                Hello,

                Check this technote[1] out. There's instruction to guide you to install the updated Eclipse plugin.

                [1]http://www-01.ibm.com/support/docview.wss?uid=swg21605858
                • warpman666
                  warpman666
                  9 Posts
                  ACCEPTED ANSWER

                  Re: cvc-complex-type.2.4.a: Invalid content was found starting with element...

                  ‏2012-07-30T18:40:12Z  in response to Shawn_Jiang
                  Shawn,

                  As per the technote, we re-installed the WEP. Everything works great now.

                  Many thanks for your help, this is deeply appreciated!

                  All the best,

                  • bb