Topic
4 replies Latest Post - ‏2012-11-21T14:17:52Z by SystemAdmin
Pozda
Pozda
2 Posts
ACCEPTED ANSWER

Pinned topic TS3310 Command Line Interface

‏2012-07-04T09:08:11Z |
Hello

I downloaded TS3310 Command Line Interface from https://www-01.ibm.com/support/docview.wss?uid=ssg1S4000981.

Any attempt to communicate with our TS3310 library failed with java error

java -jar TS3310CLI.jar -a 10.10.10.10 --viewCleaningCartridges -u user -p password
Exception in thread "main" java.lang.IllegalStateException: Scheme 'https' not registered.
at org.apache.http.conn.scheme.SchemeRegistry.getScheme(SchemeRegistry.java:71)
at org.apache.http.impl.conn.DefaultHttpRoutePlanner.determineRoute(DefaultHttpRoutePlanner.java:111)
at org.apache.http.impl.client.DefaultRequestDirector.determineRoute(DefaultRequestDirector.java:709)
at org.apache.http.impl.client.DefaultRequestDirector.handleResponse(DefaultRequestDirector.java:1051)
at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:482)
at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:820)
at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:754)
at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:732)
at com.ibm.tools.TS3310CLI.a(Unknown Source)
at com.ibm.tools.TS3310CLI.<init>(Unknown Source)
at com.ibm.tools.TS3310CLI.main(Unknown Source)

Does anybody know, where is problem?

Thanks
Martin
Updated on 2012-11-21T14:17:52Z at 2012-11-21T14:17:52Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    4779 Posts
    ACCEPTED ANSWER

    Re: TS3310 Command Line Interface

    ‏2012-11-13T21:36:51Z  in response to Pozda
    Hi.
    I have the same problem. Did you found the solution?
    marcinek
    • Pozda
      Pozda
      2 Posts
      ACCEPTED ANSWER

      Re: TS3310 Command Line Interface

      ‏2012-11-14T05:05:30Z  in response to SystemAdmin
      Hi

      Not yet. We have another TS3500 and for this library communication worsk perfectly.

      Martin
      • SystemAdmin
        SystemAdmin
        4779 Posts
        ACCEPTED ANSWER

        Re: TS3310 Command Line Interface

        ‏2012-11-14T14:49:37Z  in response to Pozda
        I managed to get it working. I disabled SSL on library's RMU.
        CLI works, but now I can not log on to Web interface.
        Each time I point my browser to http://mylibrary it gets redirected to https://mylibrary and get connection refused :-( I must have done something stupid and now I have to go to ether side of the city to run setup again or hack in over ssh if possible...
        marcinek
        • SystemAdmin
          SystemAdmin
          4779 Posts
          ACCEPTED ANSWER

          Re: TS3310 Command Line Interface

          ‏2012-11-21T14:17:52Z  in response to SystemAdmin
          It's me again.
          Regarding http to https redirect I mentioned few days ago - it's not library fault. It is the browsers trying to be hilier than a pope :-) Once such a browser "remebers" that it contacted a page through https it automatically switches to it even I put http prefix in the url. Clearing th history or switching to "private" mode helps.
          But there is one more thing about TS3310CLI tool - it can not load the tape to drive :-(
          Now I'm playing with itdt scripting which works nice, but I need to call it from host directly connected to the libray.