Topic
  • 3 replies
  • Latest Post - ‏2012-07-04T04:05:58Z by SystemAdmin
SystemAdmin
SystemAdmin
203 Posts

Pinned topic SQL0440N No authorized routine named...was found

‏2012-07-01T16:09:03Z |
Hi folks,

I've got InfoSphere Warehouse 9.7.3 and DB2 10.1 installed in my PC (both are 64-bit versions). I've designed a data mining flow to analyse a dataset (a table) stored in the DB2 database. However, every time I execute the mining flow, the following error will appear and the output cannot be generated.

SQL0440N No authorized routine named "IDMMX.BUILDCLASMODEL" of type "PROCEDURE" having compatible arguments was found.. SQLCODE=-440, SQLSTATE=42884, DRIVER=4.11.77 SQLSTATE=42884

An Intelligent Miner SQL Routine was not found.
Check if Intelligent Miner is correctly installed, and if the database is enabled for mining.

Execution failed.
It seems like there're some missing procedures which are necessary to perform the data mining process. Is there anyone having this problem before? I would appreciate for any experience shared.

Thanks in advance!

JL
Updated on 2012-07-04T04:05:58Z at 2012-07-04T04:05:58Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    203 Posts

    Re: SQL0440N No authorized routine named...was found

    ‏2012-07-02T02:25:16Z  
    Hi John,

    Pls check following:
    1. Whether Mining server has been installed on your server machine (Server package -> select Intelligent Miner in Data Server while install)
    2. Whether the database you are connecting has been enabled for Mining (Right click the database in Data Source Explorer and select "Enable the database for Data Mining)
    3. Whether the user you are using to connect the database have privilege to execute store procedures

    Thanks!
  • SystemAdmin
    SystemAdmin
    203 Posts

    Re: SQL0440N No authorized routine named...was found

    ‏2012-07-03T02:49:13Z  
    Hi John,

    Pls check following:
    1. Whether Mining server has been installed on your server machine (Server package -> select Intelligent Miner in Data Server while install)
    2. Whether the database you are connecting has been enabled for Mining (Right click the database in Data Source Explorer and select "Enable the database for Data Mining)
    3. Whether the user you are using to connect the database have privilege to execute store procedures

    Thanks!
    Hi Leung,

    Thanks so much for your prompt and kind reply. As you mentioned I think my problem is the mining server is missing. I'm working to resolving the problem now. I'll let you guys know if the problem is solved.
    Thanks again!
  • SystemAdmin
    SystemAdmin
    203 Posts

    Re: SQL0440N No authorized routine named...was found

    ‏2012-07-04T04:05:58Z  
    Hi John,

    Pls check following:
    1. Whether Mining server has been installed on your server machine (Server package -> select Intelligent Miner in Data Server while install)
    2. Whether the database you are connecting has been enabled for Mining (Right click the database in Data Source Explorer and select "Enable the database for Data Mining)
    3. Whether the user you are using to connect the database have privilege to execute store procedures

    Thanks!
    Thanks Leung! The problem with the mining server is solved and the mining flow can be executed successfully now.