Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
7 replies Latest Post - ‏2012-09-03T15:18:55Z by IdanAdar
K243_Wang_Yizhe
K243_Wang_Yizhe
1 Post
ACCEPTED ANSWER

Pinned topic [Solved] IBM Worklight 5.0 conflicts with ADT 20

‏2012-06-28T03:45:35Z |
Eclipse 3.7.2
ADT 20
Worklight lastest developer edition

After installing one by one, Worklight plugin is gone, left only configurations in preference.
Can IBM fix this as soon as possible?
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: IBM Worklight 5.0 conflicts with ADT 20

    ‏2012-06-29T03:55:06Z  in response to K243_Wang_Yizhe
    I'm having the same problem after updating Worklight and Android SDK today. I'm running Eclipse Java EE Indigo Service Release 2 on Mac OS X Lion. I really hope this gets fixed soon!
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: IBM Worklight 5.0 conflicts with ADT 20

    ‏2012-06-29T04:43:21Z  in response to K243_Wang_Yizhe
    It appears that the problem is resolved by completely uninstalling and reinstalling IBM Worklight Studio, Dojo Mobile Tools, and Rich Page Editor in Eclipse.
  • Gosh
    Gosh
    1 Post
    ACCEPTED ANSWER

    Re: IBM Worklight 5.0 conflicts with ADT 20

    ‏2012-07-07T18:19:41Z  in response to K243_Wang_Yizhe
    I just posted this in another thread, but maybe this will help:

    I also had a similar problem. The Android emulator requires an Oracle JDK. So if you're using an IBM JDK, it will give you errors. Next, you have to edit your eclipse.ini so it's pointing to the Oracle JDK javaw.exe. Add the line (use your directory):
    -vm "C:\Java\jre6\bin\javaw.exe"

    Finally, if you're dealing with Worklight Consumer or Enterprise Edition, and if you pointed to an Oracle JDK during the install process, than make sure to launch Worklight.cmd instead of eclipse.exe. Or, laucnh start > programs > IBM Software Delivery Platform > IBM Worklight Studio
  • rtimothy
    rtimothy
    4 Posts
    ACCEPTED ANSWER

    Re: IBM Worklight 5.0 conflicts with ADT 20

    ‏2012-07-27T13:53:26Z  in response to K243_Wang_Yizhe
    The root cause of this problem is that the ADT base bundle (new in ADT 20) began to export some of the same org.apache packages that Worklight also exports. In some cases, certain dependencies in the Worklight bundles will bind to the versions from ADT instead of the version we export. I've had luck uninstalling and then reinstalling the ADT plugins, also I've not had this fail (not to say that it can't fail) using the latest version of Worklight from the eclipse market place (as of July 25). We are currently working on a fix to resolve this issue completely.
    • SystemAdmin
      SystemAdmin
      300 Posts
      ACCEPTED ANSWER

      Re: IBM Worklight 5.0 conflicts with ADT 20

      ‏2012-07-27T14:13:40Z  in response to rtimothy
      As Tim said, a fix is in the works. However, in the meantime, if you have not installed yet, please install ADT after installing Worklight. This usually keeps the binding correct. Not ideal I know, but a workaround for the time being.
      • SystemAdmin
        SystemAdmin
        300 Posts
        ACCEPTED ANSWER

        Re: IBM Worklight 5.0 conflicts with ADT 20

        ‏2012-09-03T13:29:07Z  in response to SystemAdmin
        Hi Neil,

        I am sure I had this problem when I installed ADT after Worklight. I am about to try again from scratch - eclipse->work light->adt , so I will report on progress. Any news on the real fix?

        Cheers,

        Paul
  • IdanAdar
    IdanAdar
    49 Posts
    ACCEPTED ANSWER

    Re: IBM Worklight 5.0 conflicts with ADT 20

    ‏2012-09-03T15:18:55Z  in response to K243_Wang_Yizhe
    The fix exists in the latest release - IBM Worklight v5.0.0.3, so make sure you're downloading the correct version.

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform