Topic
  • 3 replies
  • Latest Post - ‏2012-06-25T09:22:24Z by SystemAdmin
KrishnaKandi
KrishnaKandi
12 Posts

Pinned topic unable to generate the code

‏2012-06-21T13:18:41Z |
Hi All,

I am unable to generate the code at the time of code generation. Workbench is giving me the error "com.ibm.was6.1" libraries are not found.

I am using RSA7.5.4 and WAS 7.0.

From the old posts, I got to know that at the runtime Workbench uses WAS6.1 libraries. I tried to install "tools for Webshpere 6.1 from the installation manager. But below is the error, I am facing.

Error during "complete" phase:
Eclipse p2 reconciler returned with error status=13, check for possible logs in D:\Programfile\IBM\SDP75\configuration for more information

Please find the log file also ..

Thanks,
Krishna Kishore.K
Updated on 2012-06-25T09:22:24Z at 2012-06-25T09:22:24Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    345 Posts

    Re: unable to generate the code

    ‏2012-06-21T13:57:32Z  
    Hi,

    Try running Installation Manager from the command line with the following parameter:

    IBMIM.exe -vmargs -Dcic.doNotReconcile=true

    .. which prevents IM failing due to reconcile errors.

    If that doesn't help then you could try to uninstall MDM Workbench, use Installation Manager to do whatever, then install MDM Workbench again.

    Hope that helps, Catherine.
  • KrishnaKandi
    KrishnaKandi
    12 Posts

    Re: unable to generate the code

    ‏2012-06-22T10:59:34Z  
    Hi,

    Try running Installation Manager from the command line with the following parameter:

    IBMIM.exe -vmargs -Dcic.doNotReconcile=true

    .. which prevents IM failing due to reconcile errors.

    If that doesn't help then you could try to uninstall MDM Workbench, use Installation Manager to do whatever, then install MDM Workbench again.

    Hope that helps, Catherine.
    Hi Catherine,

    Thanks for the replay.

    This time I am sucessful in installing the 'tools for WAS 6.1" but still I am facing the same exception while code genration.
    Please suggest.

    Thanks,
    Krishna Kishore.K
  • SystemAdmin
    SystemAdmin
    345 Posts

    Re: unable to generate the code

    ‏2012-06-25T09:22:24Z  
    Hi Catherine,

    Thanks for the replay.

    This time I am sucessful in installing the 'tools for WAS 6.1" but still I am facing the same exception while code genration.
    Please suggest.

    Thanks,
    Krishna Kishore.K
    Hi,

    Can you please post the workspace error log - that is the file .log in the folder .metadata in the workspace directory.

    Depending on which version of MDM Workbench you are using, you may have a workbench code generation log - that is a file named

    .metadata\.plugins\com.ibm.mdm.tools.models.codegen\mdmgen.log

    If you have one of those, please post as well.

    Thanks, Catherine.