Topic
30 replies Latest Post - ‏2012-08-28T13:41:55Z by SystemAdmin
RESTETS
RESTETS
27 Posts
ACCEPTED ANSWER

Pinned topic Need help with CICS Explorer and CICSPlex configuration

‏2012-06-20T18:42:00Z |
I'm testing the CICS 4.2 Developers Trial on a z/OS 1.11 system. After a bunch of trials and errors I managed to get Explorer to show the regions I want it to on the regions tab in the CICSplex Eplorer view. I'm using CICS Explorer 1.1.1.1. When I run the previous version of CICS Explorer V1.0.1.2 with CICS/TS V3.2 and I look at the same view I see a tree view. The top of the tree is my production plex name. When I click on the plus (+) sign to the left of my plex name I get a list of all of the regions that make up the plex as subordinate entries. This is good. What is bad is that this tree view isn't showing in the new version of CICS Explorer. I suspect I'm missing some configuration definition that would group my regions under the plex name but so far I haven't been able to figure out what I'm missing. If anyone understands what I'm missing here I'd appreciate your help. Thanks.
Updated on 2012-08-28T13:41:55Z at 2012-08-28T13:41:55Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    270 Posts
    ACCEPTED ANSWER

    Re: Need help with CICS Explorer and CICSPlex configuration

    ‏2012-06-27T11:59:26Z  in response to RESTETS
    Hi there,

    I think this is likely to be a CICS configuration problem. If you send me some service data (dave.nice@uk.ibm.com) I will have a look at see if I can work out what isn't coming back, but I think you will be best to head over to the CICS forum to get the right people involved in how to fix it. They might even know without seeing the service data.

    Dave
  • Dave_Key
    Dave_Key
    17 Posts
    ACCEPTED ANSWER

    Re: Need help with CICS Explorer and CICSPlex configuration

    ‏2012-06-27T12:59:55Z  in response to RESTETS
    Hi,

    Can I just get you to clarify something?

    When you said "this tree view isn't showing in the new version of CICS Explorer" do you mean there is no "CICSplex Explorer" tab or that the CICSplex and subordinate regions aren't appearing?

    If the latter, then is the CICSplex new?

    Cheers
    Dave
    • SM7M_subramanya_raju
      1 Post
      ACCEPTED ANSWER

      Re: Need help with CICS Explorer and CICSPlex configuration

      ‏2012-07-19T15:09:21Z  in response to Dave_Key
      bbbbbb
    • RESTETS
      RESTETS
      27 Posts
      ACCEPTED ANSWER

      Re: Need help with CICS Explorer and CICSPlex configuration

      ‏2012-07-19T15:37:57Z  in response to Dave_Key
      TEST
      • RESTETS
        RESTETS
        27 Posts
        ACCEPTED ANSWER

        Re: Need help with CICS Explorer and CICSPlex configuration

        ‏2012-08-10T12:07:25Z  in response to RESTETS
        For over a month now I've been trying to get support from someone on this web site to debug an issue I have with posting multiple paragraphs of information in a reply. I even have a draft of my post saved which won't post either. The web page keeps directing me to a page that shows that my request couldn't be displayed. On this error page is a link to contact support. I've done this a couple of times and I get a very nice email saying "Thank you for contacting us, blah, blah, blah." The email asked for additional info which I provided in my initial description of the problem. One of the emails have a CALLOWN Log Number 4755690. Does anyone in Web Support monitor these forums because I've tried multiple ways of asking for support and so far no help has been provided. Well, technically that's not 100% true. One time someone put a single line post on this message thread and then emailed me it was working. I tried post my response again but got redirected to the same error page. Does anyone have any suggestions how I can get someone to work with me on this issue?

        Thank you.
        • kevmeist
          kevmeist
          249 Posts
          ACCEPTED ANSWER

          Re: Need help with CICS Explorer and CICSPlex configuration

          ‏2012-08-10T12:30:34Z  in response to RESTETS
          Did you provide the service data that Dave Nice requested?

          Did you try the CICS forum as he suggested?

          The tree view DOES show up in CICS Explorer V1.1.1.0 as I am looking at it now.

          Try Dave Nice if you haven't already. IBM Hursley is very good at support, so not sure what is happening in your case.

          K
          • RESTETS
            RESTETS
            27 Posts
            ACCEPTED ANSWER

            Re: Need help with CICS Explorer and CICSPlex configuration

            ‏2012-08-10T13:08:17Z  in response to kevmeist
            Yes, Dave and I have been emailing each other outside of this forum. There are still a number of CICSPlex issues I'm having and Joe Winchester has offered to help me now. Thanks.
        • SystemAdmin
          SystemAdmin
          270 Posts
          ACCEPTED ANSWER

          Re: Need help with CICS Explorer and CICSPlex configuration

          ‏2012-08-10T13:44:01Z  in response to RESTETS
          Hey,

          Sorry you're having issues. Can I just clarify - the issue is with the developerWorks forum rather than CICS Explorer?

          Just want to make sure I understand before we start looking round to find people who might be able to help.

          Can you confirm exactly which browser you're using to do the posting? The forum seems to work OK for me in Chrome although it's not actually listed as one of their supported browsers.

          Thanks,

          Dave
          • RESTETS
            RESTETS
            27 Posts
            ACCEPTED ANSWER

            Re: Need help with CICS Explorer and CICSPlex configuration

            ‏2012-08-10T14:27:47Z  in response to SystemAdmin
            For the purpose of my postings today it was just to see if I could wake someone up in IBM who is responsible for supporting the web site that I've been having a problem and I'm not getting it resolved. The issue right now is that I'm trying to post something to the forum and when I click on the Post Message button I'm taken to a web page that says "The page you requested cannot be displayed". I'm using IE version 7.0.5730.13 on a Windows XP Pro Service Pack 3 on a Dell Optiplex 755.
    • RESTETS
      RESTETS
      27 Posts
      ACCEPTED ANSWER

      Re: Need help with CICS Explorer and CICSPlex configuration

      ‏2012-08-10T19:03:47Z  in response to Dave_Key
      In response to the posting dated Jun 27 by Dave Key... (note – in the text that follows drop the space between CICS and the four characters that follow it as I had to post it this way due to a forum web site bug)
      I'm on the CICS SM perspective. The tab in the upper left corner is labeled CMAS Explorer. Below the name on the tab is Server: CMSM. In the body of this area I see the name CICS CMSM (CICS CMSM). This is the name of the CMAS regions VTAM applid. There is a gray dash followed by a square made up of four boxes to the left of CICS CMSM

      I also have a tab on the left side (below the CMSAS Explorer tab) labeled CICSplex Explorer. This area also shows Server: CMSM. In the body of this area there is nothing. When I connect to my CICS 3.2 system the Server: changes to CMSP. I also now see the name of my plex on that system and in parenthesis after that name is (18/18). I think this is the number of regions in my plex. The CMAS Explorer tab reflects the same Server: CMSP and the body of the area shows CICS CMSP (CICS CMSP) which is the name of my CMAS on my production system.

      I need someone technical to help me determine what's missing when I'm connecting to my CICS/TS 4.2 Developers Trial plex that isn't letting me see the regions in the CICSplex Explorer tab.
      • Dave_Key
        Dave_Key
        17 Posts
        ACCEPTED ANSWER

        Re: Need help with CICS Explorer and CICSPlex configuration

        ‏2012-08-13T12:59:49Z  in response to RESTETS
        Hi,

        Thanks for the additonal information.

        From your description I believe you may be using the "SM Administration" perspective rather than the "CICS SM" perspective.
        It's fairly easy, in my personal opinion, to get confused in eclipse if the "shotcut bar" (the folder tab which shows your perspectives in the top right of the perspective) is too small (indicated by a >> symbol). If you drag the tab to the left to make it bigger I suspect it will show "SM Administration" as the selected perspective.

        The SM Administration perspective

        • The "SM Administration" perspective is a new perspective to display information related to the CICSPlex SM configuration (which is why the primary Explorer is the "CMAS Explorer") and some of the CPSM capabilities like Workload Management (which is why the CICSplex Explorer is there too).

        • The Server shown in both the "CMAS Explorer" and "CICSplex Explorer" panes is the Sysidnt of the the local CMAS to which the WUI Server (Explorer) is connected.

        • If the CICSplex shown in the "CICSplex Explorer" is sowing 18/18 then that implies that the Explorer has succesfully discovered the CICSplex and knows that all 18 of the 18 regions defined to the CICSplex are active.

        • If you hover over the CICSplex name you should see a "twisty" to indicate that there is more data, click on this and you should see the CICS regions as you expected.
        Getting back to the CICS SM perspective

        • To return to the CICSplex Explorer views as you expected to see them, you should only have to select the "CICS SM" perspective from the "shortcut bar" or use the to menu bar and select:

        • Window -> Open perspective -> CICS SM
        • Dave_Key
          Dave_Key
          17 Posts
          ACCEPTED ANSWER

          Re: Need help with CICS Explorer and CICSPlex configuration

          ‏2012-08-13T15:00:54Z  in response to Dave_Key
          Hi,

          I just re-read your post and wanted to add a little extra since I misssed some of what you were saying.

          If I have understood ths correctly, when you have connected at the Version 4.2 level you are seeing the CMAS (CMSM) in the "CMAS Explorer" view but nothing at all in the "CICSplex Explorer view". Whereas, when you connect to your 3.2 Production environment through CMAS CMSP you do see the production CICSplex and the regions within it.

          Based on this, I need to know a little bit more about your configuration as I would expect to see, at least, the name of the CICSplex that the WUI server has connected with.

          1. What CICSplex does the CMCI (WUI Server) region connect to?
          2. What other CICSplexes do you expect to see?
          3. Do you only have one CMAS and is this the Maintenance Point for the CICSplex(es)?
          4. Are there any messages in the CMAS or the WUI Server indicating a failure to conect to the CICSplex or other CMASs?

          If you have any other information about how you have set-up the CPSM configuration for this environment that would be useful too.

          You can contact me directly at dave_key@uk.ibm.com if that would help.

          Dave
        • RESTETS
          RESTETS
          27 Posts
          ACCEPTED ANSWER

          Re: Need help with CICS Explorer and CICSPlex configuration

          ‏2012-08-13T15:52:44Z  in response to Dave_Key
          Yes, I was on the SM Administrative perspective. I dragged the list of perspectives to the left so now I can see them all.

          Now I'm on the CICS SM perspective and logged on with the CICSPlex SM Data Interface Connection (if I try to log on with the CICS Management Interface connection I get a message that says my password has expired but that's another problem I'm having). After a successful logon to my 4.2 test system with the Data Interface Connection I don't see anything using the CICS SM perspective. Now, if I click on the SM Administration perspective, click on the plex name in the CMAS Explorer section I now see the various tabs are now populated (like CICSPlex Definitions, CICSplexes, and CMAS Details). Next I click on the CICS SM perspective and none of the things I have open show anything (like Tasks and Regions). If I go back to the SM Administration perspective and click on the CICSplex name in the CICSplex Definitions tab followed by refresh I go back to the CICS SM perspective and now I see what I expect to see in the Tasks and Regions tabs. What I'm not seeing however is the tree view in the CICSplex portion of my screen. There is nothing at all showing there.

          To answer your questions:
          1) There should only be a single plex called CICS CMSM (I had to add a space between CICS and CMSM due to a web site bug). There is a single WUI and a single CMAS which the other regions connect to.

          2) None

          3) Only a single CMAS and maintenace point

          4) No messages. The MAS regions seem to be connecting just fine.
          • Dave_Key
            Dave_Key
            17 Posts
            ACCEPTED ANSWER

            Re: Need help with CICS Explorer and CICSPlex configuration

            ‏2012-08-14T13:57:03Z  in response to RESTETS
            Hi,

            OK glad we've sorted the perspective.

            So, if I have got this correct, you can select a context of the CICSplex (CICS CMSM) by clicking on the CICSplex name in the "CMAS Explorer" and when you have done this you can see the Operational data for the regions in the CICSplex (Regions, Tasks etc.)

            Based on that I think we can be fairly confident that the CICS and CPSM aspects of the configuration are correct.

            Which leaves 2 things:

            1. The missing tree view in CICSplex Explorer for the CICSplex and regions we know are there from the "CMAS Explorer" set pf the Context
            2. The fact that you are unable to connect via the CMCI interface

            I'd like to know a bit more about the second of these since I would strongly recommend using the CMCI interface as it will give you significantly more capability than the CPSM Data Interface, not least of which is the CMCI allows SPI commands (SET, PERFORM etc.) to be performed rather than simply using the interface as Read-only.

            Could you also tell me exactly what level the Explorer is by going to "Help -> About the CICS Explorer" and making a note of the Version and Build

            Cheers
            Dave
            • kevmeist
              kevmeist
              249 Posts
              ACCEPTED ANSWER

              Re: Need help with CICS Explorer and CICSPlex configuration

              ‏2012-08-14T14:03:24Z  in response to Dave_Key
              Dave,

              You should note that there are some installations (mine included) where "mere programmers" do not get access to the CMCI view (we only get the "lesser" view). CMCI is restricted to the "systems programmers".

              Kevin
              • Dave_Key
                Dave_Key
                17 Posts
                ACCEPTED ANSWER

                Re: Need help with CICS Explorer and CICSPlex configuration

                ‏2012-08-14T15:23:48Z  in response to kevmeist
                Hi Kevin,

                Can I ask what the reasoning is behind the decision to use both interfaces?

                I would normally expect Security to be used to control the access to information but it is always very useful to understand where a different approach is being taken and, more importantly, the reasoning behind the approach.

                Cheers
                Dave
                • kevmeist
                  kevmeist
                  249 Posts
                  ACCEPTED ANSWER

                  Re: Need help with CICS Explorer and CICSPlex configuration

                  ‏2012-08-14T17:10:48Z  in response to Dave_Key
                  Hi Dave,

                  As I understand it, the sysprogs do not want to give us access to commands that could change system parameters (doesn't matter that I can use the SPI from within code). They have chosen to restrict programmers to CEDC access and the equivalent (I suppose) in Explorer. I've never seen the CMCI interface even.

                  Our installation, based on some of the PII data that we keep is being ratcheted down security wise more every day. Soon, we won't be able to do anything <g>.

                  Regards,

                  Kevin
            • RESTETS
              RESTETS
              27 Posts
              ACCEPTED ANSWER

              Re: Need help with CICS Explorer and CICSPlex configuration

              ‏2012-08-14T15:50:48Z  in response to Dave_Key
              I'm using CICS Explorer version 1.1.1.1 build 201205240100)
              • Dave_Key
                Dave_Key
                17 Posts
                ACCEPTED ANSWER

                Re: Need help with CICS Explorer and CICSPlex configuration

                ‏2012-08-15T16:18:43Z  in response to RESTETS
                I've regenerated my environment with CICS TS 4.2 and the same level of Explorer and it works without a problem.

                If you select the CICS SM "CICSplex Repositories" do you see anything? I'm just wondering whether the problem is with the tree generation. If so then I' suggest a re-install if you haven't already tried that!

                When you do that I'd recommend deleting the Explorer Workspace before re-installing.

                If you could send a screen shot (dave_key@uk.ibm.com) there might be something there too .. especially one of the SM Administration and one of the CICS SM perspectives, plus the service data.

                Cheers
                Dave
                • RESTETS
                  RESTETS
                  27 Posts
                  ACCEPTED ANSWER

                  Re: Need help with CICS Explorer and CICSPlex configuration

                  ‏2012-08-15T18:45:02Z  in response to Dave_Key
                  I just upgraded my CICS Explorer to 1.1.1.2 build id: 201208141736.

                  Dave - I emailed you the doc I think you asked me for along with some questions.
                • kevmeist
                  kevmeist
                  249 Posts
                  ACCEPTED ANSWER

                  Re: Need help with CICS Explorer and CICSPlex configuration

                  ‏2012-08-20T11:20:10Z  in response to Dave_Key
                  Pardon me butting in here......BUT.....deleting a workspace (although understandable) gives rise to many other problems, such as user altered configurations etc.

                  A suggestion would be to allow within CICS Explorer (RD/z would be nice also) a date driven/manual function that would allow for export of a workspace to "somewhere" else. Then, an import facility for restoring that workspace (maybe to a different name even?) to match it. Typically, once a user has setup their "running" version of Explorer and tailored it to their needs.....time goes on and you forget what you did over the prior "x" months. Reproducing your working environment manually (if you delete the workspace) is a royal PITA.

                  With the export/import, users can keep known working configurations (over releases of CICS Explorer and just for "safety" sake).

                  Regards,

                  Kevin
                  • SystemAdmin
                    SystemAdmin
                    270 Posts
                    ACCEPTED ANSWER

                    Re: Need help with CICS Explorer and CICSPlex configuration

                    ‏2012-08-28T12:29:12Z  in response to kevmeist
                    Hi Kevin,

                    Thanks for your comments about deleting workspaces.

                    We are aware that users would find it useful to be able to capture all of the customizations they've made - these are wide ranging; new perspectives, column setups for views, connections, credentials, etc.

                    We are thinking about ways to allow these to be manipulated and shared but there's nothing on the immediate horizon. We use the Eclipse preference system almost exclusively for this data so it's quite well embedded into the workspace.

                    I personally wouldn't delete my workspace (even if someone asked me to) - I would just rename it. Particularly I guess what Dave Key was suggesting was to try with a fresh workspace as a troubleshooting step. Renaming the workspace and trying with a brand new one would be just as good as a diagnostic step.

                    Dave
                    • kevmeist
                      kevmeist
                      249 Posts
                      ACCEPTED ANSWER

                      Re: Need help with CICS Explorer and CICSPlex configuration

                      ‏2012-08-28T13:00:23Z  in response to SystemAdmin
                      Hi Dave,

                      When I commented before, I was thinking more along the lines of an "CICS Explorer Admin" (however you define that) setting up a set of perspectives/views for others to use when they start using a specific release of CICS Explorer (*onto a network drive for others to use*).

                      I also install RD/z here, but our PC Support folks roll out each release. They insist on doing this (at least currently) by replacing the user's hard drive with a new one. The PCs here are locked down pretty tight with us developers only having access to a single folder and it's sub-folders.

                      So, maybe some thought could be given to an "admin" type of CICS Explorer user that can setup all sorts of perspectives/views for other "mere mortal" CICS Explorer users to "inherit". The Push To Client feature of RD/z (for the most part) works well...I do have one issue with that (subject of an SR currently) but maybe CICS Explorer could inherit some of that functionality?

                      Regards,

                      Kevin
                      • SystemAdmin
                        SystemAdmin
                        270 Posts
                        ACCEPTED ANSWER

                        Re: Need help with CICS Explorer and CICSPlex configuration

                        ‏2012-08-28T13:41:55Z  in response to kevmeist
                        Hi Kevin,

                        Yes - that idea makes sense. One way to do that (perhaps what you do already) is just to run up CICS Explorer, set everything up, and bang the workspace out to users as well as the install. Not ideal, though. Also that won't work with Web Start because the workspace isn't provided with Web Start.

                        Because we use the underlying preferences systems there is the option of using plugin_customization.ini files to pre-seed preferences with default values, however this is a bit complex for your average person and we do sometimes need to change some of the internal names for things which could cause problems mid-release.

                        So - yes, we're aware this is a problem :-)

                        Dave
  • StewartFrancis
    StewartFrancis
    5 Posts
    ACCEPTED ANSWER

    Re: Need help with CICS Explorer and CICSPlex configuration

    ‏2012-08-21T16:15:56Z  in response to RESTETS
    Hi Rick,

    From a look at what you're experiencing, I'm going to have a bit of a shot in the dark about what's going on with your setup.

    There's a WUI setup guide in the infocenter here which describes some system parameters you'll need to set:

    http://pic.dhe.ibm.com/infocenter/cicsts/v4r2/index.jsp?topic=%2Fcom.ibm.cics.ts.installation.doc%2Ftopics%2Fdfha173.html

    In particular, if you're using the SM Data Connection, you'll need to have set up the DEFAULTCMASCTXT in order for the connection to work, otherwise you'll experience symptoms which are similar to the ones you've described. Have a look at your WUI startup JCL and see if those parameters are properly specified.

    In the event that this doesn't help, i'd like to take a look at your CICS Explorer service data, to see if I can determine what problems CICS Explorer is experiencing. To collect your service data please follow this outline:

    http://www-01.ibm.com/support/docview.wss?uid=swg21385861

    To send me the service data, you can attach it to this thread, or you can respond to me directly by email - I've sent you an email address with my contact details if you'd prefer to share data that way instead.

    Thanks,

    Stew
    CICS Explorer Development
    • RESTETS
      RESTETS
      27 Posts
      ACCEPTED ANSWER

      Re: Need help with CICS Explorer and CICSPlex configuration

      ‏2012-08-21T17:28:54Z  in response to StewartFrancis
      I'm using the Data Interface Connection because if I try to log on with the Management Interface Connection I get "Password expired" but I can log on to the DIC with the same password and it works. This is another problem I'm experiencing.

      Here's what I'm using for the WUI on the EYUWUI DD statement:
      DEFAULTMENU(EYUSTARTMENU)
      DEFAULTCMASCTXT(TESTCMSM)
      DEFAULTCONTEXT(TESTCMSM)
      DEFAULTSCOPE(TESTCMSM)
      TCPIPHOSTNAME(this info intentionally removed)
      TCPIPPORT(49004)
      TCPIPSSL(YES)
      TCPIPSSLCERT(this info intentionally removed)
      CMCIPORT(49003)

      Stew - I haven't received your email.
      • StewartFrancis
        StewartFrancis
        5 Posts
        ACCEPTED ANSWER

        Re: Need help with CICS Explorer and CICSPlex configuration

        ‏2012-08-22T09:06:51Z  in response to RESTETS
        Hi Rick, you should have my email now.

        Stew
  • StewartFrancis
    StewartFrancis
    5 Posts
    ACCEPTED ANSWER

    Re: Need help with CICS Explorer and CICSPlex configuration

    ‏2012-08-23T09:42:51Z  in response to RESTETS
    Hi Rick,

    From your trace data, it looks like your DEFAULTCMASCTXT parameter isn't set up correctly on your WUI server.

    Try changing it to CICSCMSM

    Stew
    • RESTETS
      RESTETS
      27 Posts
      ACCEPTED ANSWER

      Re: Need help with CICS Explorer and CICSPlex configuration

      ‏2012-08-23T12:16:39Z  in response to StewartFrancis
      Stew,

      It's a beautiful thing!!! Thank you so much! It looks like it's working now. I was thinking it would be something simple but with my very limited knowledge of the product I didn't know where to look. If I had been comfortable with leaving the names of objects as they are in my production system then this issue wouldn't have ever arisen. We've got a perfectly working plex now. We've had some issues in the past however with a test system getting crossed up with our production system and I didn't want that to happen again so I changed the name of the plex to prevent that.
      • RESTETS
        RESTETS
        27 Posts
        ACCEPTED ANSWER

        Re: Need help with CICS Explorer and CICSPlex configuration

        ‏2012-08-23T13:04:14Z  in response to RESTETS
        OK, now that the original issue has been solved maybe someone can explain why when I log on to CICS Explorer with a Data Interface Connection I connect just fine but if I try to connect with a Management Interface Connection I get message IZE0106E Connect failed with error "Password expired".
        I'm using the same password in both cases. What's the difference?