Topic
  • 2 replies
  • Latest Post - ‏2012-06-21T06:20:30Z by SystemAdmin
SylviaValentina
SylviaValentina
3 Posts

Pinned topic CMS : URL for already executed reports

‏2012-06-20T16:17:34Z |
Hi All,

my client is implementing Cognos Mashup Service and is trying to call via CMS already executed reports as the actual execution takes a long time which the client wants to avoid. In the clients environment nearly all reports are prerendered via overnight batch.

Thanks in advance for any input.
Updated on 2012-06-21T06:20:30Z at 2012-06-21T06:20:30Z by SystemAdmin
  • KCamp
    KCamp
    20 Posts

    Re: CMS : URL for already executed reports

    ‏2012-06-20T16:40:28Z  
    Assuming you're using the REST interface, append &VERSION=LATEST to the end. However, to be able to make pre-run versions accessible to CMS, you must go the report in Cognos Connect, click the properties button, go to the settings tab, and under Advanced enabled "enhanced features in saved outputs". After the next overnight batch, the report should be accessible via CMS
  • SystemAdmin
    SystemAdmin
    217 Posts

    Re: CMS : URL for already executed reports

    ‏2012-06-21T06:20:30Z  
    • KCamp
    • ‏2012-06-20T16:40:28Z
    Assuming you're using the REST interface, append &VERSION=LATEST to the end. However, to be able to make pre-run versions accessible to CMS, you must go the report in Cognos Connect, click the properties button, go to the settings tab, and under Advanced enabled "enhanced features in saved outputs". After the next overnight batch, the report should be accessible via CMS
    Hello KCamp,

    When viewing a saved report using CMS as version latest should charts show? I ask because I am attempting to show saved reports and everything is working fine apart from any charts.

    I attached a screenshot showing a sample report with the chart issue I am experiencing. Any input would be appreciated. When viewed in JSON and LDX the charts contain data.

    I am running Cognos 10.1.1 (single server installation) on Windows 2008 R2.

    Thanks
    Malcolm