Topic
  • 2 replies
  • Latest Post - ‏2012-06-21T18:28:13Z by drogo
drogo
drogo
8 Posts

Pinned topic ITCAM WebSphere + J2EE MS 6.1 FP Install Failure

‏2012-06-20T11:10:13Z |
I have successfully installed the 6.1 MS with FP 5 + 6 in one environment as root (DB2 9.5 / WAS 7 ND on AIX 6). We are trying to get the MS installed in our production env same configuration. The base product installs fine and we can bring up the app. Try to install FP5 as root and it fails. silientUpdate properties are correct for the ND env, prepareInstall is successful.

FP 5 Install fails with the following error:

Jun 18, 2012 9:04:09 PM), update, stdout:
(Jun 18, 2012 9:04:23 PM), update, stdout: ADMA5017I: Uninstallation of ITCAM_Application started.
(Jun 18, 2012 9:04:23 PM), update, stdout: ADMA5104I: The server index entry for WebSphere:cell=g01acxapp003Cell,node=g01acxapp003Node is updated successfully.
(Jun 18, 2012 9:04:23 PM), update, stdout: ADMA5102I: The configuration data for ITCAM_Application from the configuration repository is deleted successfully.
(Jun 18, 2012 9:04:23 PM), update, stdout: ADMA5011I: The cleanup of the temp directory for application ITCAM_Application is complete.
(Jun 18, 2012 9:04:23 PM), update, stdout: ADMA5106I: Application ITCAM_Application uninstalled successfully.
(Jun 18, 2012 9:04:23 PM), update, stdout: ADMA5011I: The cleanup of the temp directory for application ITCAM_Application is complete.
(Jun 18, 2012 9:04:23 PM), update, stdout: ADMA5069E: The installation of application ITCAM_Application failed. This application was in the middle of a full update and therefore is uninstalled from the configuration session. Discard your current configuration session immediately to recover the application. Do not save changes to the WebSphere Application Server configuration repository. The application is not uninstalled from this repository. Until the current configuration session is discarded you do not see this application in the current session.
(Jun 18, 2012 9:04:23 PM), update, stdout: Updating application ITCAM_Application failed. Error info: com.ibm.ws.scripting.ScriptingException: WASX7418E: Application update for ITCAM_Application failed: see previous messages for details.
(Jun 18, 2012 9:04:23 PM), update, stdout: while executing
(Jun 18, 2012 9:04:23 PM), update, stdout: "$AdminApp install $ear_location $options"
(Jun 18, 2012 9:04:23 PM), update, stdout: ITCAM-ERROR
(Jun 18, 2012 9:04:23 PM), update, stdout: WASX7309W: No "save" was performed before the script "/opt/IBM/itcam/WebSphere/MS/update/tmp/prepare/updateEar.jacl" exited; configuration changes will not be saved.
(Jun 18, 2012 9:04:34 PM), update, The child process closed streams, waiting 1,754 seconds for process to terminate
(Jun 18, 2012 9:04:34 PM), update, Command exited with code 22
(Jun 18, 2012 9:04:34 PM), update, Action failed: {0}com.ibm.wsam.update.exception.UpdateException: Failed to update application ITCAM_Application with EAR /opt/IBM/itcam/WebSphere/MS/lib/octigate-was.ear
at com.ibm.wsam.update.action.updateve.UveEffectPerformer.wasPerfom(UveEffectPerformer.java:259)
at com.ibm.wsam.update.action.updateve.UveEffectPerformer.perform(UveEffectPerformer.java:101)
at com.ibm.wsam.update.controller.ControllerBase.perform(ControllerBase.java:53)
at com.ibm.wsam.update.controller.EffectController.execute(EffectController.java:76)
at com.ibm.wsam.update.controller.UpdateController.install(UpdateController.java:506)
at com.ibm.wsam.update.controller.UpdateController.execute(UpdateController.java:401)
at com.ibm.wsam.update.is.wizard.action.InstallUpdateAction.execute(InstallUpdateAction.java:27)
at com.installshield.wizard.RunnableWizardBeanContext.run(Unknown Sou

Any idea what the issue could be?

Steve Drogo
Updated on 2012-06-21T18:28:13Z at 2012-06-21T18:28:13Z by drogo
  • gulfsoft
    gulfsoft
    20 Posts

    Re: ITCAM WebSphere + J2EE MS 6.1 FP Install Failure

    ‏2012-06-21T01:48:21Z  
    It looks like you left out the important part of the log file (or maybe the editor ate it). The part you posted appears to begin after the error was encountered and the installer began uninstalling. Maybe if you attach the file it might work better, or try some other formatting?

    Frank

    We can make Tivoli software work for you!www.gulfsoft.com
  • drogo
    drogo
    8 Posts

    Re: ITCAM WebSphere + J2EE MS 6.1 FP Install Failure

    ‏2012-06-21T18:28:13Z  
    Able to get FP 5+6 installed using wassrvr. Failed the first time, needed to give wassrvr write authority to Octigate and then FP installed.