Topic
8 replies Latest Post - ‏2012-10-01T18:48:04Z by SystemAdmin
thompsam
thompsam
4 Posts
ACCEPTED ANSWER

Pinned topic "Getting "Error saving password" when trying to create a new ICA Connection

‏2012-06-19T19:29:48Z |
I've installed ICA Studio installed on Windows 7 and everything seems to be working nicely. However, anytime I try to create an ICA Server connection file, when I try to save the the file, I get 2 dialog boxes that pop up. The first,has an "Error saving password" message and the second states "The configuration file has been changed outside of the editor. Do you want to load the changes? Regardless of my answer to the second question, the connection file doesn't get saved properly as when I try to use the connection during an export operation, I get errors because of the missing password, I thought it my be the location of my workspace, but no, I created a brand new workspace with nothing in it and still get the above error when I try to save this file. No other diagnostic information is provided.

Anyone else ever seen this error?
Sam Thompson
Updated on 2012-10-01T18:48:04Z at 2012-10-01T18:48:04Z by SystemAdmin
  • bfoyle
    bfoyle
    60 Posts
    ACCEPTED ANSWER

    Re: "Getting "Error saving password" when trying to create a new ICA Connection

    ‏2012-06-19T21:24:14Z  in response to thompsam
    Yes, I've gotten this error when I installed ICA Studio on a remote machine using one user and then logged in with another user and used ICA Studio and tried to create or edit the connection. I'm guessing it's some sort of permissions issue in the workspace but I couldn't figure it out by giving appropriate permissions at the file store. Ultimately, I just logged back in with that original user and everything worked fine.

    bf
  • thompsam
    thompsam
    4 Posts
    ACCEPTED ANSWER

    Re: "Getting "Error saving password" when trying to create a new ICA Connection

    ‏2012-06-20T13:13:50Z  in response to thompsam
    Yea, the error seemed like a Linux permissions problem. Thing is, this is on Windows 7 and I'm using the same Windows user that was used during the install. The other weird thing is that other files in the workspace can be shed without issue. Where does ICA Studio save the password information? On a colleague's system, when he saves the connection file, the password doesn't appear to be saved in the connection's icaconfig file. I'm thinking the issue is with the file where the ICA admin password is being saved.

    Sam Thompson
    • bfoyle
      bfoyle
      60 Posts
      ACCEPTED ANSWER

      Re: "Getting "Error saving password" when trying to create a new ICA Connection

      ‏2012-06-20T14:14:15Z  in response to thompsam
      We've opened it as a defect and are researching it. Just for more information, when you installed on windows 7 did you run the install "as administrator" or just with the normal user privileges?
  • thompsam
    thompsam
    4 Posts
    ACCEPTED ANSWER

    Re: "Getting "Error saving password" when trying to create a new ICA Connection

    ‏2012-06-20T15:58:19Z  in response to thompsam
    I installed it as normal user. I also tried to install it as you suggested, as administrator and got the same result. I did finally figure out the mystery. I was installing this on a VMWARE Windows 7 image and run my VMWARE image with sharing of folders turned on. Just to try it, I turned folder sharing off and poof, I was able to save the file. When I slicked the save icon, I I got prompted with a message stating "A new master password has been created. Password recover can be enabled by providing additional information. Would you like to do so now?" I followed the dialog and when finished, I was able to save the connection file. So after I did this, I reenabled sharing and tried saving a new connection file and once again get the "A new master password has been created. Password recover can be enabled by providing additional information. Would you like to do so now?" message. I completed the dialog and it still worked even though VMWARE folder sharing was turned on.

    Very strange...thanks for trying to help, I appreciate it.
    Sam
    • geoff@languageware
      geoff@languageware
      1 Post
      ACCEPTED ANSWER

      Re: "Getting "Error saving password" when trying to create a new ICA Connection

      ‏2012-07-16T08:25:23Z  in response to thompsam
      Sam

      The way Eclipse stores paswords (as used by the icaconfig file editor) it does not work with VMWare file sharing. If you are running on a VMWare image, turn off file sharing.

      Geoff
      • thompsam
        thompsam
        4 Posts
        ACCEPTED ANSWER

        Re: "Getting "Error saving password" when trying to create a new ICA Connection

        ‏2012-07-17T15:12:39Z  in response to geoff@languageware
        Geoff, I'm working with another IBMer who is having the the problem with Windows 7. Its a clean install of ICA Studio V3 that was downloaded from the Software XL site. He is getting the same error I reported above and it running this on Windows 7 on a thinkpad without VMWARE involved. Any advice on how to solve this problem.

        Sam
        • bfoyle
          bfoyle
          60 Posts
          ACCEPTED ANSWER

          Re: "Getting "Error saving password" when trying to create a new ICA Connection

          ‏2012-08-27T14:48:38Z  in response to thompsam
          There is now a fixpack out for ICA Studio, can you have the person in the clean environment update to the fixpack and let us know if they are still getting the error?
          • SystemAdmin
            SystemAdmin
            197 Posts
            ACCEPTED ANSWER

            Re: "Getting "Error saving password" when trying to create a new ICA Connection

            ‏2012-10-01T18:48:04Z  in response to bfoyle
            I have the same environment - Thinkpad 64bit with Windows7. I have ICA Studio installed as Administrator and applied the fixpack. However facing the same password save issue.