Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
2 replies Latest Post - ‏2012-06-20T06:02:22Z by vin.app
vin.app
vin.app
2 Posts
ACCEPTED ANSWER

Pinned topic Getting error while adding new adapter in Run Configuration

‏2012-06-19T17:17:54Z |
Getting error while adding new adapter in Run Configuration. Have attached the screen shot as well

Eclipse version is 3.7.2
Worklight version is 4.2.2
Below is the exception:

ENTRY org.eclipse.jface 4 2 2012-06-19 21:55:18.178
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
!STACK 0
java.lang.IllegalArgumentException: Path for project must have only one segment.
at org.eclipse.core.runtime.Assert.isLegal(Assert.java:63)
at org.eclipse.core.internal.resources.WorkspaceRoot.getProject(WorkspaceRoot.java:184)
at com.worklight.studio.plugin.composites.ProjectAdapterComposite.updateAdapterNameCombo(ProjectAdapterComposite.java:88)
at com.worklight.studio.plugin.composites.ProjectAdapterComposite.projectSelected(ProjectAdapterComposite.java:57)
at com.worklight.studio.plugin.composites.ProjectComposite$1.widgetSelected(ProjectComposite.java:74)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:240)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:774)
at com.worklight.studio.plugin.composites.ProjectComposite.selectProject(ProjectComposite.java:43)
at com.worklight.studio.plugin.launch.deploy.adapters.DeployAdapterLaunchConfigurationTab.initializeProjectFromConfiguration(DeployAdapterLaunchConfigurationTab.java:63)
at com.worklight.studio.plugin.launch.deploy.adapters.DeployAdapterLaunchConfigurationTab.initializeFrom(DeployAdapterLaunchConfigurationTab.java:52)
at org.eclipse.debug.ui.AbstractLaunchConfigurationTabGroup.initializeFrom(AbstractLaunchConfigurationTabGroup.java:86)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupWrapper.initializeFrom(LaunchConfigurationTabGroupWrapper.java:194)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.displayInstanceTabs(LaunchConfigurationTabGroupViewer.java:751)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer$8.run(LaunchConfigurationTabGroupViewer.java:623)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.inputChanged(LaunchConfigurationTabGroupViewer.java:640)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.setInput0(LaunchConfigurationTabGroupViewer.java:602)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.setInput(LaunchConfigurationTabGroupViewer.java:578)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog.handleLaunchConfigurationSelectionChanged(LaunchConfigurationsDialog.java:941)
at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog$3.selectionChanged(LaunchConfigurationsDialog.java:560)
at org.eclipse.jface.viewers.StructuredViewer$3.run(StructuredViewer.java:888)
  • IdanAdar
    IdanAdar
    288 Posts
    ACCEPTED ANSWER

    Re: Getting error while adding new adapter in Run Configuration

    ‏2012-06-20T04:32:40Z  in response to vin.app
    Hi Vin,

    Worklight 4.2.x was not tested on Eclipse Classic - for v4.2 we recommend Eclipse 2JEE.
    Have you tried running the developer edition, license-free, Worklight v5.0 on Eclipse Classic? v5.0 was certified for this version of Eclipse.
    • vin.app
      vin.app
      2 Posts
      ACCEPTED ANSWER

      Re: Getting error while adding new adapter in Run Configuration

      ‏2012-06-20T06:02:22Z  in response to IdanAdar
      Hi IdanAdar,

      It doesn't work when we right click on the project, select Run Configuration and try to create a new "Deploy Worklight Adapter" manually.

      Howeever, it did work when we select from Run menu. Run --> Run As ---> Deploy WorkLight Adapter. In this case it created a new "Worklight Adapter". So I am able to deploy and test it.

      Thanks a lot.